No announcement yet.

Catalyst 9.9 + Left4Dead (Steam) using WINE Results in Flickering

  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 9.9 + Left4Dead (Steam) using WINE Results in Flickering

    Hello there fellow ATI'rs. My apologies for posting on this forum, as I know this isn't a WINE support forum, but think that it's relevant to the ATI drivers themselves, so I figured this was the best choice.

    The Goal:
    * Getting Left4Dead to work in WINE

    The Problem:
    * When I get "in game" there is significant flickering (many flickers per second). -- NOTE that the menus work fine, as does the loading screen, it's not until the in-game portion is loaded that the flickering begins.
    * (also I have no audio/sound in this game, but that's neither here nor there)

    An important point to note is that I have the following games already working:
    * Warcraft III, Starcraft, Flatout2, Supreme Commander - Forged Alliance, etc. -- this tells me that there's something "missing" in the current ATI driver which is causing this Left4Dead issue?

    Here's my config:
    * Ubuntu 9.04 Jaunty
    * ATI Radeon (01:00.0 VGA compatible controller: ATI Technologies Inc RV770 [Radeon HD 4870])
    * Latest fglrx driver's from ATI (Catalyst 9.9)
    * Wine version 1.1.28 (also tried 1.1.27 & 1.1.30)

    I've posted a similar message on the WineHQ site ( : Thread="October 1st 2009, 14:28"), and someone has made suggestions in fiddling with ATI driver settings. Could someone from ATI please confirm that this is the correct route to take?


  • #2
    Did you enable vsync (quality mode) in amdcccle?


    • #3
      Originally posted by Kano View Post
      Did you enable vsync (quality mode) in amdcccle?
      Thanks for the quick reply Kano.

      I just tried turning Vsync from (OFF, unless app specifies) to ALWAYS ON. This didn't help.

      To describe the flickering a little better, it's ALMOST like tearing, but just a "black screen" flicker. The entire screen goes black several times per second, interleaving with the actual game image.


      • #4
        Did you disable the film effect in L4D?