Announcement

Collapse
No announcement yet.

Abysmal compositing performance with VSync enabled

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Abysmal compositing performance with VSync enabled

    I had to watch two videos at once with mplayer (to visually compare them). Doing that revealed that fglrx is *slower* than molasses when having two opengl apps run at the same time with VSync enabled in a compositing environment (KDE 4).

    So I tried running several instances of glxgears at once. Even with just two, the lag becomes intolerable. Add a third, and you feel like running Windows Vista on a 486.

    Disabling VSync makes everything super-fluid again.

    Is this normal and will we have to live with it? It sucks.

  • #2
    I had 13 glxgears windows running with compositing (compiz-fusion) and no lags with VSYNC (in compiz) enabled!

    tweak your cpu-scheduler / CFS and probably switch to compiz ?

    Comment


    • #3
      I just tested this as well and get the fps drop with only two glxgears running if Vsync is set in amdcccle. In compiz settings everything is fine.

      Comment


      • #4
        Originally posted by kernelOfTruth View Post
        I had 13 glxgears windows running with compositing (compiz-fusion) and no lags with VSYNC (in compiz) enabled!
        Not in Compiz. That doesn't work with fglrx anyway. You have to enable it in CCC (amdcccle).

        Comment


        • #5
          Originally posted by RealNC View Post
          Not in Compiz. That doesn't work with fglrx anyway. You have to enable it in CCC (amdcccle).
          found it & confirmed !

          can this be fixed with the official Catalyst 9.10 ?

          Many thanks in advance

          Comment

          Working...
          X