Announcement

Collapse
No announcement yet.

fglrx Problem or My Problem?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx Problem or My Problem?

    I'm pretty new at Linux. I just upgraded my machine with an ATI X1650 Pro. I planned to switch over to Linux, but I have had problem after problem with the ATI drivers. I tried Ubuntu Edgy, Feisty Fawn, Sabayon, finally to conclude that it's because of the ATI drivers that I can't get desktop acceleration to work.
    Now I also can not run Google Earth or Sketchup, or Cedega, because OpenGL support is not detected.
    In the xorg.0.log I get messages that DRI is not working, and I get Mesa driver reported by fglrxinfo.
    I'm so frustrated!
    Just to be sure: is it really because of the ATI drivers, or am I doing something wrong?
    All help appreciated.

  • #2
    In your xorg.conf do you have:

    Section "Extensions"
    Option "Composite" "Disable"
    Option "AIGLX" "Disable"
    EndSection
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Tried all combinations

      I tried all combinations of Enabling and Disabling the options you mention. I'll check if there is any difference in the messages I get in the xorg log.
      I read somewhere that the newer generation of ATI video cards is not yet fully supported by the Linux drivers. I'll probably have to wait for the new release.

      Comment


      • #4
        The X1000 cards should be fully supported when it comes to the standard features/

        Do you get any warnings or errors in your log?
        Michael Larabel
        http://www.michaellarabel.com/

        Comment


        • #5
          driver trouble under FC6 on Lenova T60

          I suspect that my notebook does not currently have the appropriately configured and proper driver. Getting bugs that look like the reported cursor bug. I have a new Lenova T60 running Fedora Core 6. ATI Radeon Mobility X1400, driver 8.34.08. Goals are two eliminate the mouse bug, enable 3D acceleration, set up Dual Head (one big desktop). Anyone get recent drivers to behave under FC6 on this hardware? Should I go to Xorg driver? Some info below.

          Mike
          --------

          X log file shows no errors, but does report warning

          (WW) fglrx(0): ***********************************
          (WW) fglrx(0): * DRI initialization disabled! *
          (WW) fglrx(0): * 2D acceleraton available (MMIO) *
          (WW) fglrx(0): * no 3D acceleration available *
          (WW) fglrx(0): ***********************************

          Other info:

          [root@camero ~]# uname -a
          Linux camero.sr.unh.edu 2.6.20-1.2933.fc6 #1 SMP Mon Mar 19 11:38:26 EDT 2007 i686 i686 i386 GNU/Linux

          [root@camero log]# fglrxinfo
          Xlib: extension "XFree86-DRI" missing on display ":0.0".
          display: :0.0 screen: 0
          OpenGL vendor string: Mesa project: www.mesa3d.org
          OpenGL renderer string: Mesa GLX Indirect
          OpenGL version string: 1.2 (1.5)

          [root@camero log]# fgl_glxgears
          Using GLX_SGIX_pbuffer
          Xlib: extension "XFree86-DRI" missing on display ":0.0".
          X Error of failed request: BadMatch (invalid parameter attributes)
          Major opcode of failed request: 142 (GLX)
          Minor opcode of failed request: 5 (X_GLXMakeCurrent)
          Serial number of failed request: 30
          Current serial number in output stream: 30

          Comment


          • #6
            Umm you can't go to the Xorg driver as there is no proper open-source R500 support.

            I have a Lenovo ThinkPad T60 that works no problems with fglrx. Have you tried 8.35.5? What does your xorg.conf look like?
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Newer ATI chips are the problem

              I'm not quite sure, but I think that the newer series of ATI Radeon chips are not fully supported by the Linux Drivers. Not even the 8.35 ones.
              I get similar messages as useratpnix, so I suspect we are suffering from the same problem.
              What video chip is in the T60?

              I just hope that release 8.36 will help, but I do not get my hopes too high.

              Comment


              • #8
                I don't know all of the details, but it appears that my problem with DRI initialization was related to a faulty file permission. Our sys admin has got everything to work by changing this file permission. Now fglxinfo shows the ATI driver being used and direct rendering enabled.

                Mike

                Comment


                • #9
                  no, its fglrx (or rather ATI)

                  Even though the X1950 cards have been out for a while, they aren't supported with that PoS ATI closed-source driver.

                  Also, notice that even if you manage to get it working (the 1950 chip is not the same instruction or register set as the 1900) its slower than hell. Want to run Beryl or Compiz? Tough - they perform miserably with that card (at least at 1920x1200 they did).

                  As someone else mentioned, the fastest way to get it working is to sell it on Ebay and buy an nVidia.

                  Bonus: you can actually install linux when using something like a 7600 GT on a PCIe bus.


                  I have nothing but seething hate for ATI. They own me $200 for this lemon video card, IMO.

                  Comment


                  • #10
                    Originally posted by Thund View Post
                    Even though the X1950 cards have been out for a while, they aren't supported with that PoS ATI closed-source driver.

                    Also, notice that even if you manage to get it working (the 1950 chip is not the same instruction or register set as the 1900) its slower than hell. Want to run Beryl or Compiz? Tough - they perform miserably with that card (at least at 1920x1200 they did).

                    As someone else mentioned, the fastest way to get it working is to sell it on Ebay and buy an nVidia.

                    Bonus: you can actually install linux when using something like a 7600 GT on a PCIe bus.

                    I have nothing but seething hate for ATI. They own me $200 for this lemon video card, IMO.
                    Due to the lack of AIXGL support in the 8.35.5 ATI drivers Beryl and Compiz will not run as fast/smooth as one would expect. It's a given that Compiz and Beryl run much better on a box/laptop with a nVidia card because the nVidia drivers do have support for AIXGL. I have no information if AIXGL support in the ATI driver is coming soon. Michael would probably be the best person to comment on that (if he has that information and can share it). If you can find the patience why not wait a bit and see what happens with the next few driver releases. I think ATI has a monthly release cycle now so the wait is not too long. If you decide to do so I hope you will be able to sell your card and get one better to your liking.

                    As a general note to those interested in buying a new video card to be used on a Linux box, make sure you have all the info before deciding on the brand & type:
                    - check the phoronix website and forum, If you can't find useful info ask on the forum
                    - check the vendors' websites and driver release notes to see if the card you are interested in is supported on Linux
                    - ask on the mailing lists and forums of the distro you are using if anyone else has any experience with the card you are interested in
                    - use google to see if there's more information out there. Then google again using different search terms. And again
                    - cut a deal with the shop where you are planning on buying the card that you can return the card for a full refund if it does not work (it should work because you did your homework, right...)

                    Comment

                    Working...
                    X