No announcement yet.

ATI Catalyst 9.8 Xorg freeze when idle

  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Catalyst 9.8 Xorg freeze when idle

    I have installed catalyst 9.8 in my arch system with radeon HD 4850. I suffer from Xorg freezes. I leave my computer for several minutes, then go back and screen is blank, and there is no signal. REISUB sequence does the work.
    I used to use ati open source driver but now I need it to use HDMI and audio over HDMI.
    Does anyone know the solution?

  • #2
    Pray that they poach some nVidia driver developers soon...

    Other than that if you're using Compiz/beryl (sometimes known as desktop effects) turn them ALL OFF, as this "fixed" my freeze when awaking from sleep and a couple of other things...

    Beyond that we all just sit around waiting for either the OSS drivers to catch up to current architectures and actually be good(bridgman says they're already better than the proprietary for 2D) or wait for something awful to happen at AMD and they actually release a quality catalyst for linux +


    • #3
      I got same thing with using kernel 2.6.27.
      I upgrade my kernel to 2.6.31-rc7 and all hangups are gone.
      You need to modify fglrx kernel code with patch for make compatible with 2.6.31.


      • #4
        Sorry, because this might look like a zombie resurrection post, but it is not.

        I had similar problem as the described one (ATI Radeon laptop + Compiz resulting in complete lock up after exactly 20 minutes idle time).
        I searched the web in all directions and was unable to find any clue, but suddenly I resolved it. The problem was simple to deal with, but it took a long time to find out what's going on. As I forementioned I'm using Compiz. I ticked all the boxes in Compiz workarounds plugin, and the lock-up problem is gone.

        I am writing, because I couldn't find any recipe anywhere on the internet, the problem persisted with every Catalyst version I could test (10.x, 11.x up to 11.9), so I think it might be useful for somebody having same issues.

        So forgive me waking up a zombie thread. ;-)


        • #5

          One more detail I've found is that "tear free" option in Catalyst configuration has to be disabled also.