Announcement

Collapse
No announcement yet.

AMD Catalyst 9.8 Delivers New Kernel Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by Tares View Post
    Okay, I've done fast tests comparing 9.7 and 9.8, here are the results :
    snipped results since they're useless as benchmarks,
    but anyways for comparison's sakes mobility radeon 4850 512MB GDDR3
    my glxgears FPS stabilize at c. 8200 FPS, and my fgl_glx gears at around 2300 FPS, this is a 500/850 core/mem R770.

    I've done ZERO else ATM, and don't really have the heart to test prior bug states ATM to comment on those... no progs run under wine, no games under wine, no video, no sleep, no compiz/beryl, no sleep(power mgmt) testing etc. ad nauseum just plain old 2D unadorned GNOME/Ubuntu variant desktop which still functions OK.

    GPU temps: For me they DO run HIGHER than under windows even at the basic windows(vista) performance setting.

    e.g. typically unde rlinux even w/ clocks at 250/200 (core/mem) aticonfig reports 56.5C, while under windows it's more like 50C power saving, 52C balanced, 54(ish)C high performance. MSI's turbo battery mode(Vista, I suspect that they underclock but I've not investigated so long as things are working well as it's a pointless triviality) get's me down to 44-46C.

    Never really recorded temps under linux while running games or other GPU intensive apps, so I won't bother to mention various peaks here...
    Last edited by cutterjohn; 08-19-2009, 07:25 PM.

    Comment


    • #92
      For the HoN freezes, try nopat at boot.

      Comment


      • #93
        Originally posted by RealNC View Post
        On a 4870, 80 to 85C idle temp is normal. Full load is about 90-95C.

        Since you're on Crossfire, higher temps than the above is normal; the cards are close together and heat up more.
        Ive installed for testing shortly Windows 7. The temps are 65 to 70C and I can set the fan speed.

        My problem is, that my case is nearly burning with the two cards (an usb cable was melting cause of this!) in it.

        I would be so much happy when I can set the fan speed, I missing the noise of the fan.


        At all, this is still a bug:
        aticonfig --pplib-cmd "get fanspeed 0"
        PPLIB command execution has failed!
        ati_pplib_cmd: execute "get" failed!

        aticonfig --pplib-cmd "get fanspeed 1"
        PPLIB command execution has failed!
        ati_pplib_cmd: execute "get" failed!
        Is there another way to set the fan speed?

        Comment


        • #94
          Originally posted by blabub View Post
          Is there another way to set the fan speed?
          http://www.phoronix.com/forums/showt...ight=overdrive

          Comment


          • #95
            Originally posted by storma View Post
            For the HoN freezes, try nopat at boot.
            I've tried that, but I don't think it works here. I'm on ubuntu amd64 and dmesg didn't said anything about pat ;x

            Comment


            • #96
              Hi, I changed from fedora 11 to ubuntu, only to get the new ATI driver work, well it does, but it works very badly.
              I do not know how so many of you can say with their cards, the driver works perfectly well, because with my card HD 4670 it definately doesn't.
              When I idle for a while the X-Server freezes ...
              When I open windows in full size, it freezes for a short time and videos are playbacked in a miserable way.
              I tried to improve with adding "nopat" to my boot parameters and through Xorg.conf options, but no success.
              Here's my current Xorg.conf, maybe someone knows what to do to get this problems solved.


              Code:
              Section "ServerLayout"
              	Identifier     "aticonfig Layout"
              	Screen      0  "aticonfig-Screen[0]-0" 0 0
              	Option  "AIGLX"  "on"
              EndSection
              
              Section "Files"
              EndSection
              
              Section "Module"
              EndSection
              
              Section "Monitor"
              	Identifier   "Configured Monitor"
              EndSection
              
              Section "Monitor"
              	Identifier   "aticonfig-Monitor[0]-0"
              	Option	    "VendorName" "ATI Proprietary Driver"
              	Option	    "ModelName" "Generic Autodetecting Monitor"
              	Option	    "DPMS" "true"
              EndSection
              
              Section "Device"
              	Identifier  "Configured Video Device"
              EndSection
              
              Section "Device"
              	Identifier  "aticonfig-Device[0]-0"
              	Driver      "fglrx"
              	BusID       "PCI:1:0:0"
              	Option "TexturedVideo" "on"
              	Option "TexturedVideoSync" "True"
              	Option "OpenGLOverlay" "off"
              	Option "Textured2D" "on"
              	Option "TexturedXrender" "on"
              	Option "UseFastTLS" "1
              EndSection
              
              Section "Screen"
              	Identifier "Default Screen"
              	Device     "Configured Video Device"
              	Monitor    "Configured Monitor"
              EndSection
              
              Section "Screen"
              	Identifier "aticonfig-Screen[0]-0"
              	Device     "aticonfig-Device[0]-0"
              	Monitor    "aticonfig-Monitor[0]-0"
              	DefaultDepth     24
              	SubSection "Display"
              		Viewport   0 0
              		Depth     24
              	EndSubSection
              EndSection
              
              Section "DRI"
              Mode 0666
              EndSection
              
              Section "Extensions"
                      Option "Composite" "Enable"
              	Option "RENDER" "Enable"
              	Option "DAMAGE" "Enable"
              EndSection

              Comment


              • #97
                Thanks for the link but:

                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value
                Error reading fan speed value

                Comment


                • #98
                  Originally posted by Lory View Post
                  I have installed the driver, and the TV out is broken. Despite I have the
                  Code:
                  Option "TVFormat" "PAL-B"
                  line in my device section of my xorg.conf if I run
                  Code:
                  xrandr -screen 1 --prop
                  it gives tv_format:NTSC-JPN. And the image is flickering and there are no colors.

                  Moreover, after rollback to the 9.7 driver the problem persist.

                  Has anyone any idea?
                  The solution was:

                  Remove the /etc/ati

                  reinstall the driver
                  then running aticonfig --tvf PAL-B

                  Now all is ok.

                  Comment


                  • #99
                    Originally posted by Domi09 View Post
                    Hi, I changed from fedora 11 to ubuntu, only to get the new ATI driver work, well it does, but it works very badly.
                    I do not know how so many of you can say with their cards, the driver works perfectly well, because with my card HD 4670 it definately doesn't.
                    [/CODE]
                    i have an 4670 to and it works!

                    Kubuntu 9.04 with kernel 2.6.30+KDE4.3

                    Comment


                    • Originally posted by Lory View Post
                      The solution was:

                      Remove the /etc/ati

                      reinstall the driver
                      then running aticonfig --tvf PAL-B

                      Now all is ok.
                      This "delete /etc/ati" problem has been mentioned so many times already, but still the catalyst installer doesn't seem to care about it.

                      Comment


                      • what shall the installer do? remove configs that were changed by the user? that would be equally wrong.

                        The installer could warn about it, that problems might go away if you remove that directory...

                        Comment


                        • Or it could update the incompatible entries.

                          Comment


                          • F11 workaround

                            For those having problems with F11

                            http://forums.fedoraforum.org/showth...55503&page=234

                            it is a problem related to the hardware cursor and fglrx.

                            Comment


                            • People are really desperate in looking for things to blame the fglrx drivers it would seem.

                              Comment


                              • This is an existing problem. Of course you think that having people chasing forums for several days until they discover the "delete /etc/ati" solution is really great. Your opinion. My opinion is that the user should be told or the installer should fix the entries.

                                People are really desperate in defending the fglrx driver's bugs.

                                Comment

                                Working...
                                X