Announcement

Collapse
No announcement yet.

AMD Catalyst 9.8 Delivers New Kernel Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by Domi09 View Post
    Does anyone have a solution for the freeze situation on FC11?
    I have installed the 9.8 driver on FC11 64-bit, it works fine until a program of mine tries to connect to the internet, pidgin for instance.
    As soon as that happens, the whole system freezes. The open source radeon driver works flawlessly though.
    I haven't found any solution for that problem. so I hope anyone of you DOES have a solution.

    Looking forward
    Really hard freezes? SysRq keys don't work anymore? If you can't get any log message, it will be hard to debug. With gentoo unstable the driver works fine so far.

    Comment


    • #62
      OK so I tried again to get this working and succeeded after turning on a bunch of unwanted IA32 crap in the kernel (which the gentoo ebuild helpfully doesn't mention at all) and downgrading from git Xorg.

      So now I have 3D until the memory leaks force me to quit the program or suffer a crash. It feels like IE6-quality software, that's for sure.

      Comment


      • #63
        Originally posted by RealNC View Post
        Still "not found" in the link to the release notes. IMO just shows how much attention they pay to the Linux release. It's not the first time they don't release properly.
        Here the typical AMD ReleaseNotes PDF:
        http://www2.ati.com/drivers/linux/catalyst_98_linux.pdf

        Comment


        • #64
          The new randr feature works like a charm. With previous releases I had to disable randr 1.2 to be able to use dual screen.

          3D seams like a downgrade.

          Error message may appear while playing H264/VC1/mpeg2 media files with
          Hardware Acceleration
          I wonder what this really means

          Comment


          • #65
            Originally posted by ObiWan View Post
            Here the typical AMD ReleaseNotes PDF:
            http://www2.ati.com/drivers/linux/catalyst_98_linux.pdf
            Still mention "Linux kernel 2.6 or above" as requirement.

            Comment


            • #66
              Fedora users shouldn't complain too much

              Fedora uses a patched and ahead-of-stream graphics stack. Thus, if you are using Fedora please don't slag off the ATI team, and instead suggest to the Fedora team that be a little less cutting edge. If the Slack, Gentoo, and Arch users aren't encountering problems, it's fair to say that this is a successful release.

              I say this as a (very) patient Fedora user

              Comment


              • #67
                Well its good that the release notes seem to cover a lot more known issues now. Lets hope that they're working on fixing them.

                Comment


                • #68
                  Originally posted by yesterday View Post
                  Fedora users shouldn't complain too much

                  Fedora uses a patched and ahead-of-stream graphics stack. Thus, if you are using Fedora please don't slag off the ATI team, and instead suggest to the Fedora team that be a little less cutting edge. If the Slack, Gentoo, and Arch users aren't encountering problems, it's fair to say that this is a successful release.

                  I say this as a (very) patient Fedora user
                  I'd call this a successful release if the Ubuntu users aren't having problems.

                  I don't agree with Fedora needing to be less cutting edge. I think it's fair to say that if the OSS driver eventually gets decent support across chipsets, it'll be the Fedora users the ones who'll be testing it first.

                  What it is absolutely true is that Catalyst and Fedora don't mix. Fedora is constantly pushing the envelope and Catalyst is targeted to a different audience; being very popular amongst retired people living in Florida

                  Comment


                  • #69
                    Originally posted by PuckPoltergeist View Post
                    Still mention "Linux kernel 2.6 or above" as requirement.
                    and it works with 2.6.29+30 without patches.

                    So what is your problem?

                    Comment


                    • #70
                      One thing I find funny in the release notes system requirements is "glibc 2.2 or 2.3". 2.2 was released in 2000, 2.3 in 2002.

                      We're at 2.10 today (which is 2009.)

                      Edit: here's another "diamond":

                      "Error message may appear while playing H264/VC1/mpeg2 media files with
                      Hardware Acceleration"

                      Uh, wut?
                      Last edited by RealNC; 08-18-2009, 08:28 PM.

                      Comment

                      Working...
                      X