Announcement

Collapse
No announcement yet.

AMD Catalyst 9.8 Delivers New Kernel Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Good release, at last kernel 2.6.30 support, though 2.6.31 is about to be released. But hopefully 9.9 will have support for it because Ubuntu will be almost close to release by then. Still the leaked 64bit driver I was using was not from 9.8 maybe it was 9.9 or 9.10 beta.

    Comment


    • #52
      I think it was a very early 9.9, sort of a pre-alpha.

      Comment


      • #53
        I'm missing the --xv-pixmap-buffer-type option from the leaked 8.65 version in aticonfig.

        Comment


        • #54
          I have installed the driver, and the TV out is broken. Despite I have the
          Code:
          Option "TVFormat" "PAL-B"
          line in my device section of my xorg.conf if I run
          Code:
          xrandr -screen 1 --prop
          it gives tv_format:NTSC-JPN. And the image is flickering and there are no colors.

          Moreover, after rollback to the 9.7 driver the problem persist.

          Has anyone any idea?

          Comment


          • #55
            Originally posted by kensai View Post
            Good release, at last kernel 2.6.30 support, though 2.6.31 is about to be released. But hopefully 9.9 will have support for it because Ubuntu will be almost close to release by then. Still the leaked 64bit driver I was using was not from 9.8 maybe it was 9.9 or 9.10 beta.
            I'd assume they ship a pre-release and backport the release, as before, if it's not ready in time.

            Comment


            • #56
              Originally posted by Melcar View Post
              Anyone else getting massive graphical distortions on the Tropics demo?
              I've got the same thing. Try to change AA settings, it helps... sometimes.

              Comment


              • #57
                Originally posted by Lory View Post
                I have installed the driver, and the TV out is broken. Despite I have the
                Code:
                Option "TVFormat" "PAL-B"
                line in my device section of my xorg.conf if I run
                Code:
                xrandr -screen 1 --prop
                it gives tv_format:NTSC-JPN. And the image is flickering and there are no colors.

                Moreover, after rollback to the 9.7 driver the problem persist.

                Has anyone any idea?
                I'm guessing that option came from some other driver.

                AFAIK you normally set TV standards on fglrx using aticonfig. Run aticonfig --help and look for TV options.

                I think you want something like aticonfig --tvf=PAL-B.
                Last edited by bridgman; 08-18-2009, 03:58 PM.

                Comment


                • #58
                  Originally posted by bridgman View Post
                  Just curious, where did you get that option from, maybe some other driver ?
                  from the catalyst driver manual (/usr/share/doc/ati/html/ for me)

                  Originally posted by bridgman View Post
                  AFAIK you normally set TV standards on fglrx using aticonfig. Run aticonfig --help and look for TV options.
                  Yes, I have tried but not working. Nor with catalyst 9.7.

                  Comment


                  • #59
                    Originally posted by bridgman View Post
                    I think it was a very early 9.9, sort of a pre-alpha.
                    Then 9.9 won't have kernel 2.6.31 support, 9.10 should.

                    Comment


                    • #60
                      Does anyone have a solution for the freeze situation on FC11?
                      I have installed the 9.8 driver on FC11 64-bit, it works fine until a program of mine tries to connect to the internet, pidgin for instance.
                      As soon as that happens, the whole system freezes. The open source radeon driver works flawlessly though.
                      I haven't found any solution for that problem. so I hope anyone of you DOES have a solution.

                      Looking forward

                      Comment

                      Working...
                      X