Announcement

Collapse
No announcement yet.

AMD Catalyst 9.8 Delivers New Kernel Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • you could start with like posting the error message.

    Comment


    • Originally posted by energyman View Post
      you could start with like posting the error message.
      Fair enough...
      more /usr/share/ati/fglrx-install.log
      [Message] Kernel Module : Trying to install a precompiled kernel module.
      [Message] Kernel Module : Precompiled kernel module version mismatched.
      [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
      AMD kernel module generator version 2.1
      doing Makefile based build for kernel 2.6.x and higher
      rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
      make -C /lib/modules/2.6.29.6/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
      make[1]: Entering directory `/home/downloads/kernel/linux-2.6.29.6'
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
      /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MapPageToPfn’:
      /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1568: warning: unused variable ‘bus_addr’
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
      /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:431:6: warning: #warning "ACPI notification wrapping won't work."
      /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:464:6: warning: #warning "ACPI notification wrapping won't work."
      /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:490:6: warning: #warning "ACPI notification wrapping won't work."
      /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.c:514:6: warning: #warning "ACPI notification wrapping won't work."
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
      CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
      LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
      Building modules, stage 2.
      MODPOST 1 modules
      CC /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
      LD [M] /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
      make[1]: Leaving directory `/home/downloads/kernel/linux-2.6.29.6'
      build succeeded with return value 0
      duplicating results into driver repository...
      done.
      You must change your working directory to /lib/modules/fglrx
      and then call ./make_install.sh in order to install the built module.
      - recreating module dependency list
      - trying a sample load of the kernel modules
      failed.
      [Error] Kernel Module : Failed to install compiled kernel module - please consult readme.
      Thanks,
      Partha

      Comment


      • Originally posted by energyman View Post
        btw, I edited the xorg-server ebuild to add the fedora_dont_backfill_bg_none.patch patch and installed the very latest qt version while I was at it.

        composite is on. 2d speed is PERFECT. There are NO slowdowns. Resizing windows is an instant action. No corruption so far.

        This patch should be standard everywhere.
        2D speed is good, no slowdowns, but sometime artefacts. You should be able to trigger with hidden panel that only apears when hitting the boddom of the screen with the mouse. Tested with KDE 4.3 and Qt 4.5.2.

        Comment


        • no problem here. No artifacts, but I am using a svn version of qt which has a lot of kde related fixes.

          partha - I have no idea - but you can find my working kernel config here:
          http://omploader.org/vMjdhbg

          Comment


          • Erm, I've been reading these forums for quite a while bun never got into the discussion.

            First of all, I've been using various Linux and *BSD distros for almost 10 years now. I've also used ATI cards since my first ISA bus ATi card with 512K (K!) RAM and I know the pain of ATi drivers. I still have it in some junk box, along with the manual. It's actually made in Canada!

            For my FreeBSD box I have an old Nvidia Gf4800 and, while the dark days of ATi / Linux I used an Gf2 GTS (yes "2"!) for the linux box.

            Anyways, I have 5 machines at home and, except for the FreeBSD box for which ATi shows no love, all have ATi and had ATi forever. I have two machines with radeon 3200 integrated on the (gigabyte) motherboard, one with a sapphire radeon 3870 and one with a sapphire radeon 4850. I also have a 4830 that I used at my last workplace (I brought my own card) with a Debian machine.

            All these work fine on Debain / Ubuntu / Gentoo and SuSe (I need to make and test app packages for these distros, in case you are wondering). Debian, Ubuntu and SuSe all have 2.6.26-amd64 kernel and the Gentoo Box has a kernel that is a little older because the box has an older Adaptec I/O card that has problems with any kernel >24.

            I just updated all except Gentoo to ATi's 9.8 driver and all boxes work fine. I always purge the fglrx module and assorted packages without X started, reboot into single user mode, run the blob from ATi, copy a backed-up xorg, reboot and it works. fglrxinfo works so does fglxgears, google earth works, and i ran some games to see how it works and it's ok. No hangups, no corruption.

            I played some 720p and 1080p mkvs in VLC and mplayer and its all good. (with vlc > 0.8.8).

            Here are the configurations that *work* 100% with all Catalyst drivers released recently:

            Ubuntu (8.04 AMD64) Radeon 3200 (integrated) on a Gigabyte GA-MA78GM-S2H (AMD 780G/SB700) with a AMD Phenom X4 9350e and 4GB RAM. Everything works with Catalyst 9.8, no freeze, no lockups, OpenGL rendering ok, 1080p videos...

            SuSe (10.2 AMD64) Radeon 3200 (integrated) on a Gigabyte GA-MA78GM-S2H (AMD 780G/SB700) with a AMD Athlon X2 5050e and 4GB RAM. Same, but i only tested Google Earth and glxgears, no wine and/or 3D games.

            Debian (5 AMD64) Sapphire Radeon 3870 512MB pciex16 on a Gigabyte GA-MA790FX-DQ6 (AMD790FX/SB600 ) with a AMD Athlon X2 6000 and 8GB RAM. I have tested everything, including AvP1, AvP2, DeusEx, Quake 3 and Quake 4 in wine. AvP2 and Q4 crash randomly but it's from wine, otherwise they work fine.

            Gentoo (2008 AMD64) Sapphire Radeon 4850 512MB pciex16 on a Gigabyte GA-MA790FX-UD5P (AMD790FX/SB750 ) with a AMD Phenom X4 9850 and 8GB RAM. This one has 8.10 with kernel 2.6.24.* and I don't use any compiz/3d games and such because I need a specific clean configuration of Gentoo for my builds, but X works ok, no hangups or random freeze... I tried an 1080p in mplayer and it worked ok. (in case you are wondering why the 4850 and 9850 on a gentoo box, it also has an WinXP drive)

            It seems to me that, on one hand, people with older ATi cards, from the pre 2xxx generations have a lot of trouble and, on the other hand, there might be some hardware issues with other components.

            The truth is, before the "big" Gigabyte mobos (790FX) i had similar ASUS mobos and they gave me a lot of headakes, one had really crappy sound in Debian/SuSe (not in windows) and it finally just died and the other had a horrible I/O controller problem.

            I have somewhere around and old Athlon x2 on 939 socket, a mobo and a sapphire radeon 1600 pro AGP. I'll install Debian/Ubuntu/SuSe on it, if i find some DDR1 RAM and let you all know how it works with the latest catalyst drivers.

            I hope this helps.

            Comment


            • partha - I have no idea - but you can find my working kernel config here:
              http://omploader.org/vMjdhbg
              Thanks Energyman. Looks like 9.8 is not ready for my machine yet with a kernel > 2.6.27.25. So, I am sticking to 9.8 and 2.6.27.25 for now. 9.8 works beautifully on that kernel and I get everything I need. I will wait for 9.9 for the issues to be ironed out before attempting with a higher version of the kernel.

              Partha

              Comment


              • Bridgman,

                Does ATI have any intention to eventually deliver the same quality drivers as nVidia? Because, with all due respect, this is getting absolutely ridiculous.

                -V!NCENT

                Comment


                • Originally posted by V!NCENT View Post
                  Bridgman,

                  Does ATI have any intention to eventually deliver the same quality drivers as nVidia? Because, with all due respect, this is getting absolutely ridiculous.

                  -V!NCENT
                  You may as well have put up a neon sign saying "I am a troll. Feed me."

                  Comment


                  • @CNCFarraday

                    When you try to use xv with fglrx all videos have EXTREME tearing. That's usually the default renderer for videos and not opengl which is better for fglrx users as long as vsync is forced via amdcccle. It seems you never could compare that against a vdpau enabled nvidia card...

                    Comment


                    • Originally posted by mirv View Post
                      You may as well have put up a neon sign saying "I am a troll. Feed me."
                      Am I? I have bought a HD4870 X2. On Windows XP I keep getting BSOD's due to the ATI driver. And that's not with heavy 3D. No sir. It's usually when I'm on the 2D desktop! And in 3D games most shadows are not even texture filtered (Red Alert 3, Colin Mcrae Dirt)

                      OK no worries, we have Linux also. Guess what? X.org is in the middle of a complete rework for the r6xx and the proprietary driver is a crying shame.

                      So what does this mean? Am I a troll or does ATI suck that much? Well, the latter.

                      I might as well just throw the graphics card I payed 480 euro for in the trashcan. Thank you very much with your "Stop trolling" BS. Go fsck yourself. I mean it.
                      Last edited by V!NCENT; 08-24-2009, 07:37 AM.

                      Comment

                      Working...
                      X