Announcement

Collapse
No announcement yet.

AMD Catalyst 9.8 Preview

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 9.8 Preview

    Source: http://www.pcper.com/comments.php?nid=7641

    Originally posted by pcper.com
    This month we are seeing a massive performance increase with a whole host of games as compared to the ATI Catalyst 9.7 driver. Detailed release notes are available for most of the game optimizations; here are the highlights:

    [...]
    UnigineTropics OpenGL performance improvements of up to 20%.
    [...]

    This release of the ATI Catalyst driver provides OpenGL 3.1 extension support. The following is a list of OpenGL 3.1 features and extensions added in ATI Catalyst 9.8:

    - Support for OpenGL Shading Language 1.30 and 1.40.
    - Instanced rendering with a per-instance counter accessible to vertex shaders (GL ARB draw instanced).
    - Data copying between buffer objects (GL EXT copy buffer).
    - Primitive restart (NV primitive restart). Because client enable/disable no longer exists in OpenGL 3.1, the PRIMITIVE RESTART state has become server state, unlike the Nvidia extension where it is client state. As a result, the numeric values assigned to PRIMITIVE RESTART and PRIMITIVE RESTART INDEX differ from the NV versions of those tokens. o At least 16 texture image units must be accessible to vertex shaders, in addition to the 16 already guaranteed to be accessible to fragment shaders.
    - Texture buffer objects (GL ARB texture buffer object).
    - Rectangular textures (GL ARB texture rectangle). o Uniform buffer objects (GL ARB uniform buffer object).
    - SNORM texture component formats.

    Support for new Linux operating systems
    This release of ATI Catalyst driver for Linux introduces support for the following new operating systems:

    - RHEL 4.8 production support
    - Ubuntu 9.04 production support

    ATI Catalyst™ Control Center - Linux Edition support for RandR 1.2 This release of the ATI Catalyst driver for Linux introduces ATI Catalyst Control Center - Linux Edition support for the RandR 1.2 extension API. The following new features are now available in the ATI Catalyst Control Center - Linux Edition Display Manager:

    - Display rotation
    - Multiple display arrangement and desktop sizing
    Also, not to forget, Linux 2.6.29/2.6.30 support as announced in last month's news post by Michael.

    The driver should be released tomorrow.

  • #2
    That note about the primitive restart sounds a bit funky. If that list of extensions actually is getting in as new stuff and they get the support for two new Linux versions, I'd probably be impressed if I still used the closed drivers.

    Comment


    • #3
      does it support <=r500?

      Comment


      • #4
        Originally posted by kkkk View Post
        does it support <=r500?
        Those are legacy cards anyway both on Windows and Linux side. Only supported by older closed driver versions... (and open drivers)

        Comment


        • #5
          Originally posted by nanonyme View Post
          Those are legacy cards anyway both on Windows and Linux side. Only supported by older closed driver versions... (and open drivers)
          yeah, but there should be a release every 3-4 months, if I remember correctly

          Comment


          • #6
            Originally posted by kkkk View Post
            yeah, but there should be a release every 3-4 months, if I remember correctly
            I haven't heard of that, sounds interesting. Where'd you read it?

            Comment


            • #7
              Originally posted by kkkk View Post
              yeah, but there should be a release every 3-4 months, if I remember correctly
              They planned to release a new one every 3 or 4th month but only for Windows. There was one releases, Catalyst 9.3.1, but they decided to stop those too.

              Comment


              • #8
                Originally posted by d2kx View Post
                They planned to release a new one every 3 or 4th month but only for Windows. There was one releases, Catalyst 9.3.1, but they decided to stop those too.
                Well, I'd expect they weren't planning to add support for new Windows graphical API's either... Low-effort legacy releases (as in, only bug fixes) would be pretty much useless for Linux users but neat for Windows users, really. ^^

                Comment


                • #9
                  2.6.29/30 at last. Of course when 31 comes out, we'll start complaining all over again :P

                  Comment


                  • #10
                    Originally posted by RealNC View Post
                    2.6.29/30 at last. Of course when 31 comes out, we'll start complaining all over again :P
                    Remember it's only two months until Ubuntu 9.10 which uses Linux 2.6.31 and they'll want to support that from the beginning.

                    Comment

                    Working...
                    X