Announcement

Collapse
No announcement yet.

Ubuntu 9.04 & Catalyst 9.7 (fglrx)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    AMD Big Desktop settings reset upon logout of X.

    Originally posted by adamk View Post
    Run this command to change your xorg configuration so that xrandr is disabled:

    aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

    Then restart X and you should see "Big Desktop" as an option.

    AMD should make that the default till they fix their buggy xrandr implementation.

    Adam
    Adam,
    I managed to get the "Big Desktop" option to appear and remain an option in Catalyst, but every time I logout or reboot the system, the "clone 1" option is replacing my settings which work perfectly while logged in. I ran amdcccle as super-user and my user account and still have the same result. The Gnome login window after reboot/logout recognizes the new settings (login is on left screen, right screen black).

    I am running Ubuntu Jaunty 64-bit system, using a ATI Radeon HD 3600, installed driver version 8.65, catalyst 9.9.

    Comment


    • #12
      Sorry, I can't really help with this. I haven't used fglrx in quite a while, and found that command on the internet.

      Adam

      Comment


      • #13
        Originally posted by BillTheGeologist View Post
        Adam,
        I managed to get the "Big Desktop" option to appear and remain an option in Catalyst, but every time I logout or reboot the system, the "clone 1" option is replacing my settings which work perfectly while logged in. I ran amdcccle as super-user and my user account and still have the same result. The Gnome login window after reboot/logout recognizes the new settings (login is on left screen, right screen black).

        I am running Ubuntu Jaunty 64-bit system, using a ATI Radeon HD 3600, installed driver version 8.65, catalyst 9.9.
        When I used to have problems with settings not sticking, I fiddled with the amd config file:
        fermulator@fermmy:/etc/ati$ ls -al /etc/ati/amd*
        -rw-r--r-- 1 root root 27568 2009-10-01 11:01 /etc/ati/amdpcsdb
        -rw-r--r-- 1 root root 1635 2009-09-26 21:35 /etc/ati/amdpcsdb.default

        1. Boot system in single user mode (don't let X load)
        2. make a backup of your amdpcsdb
        Code:
        sudo mv /etc/ati/amdpcsdb /etc/ati/amdpcsdb.bak
        3. copy the default
        Code:
        sudo cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb
        4. Apply necessary changes again ...
        5. Restart the system

        Hopefully this helps you in so me way. Perhaps someone from ATI can comment and confirm the process for "settings not sticking". For me at least, this is what I did to make things work again.

        Comment


        • #14
          Originally posted by fermulator View Post
          When I used to have problems with settings not sticking, I fiddled with the amd config file:
          fermulator@fermmy:/etc/ati$ ls -al /etc/ati/amd*
          -rw-r--r-- 1 root root 27568 2009-10-01 11:01 /etc/ati/amdpcsdb
          -rw-r--r-- 1 root root 1635 2009-09-26 21:35 /etc/ati/amdpcsdb.default

          1. Boot system in single user mode (don't let X load)
          2. make a backup of your amdpcsdb
          Code:
          sudo mv /etc/ati/amdpcsdb /etc/ati/amdpcsdb.bak
          3. copy the default
          Code:
          sudo cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb
          4. Apply necessary changes again ...
          5. Restart the system

          Hopefully this helps you in so me way. Perhaps someone from ATI can comment and confirm the process for "settings not sticking". For me at least, this is what I did to make things work again.


          Fermulator,
          You're awesome. That took care of the settings issue. I need to figure out now how to get the resolution and refresh rates for each monitor back to the correct settings. This was fine before, except for the whole settings loss on logout/reboot thing.

          I had the resolution set for 2560x1024 and refresh was 75Hz. Can you post the appropriate syntax to get this set/available. The highest setting in "gksu amdcccle" is 2048x768, but the requested res and refresh was available previously (before the fix).

          Comment


          • #15
            Originally posted by BillTheGeologist View Post
            Fermulator,
            You're awesome. That took care of the settings issue. I need to figure out now how to get the resolution and refresh rates for each monitor back to the correct settings. This was fine before, except for the whole settings loss on logout/reboot thing.

            I had the resolution set for 2560x1024 and refresh was 75Hz. Can you post the appropriate syntax to get this set/available. The highest setting in "gksu amdcccle" is 2048x768, but the requested res and refresh was available previously (before the fix).
            Glad it worked for you!

            What distro are you running? -- I'm running Ubuntu 9.04 currently, and following these instructions is how I get the AMD Catalyst drivers to install nicely integrating with Ubuntu's "Deb" package manager and etc.:
            http://wiki.cchtml.com/index.php/Ubu...ivers_manually

            My guess is that you need to re-run the ati config command:
            Code:
            sudo aticonfig --initial -f
            The other thing to consider is to check your /etc/X11/xorg.conf file and ensure that the "Virtual" resolution is as large as needed... (honestly though, I'm not sure you should have to edit this manually as when I ran amdcccle it automatically adjusted this for me, and even told me it was going to do this...)

            Here's my screen section in my own xorg.conf:
            Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device "aticonfig-Device[0]-0"
            Monitor "aticonfig-Monitor[0]-0"
            DefaultDepth 24
            SubSection "Display"
            Viewport 0 0
            Virtual 3360 3360
            Depth 24
            EndSubSection
            EndSection
            NOTE: I have dual monitors, each monitor running @ 1680x1050, so the total virtual space configuration allows me to have my screens side-by-side or top-to-bottom (rotated) -- basically the worst case -- allows me to configure my dual monitors in any way I like.

            Comment


            • #16
              Originally posted by fermulator View Post
              Glad it worked for you!

              What distro are you running? -- I'm running Ubuntu 9.04 currently, and following these instructions is how I get the AMD Catalyst drivers to install nicely integrating with Ubuntu's "Deb" package manager and etc.:
              http://wiki.cchtml.com/index.php/Ubu...ivers_manually

              My guess is that you need to re-run the ati config command:
              Code:
              sudo aticonfig --initial -f
              The other thing to consider is to check your /etc/X11/xorg.conf file and ensure that the "Virtual" resolution is as large as needed... (honestly though, I'm not sure you should have to edit this manually as when I ran amdcccle it automatically adjusted this for me, and even told me it was going to do this...)


              Here's my screen section in my own xorg.conf:

              NOTE: I have dual monitors, each monitor running @ 1680x1050, so the total virtual space configuration allows me to have my screens side-by-side or top-to-bottom (rotated) -- basically the worst case -- allows me to configure my dual monitors in any way I like.

              I am running 9.04, too, 64-bit. I tried your suggestions with no luck. For some reason, the resolution and refresh do not change even after replacing the amdpcsdb file and applying the changes. Xrandr is still an available command option and it shows the max resolution being the 2048x768 at 60 Hz.

              Is there a way to tell X whether through Xrandr or somewhere in the amd/ati config files that these values are higher? The xorg.conf file doen't have an option for "Virtual", and when I insert, save, and reboot the wallpaper has changed, window switching/minimizing/maximizing/closing is slow by 1-2 seconds, and the settings in both Catalyst and Gnome Screen Resolution remain the same. I can't seem to get the code to work using Xrandr: I need to add the resolution and refresh rate to be available in Catalyst and the syntax is a little confusing. Only 2048x768 shown when Catalyst open, but numerous under the Gnome Screen Resolution option under System=>Preferences, none higher than 2048x768.

              Comment


              • #17
                I'm running Ubuntu 9.04. How should I do this?

                Mike


                Originally posted by fermulator View Post
                Try the latest catalyst drivers, they work better with defaults.

                Comment


                • #18
                  Originally posted by mslinn View Post
                  I'm running Ubuntu 9.04. How should I do this?

                  Mike
                  I always follow these instructions: http://wiki.cchtml.com/index.php/Ubu...ivers_manually, modifying for whatever the latest version from ATI is at the time.

                  Installing the ATI drivers as DEBs is "nicer".

                  Comment


                  • #19
                    Uh-oh. I have two EAH-4350 cards, which are not on the compatibility list. Is there a way forward?

                    Comment


                    • #20
                      I just did a clean install with Ubuntu 9.10 and the Catalyst drivers. Still only uses one monitor even though there are two EAH4350 cards. I get "Failed to execute child process "amdxdg-su" (No such file or directory)."

                      Tried uninstalling and reinstalling several times. Am I wasting my time on this card? Should I be using other drivers?

                      I've been stuck here for months.

                      Comment

                      Working...
                      X