Announcement

Collapse
No announcement yet.

Can't get out of VESA...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    OK, let's start switching things off and try to see what function is causing the problem. Run "man radeon" and look through the output to find the xorg conf option to disable acceleration. Put that in your xorg.conf and start again.
    Started with dpkg -reconfigure -phigh xserver-xorg to get a clean xorg.conf... Then added:

    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    	Driver		"radeon"
    	Option		"NoAccel"		"true"
    	Option		"UseFBDev"		"true"
    EndSection
    UseFBDev true - came from the dpkg -reconfigure, so I left it...

    The result... OMG... I have native resolution again... I can't believe I didn't think about trying that, but I'll be the first to admit I've been stabbing in the dark...

    So what next, the issue is now totally reproducible - NoAccell fixes it... I'd like to get a fully functional card back.

    ~~~
    Thanks to everyone who has chimed in here!

    Comment


    • #12
      I'm a bit suspicious about that fbdev option, will check.

      EDIT - all indications are that you should not have the UseFBDev option turned on. It does seem to help with some non-ATI GPUs, however.

      Can you pastebin your dmesg output ? Let's see if the drm is coming up OK.
      Last edited by bridgman; 08-08-2009, 03:34 PM.

      Comment


      • #13
        pastebin as requested: http://pastebin.ca/1522174

        I pulled the relevant parts below, in case you don't want to dig through all of it...

        Code:
        #:~$ dmesg |grep drm
        [   10.596553] [drm] Initialized drm 1.1.0 20060810
        [   10.614962] [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0
        #:~$ dmesg |grep radeon
        [    1.637946] radeonfb 0000:01:00.0: power state changed by ACPI to D0
        [    1.637962] radeonfb 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
        [    1.638356] radeonfb: Retrieved PLL infos from BIOS
        [    1.638361] radeonfb: Reference=27.00 MHz (RefDiv=6) Memory=400.00 Mhz, System=250.00 MHz
        [    1.638366] radeonfb: PLL min 20000 max 40000
        [    3.149013] radeonfb: Monitor 1 type LCD found
        [    3.149017] radeonfb: Monitor 2 type no found
        [    3.149024] radeonfb: panel ID string: QDS                     
        [    3.149028] radeonfb: detected LVDS panel size from BIOS: 1440x900
        [    3.149031] radeondb: BIOS provided dividers will be used
        [    3.228009] radeonfb: Dynamic Clock Power Management enabled
        [    3.228536] radeonfb (0000:01:00.0): ATI Radeon 3150 "1P"
        [   10.614366] radeonfb 0000:01:00.0: setting latency timer to 64
        [   10.614962] [drm] Initialized radeon 1.30.0 20080528 for 0000:01:00.0 on minor 0
        Perhaps the FBdev came in because the radeonfb driver is in use...

        Comment


        • #14
          Arggh ! Get rid of radeonfb; that's probably what is causing all your problems.

          Comment


          • #15
            There's a 99% chance bridgman's right here, since I just had almost the same problem...

            Comment


            • #16
              Originally posted by bridgman View Post
              Arggh ! Get rid of radeonfb; that's probably what is causing all your problems.
              I so wish it was that simple, but radeonfb was something I had just started playing with today... I've removed it from the startup, and blacklisted in blacklist-framebuffers.conf as per a normal install.

              dmesg produces the same output without radeonfb, drm initializes...etc. Still no love on getting any form of acceleration to work.

              I'm trying various option out of the radeon manual... I'll post if I have any luck.

              Where do you think the problem is stemming from? Xorg, radeon, my hardware, my config?

              And thanks for the help... and patience. it is appreciated...

              Comment


              • #17
                have you also removed the "UseFBDev" option ?

                Turn that off if it's not already off, then power down, restart, start up X and post xorg log + dmesg output along with a summary of what isn't right.

                Comment


                • #18
                  Originally posted by bridgman View Post
                  have you also removed the "UseFBDev" option ?
                  Turn that off if it's not already off, then power down, restart, start up X and post xorg log + dmesg output along with a summary of what isn't right.
                  My Device section from xorg.conf (UseFBDev option removed):
                  Code:
                  Section "Device"
                  	Identifier	"Configured Video Device"
                  	Driver		"radeon"
                  	Option		"NoAccel"	"true"
                  EndSection
                  Xorg.0.log: http://pastebin.ca/1522415
                  Fresh Dmesg: http://pastebin.ca/1522417

                  The issue at this point is without "NoAccel" set to "true" in xorg.conf, Xorg will eat my CPU (100%) and locks the machine up. I'd love to get back to a fully functional card...

                  thanks again...

                  Comment


                  • #19
                    We need xorg log and dmesg from when it's *not* working (ie without the NoAccel option) to figure out what's wrong

                    Not sure what the default accel method was in 6.12.1, might still be XAA, but try adding Option "AccelMethod" "XAA" in the device section just to be safe.

                    Comment


                    • #20
                      Originally posted by bridgman View Post
                      We need xorg log and dmesg from when it's *not* working (ie without the NoAccel option) to figure out what's wrong

                      Not sure what the default accel method was in 6.12.1, might still be XAA, but try adding Option "AccelMethod" "XAA" in the device section just to be safe.
                      Surely that would help... the non-functional one... it's been a long day.

                      The default according to radeon manual and Xorg.0.log is EXA - I tried specifying XAA - and Xorg.0.log said it wasn't supported for this model type and to use EXA. So, at this point, I just removed the "NoAccel" option and let it choose what it wanted...

                      Here's some new info...
                      Xorg.0.log: http://pastebin.ca/1522454
                      Dmesg: http://pastebin.ca/1522455

                      thanks again...

                      Comment

                      Working...
                      X