Announcement

Collapse
No announcement yet.

What is the correct "BusID" syntax for device 0x0c:0:0 ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • What is the correct "BusID" syntax for device 0x0c:0:0 ?

    Hi,

    I have just installed a new 4650 card into my laptop's docking station, and am trying to configure X for dual screen. This is my device section:
    Code:
    Section "Device"
            Identifier  "FireGL-fglrx"
            Driver      "fglrx"
            Option      "OpenGLOverlay" "off"
            Option      "VideoOverlay" "on"
            Option      "UseFastTls" "1"
            Option      "UseInternalAGPGART" "no"
            Option      "MaxGARTSize" "255"
            Option      "BlockSignalsOnLock" "off"
            Option      "TexturedVideoSync" "on"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Device"
            Identifier  "HD4650-fglrx"
            Driver      "fglrx"
            BusID       "PCI:12:0:0"
            Screen      1
    EndSection
    However, fglrx is hating this. (It appears to crash the driver.) Omitting the BusID doesn't work either because then I get the following:
    Code:
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@12:0:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@12:0:1) found
    (--) Chipset Supported AMD Graphics Processor (0x71D4) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@12:0:1) found
    (**) ChipID override: 0x9498
    (**) Chipset Supported AMD Graphics Processor (0x9498) found
    Does anyone have any ideas, please? Note that the laptop's primary device is a V5250, and so upgrading the fglrx driver from 9.3 is not an option.

    Thanks,
    Chris

  • #2
    AFAIK configuration for dual head is done with aticonfig, not with xorg.conf :

    aticonfig --initial=dual-head -f

    Are you able to disable the internal V5250 ? I'm not sure how the driver will handle multiple GPUs if one is pre-6xx and the other is post-6xx.

    Comment


    • #3
      Originally posted by bridgman View Post
      AFAIK configuration for dual head is done with aticonfig, not with xorg.conf :

      aticonfig --initial=dual-head -f

      Are you able to disable the internal V5250 ? I'm not sure how the driver will handle multiple GPUs if one is pre-6xx and the other is post-6xx.
      Thanks for the reply. I was hoping to keep the V5250 enabled for those times when the laptop is not docked ;-). Regardless, aticonfig seems to imply that the BusID is always the primary device, even for the second Device section. The point seems to be adding "Screen 1" to the second Device section. Although it still doesn't work...
      Code:
      (II) fglrx(0): VESA BIOS detected
      (II) fglrx(0): VESA VBE Version 3.0
      (II) fglrx(0): VESA VBE Total Mem: 16384 kB
      (II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
      (II) fglrx(0): VESA VBE OEM Software Rev: 9.12
      (II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc. 
      (II) fglrx(0): VESA VBE OEM Product: M66GL
      (II) fglrx(0): VESA VBE OEM Product Rev: 01.00
      (WW) fglrx(0): GetVBEMode failed
      (II) fglrx(0): ATI Video BIOS revision 9 or later detected
      (II) fglrx(0): PCI bus 12 card 0 func 0
      (**) fglrx(0): Chipset: "ATI Radeon HD 4650" (Chipset = 0x9498)
      (**) fglrx(0): (PciSubVendor = 0x1787, PciSubDevice = 0x2269)
      (**) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
      (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
      (--) fglrx(0): MMIO registers at 0xedf00000
      (==) fglrx(0): ROM-BIOS at 0x000c0000
      (II) fglrx(0): ATI Video BIOS revision 9 or later detected
      (--) fglrx(0): Video RAM: 1048576 kByte, Type: DDR2
      (II) fglrx(0): PCIE card detected
      (WW) fglrx(0): board is an unknown third party board, chipset is supported
      Force CF off in dual-head mode.
      drmOpenDevice: node name is /dev/dri/card0
      drmOpenDevice: open result is 12, (OK)
      drmOpenByBusid: Searching for BusID PCI:1:0:0
      drmOpenDevice: node name is /dev/dri/card0
      drmOpenDevice: open result is 12, (OK)
      drmOpenByBusid: drmOpenMinor returns 12
      drmOpenByBusid: drmGetBusid reports PCI:12:0:0
      drmOpenDevice: node name is /dev/dri/card1
      drmOpenDevice: open result is 12, (OK)
      drmOpenByBusid: drmOpenMinor returns 12
      drmOpenByBusid: drmGetBusid reports PCI:1:0:0
      (II) fglrx(0): Using adapter: 1:0.0.
      (--) fglrx(0): Video RAM: 262144 kByte, Type: DDR3
      (II) fglrx(0): [FB] MC range(MCFBBase = 0xc0000000, MCFBSize = 0x10000000)
      (II) fglrx(0): PCIE card detected
      (WW) fglrx(0): board is an unknown third party board, chipset is supported
      (II) fglrx(0): RandR 1.2 support is enabled!
      (II) fglrx(0): RandR 1.2 rotation support is enabled!
      (II) Loading sub module "ddc"
      (II) LoadModule: "ddc"
      (II) Module "ddc" already built-in
      drmOpenDevice: node name is /dev/dri/card0
      drmOpenDevice: open result is 13, (OK)
      drmOpenByBusid: Searching for BusID PCI:12:0:0
      drmOpenDevice: node name is /dev/dri/card0
      drmOpenDevice: open result is 13, (OK)
      drmOpenByBusid: drmOpenMinor returns 13
      drmOpenByBusid: drmGetBusid reports PCI:12:0:0
      (II) fglrx(0): Using adapter: 12:0.0.
      This is as far as it gets.

      Comment

      Working...
      X