Announcement

Collapse
No announcement yet.

ASUS M51TA-x2, Radeon HD 3650, Ideas

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by tball View Post
    well did you run:
    aticonfig --initial

    After, check that it set the right pciID under device section in xorg.conf.

    EDIT:
    It should say 02:00.0 in your config.
    Hello, thanks for your comment, I will tell you exactly what I did:
    (1) Installed from scratch Ubuntu 9.10 beta 64bits (in other partitions Ubunut 9.04 64bits & Vista 32bits)
    (2.0) Upgraded everything that could be updated (kernel 2.6.31-14,...)
    (2.1) Restart
    (3) Installed xorg-driver-fglrx (2:8.660-0ubuntu4) and all other dependencies which were needed from Synaptic
    (4.0) In terminal: "sudo aticonfig --initial -f"
    (4.1) A xorg.conf file was created (before there was no xorg.conf) with the following text:

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:1:5:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    (4.2) Restart... XORG CRASHED!
    (5) I tried changing in xorg.conf BusID to "PCI:2:0:0" but it always crashes...
    (6) Finally I changed the name of xorg.conf so that it doesn't read it and now it works but, of course, no 3D acceleration
    PLEASE HELP!

    Shoul I install the fglrx manually?? following this guide: http://wiki.cchtml.com/index.php/Ubu...allation_Guide
    I don't know what else to do.

    Comment


    • #12
      Originally posted by rmartinez View Post
      Hello, thanks for your comment, I will tell you exactly what I did:
      (1) Installed from scratch Ubuntu 9.10 beta 64bits (in other partitions Ubunut 9.04 64bits & Vista 32bits)
      (2.0) Upgraded everything that could be updated (kernel 2.6.31-14,...)
      (2.1) Restart
      (3) Installed xorg-driver-fglrx (2:8.660-0ubuntu4) and all other dependencies which were needed from Synaptic
      (4.0) In terminal: "sudo aticonfig --initial -f"
      (4.1) A xorg.conf file was created (before there was no xorg.conf) with the following text:

      Section "ServerLayout"
      Identifier "aticonfig Layout"
      Screen 0 "aticonfig-Screen[0]-0" 0 0
      EndSection

      Section "Files"
      EndSection

      Section "Module"
      EndSection

      Section "Monitor"
      Identifier "aticonfig-Monitor[0]-0"
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"
      EndSection

      Section "Device"
      Identifier "aticonfig-Device[0]-0"
      Driver "fglrx"
      BusID "PCI:1:5:0"
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]-0"
      Device "aticonfig-Device[0]-0"
      Monitor "aticonfig-Monitor[0]-0"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      EndSubSection
      EndSection

      (4.2) Restart... XORG CRASHED!
      (5) I tried changing in xorg.conf BusID to "PCI:2:0:0" but it always crashes...
      (6) Finally I changed the name of xorg.conf so that it doesn't read it and now it works but, of course, no 3D acceleration
      PLEASE HELP!

      Shoul I install the fglrx manually?? following this guide: http://wiki.cchtml.com/index.php/Ubu...allation_Guide
      I don't know what else to do.
      Maybe you should try deactivate the internal card in the bios?

      EDIT:

      Hmm if you can't deactivate the internal card, is there some way you can deactivate hybrid in fglrx?
      Last edited by tball; 10-19-2009, 12:46 PM.

      Comment


      • #13
        Originally posted by tball View Post
        Maybe you should try deactivate the internal card in the bios?

        EDIT:

        Hmm if you can't deactivate the internal card, is there some way you can deactivate hybrid in fglrx?
        With the present bios 207 in this computer (ASUS M51Ta) it's impossible to activate or deactivate any of the integrated / discrete graphic cards. And if there is a way to deactivate from any other place I would be delighted to know how... May be with new kernel 2.6.32 and integrated radeonhd driver... I just have no idea.

        Comment


        • #14
          Hello, I wanted to share my frustration again with new fglrx 8.661 (ATI driver for Linux 9.10):

          Update: fglrx 8.661 with ASUS M51Ta still not working
          ================================================== ===

          Details:

          Linux: Ubuntu 9.10beta + all updates
          Kernel: 2.6.31-14
          fglrx: 9.10 (8.661)
          Hybrid graphic cards:
          01:05.0 VGA compatible controller: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]

          02:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3650

          Error (in Xorg.0.log):

          (EE) fglrx(0): Invalid video BIOS signature!
          (EE) fglrx(0): GetBIOSParameter failed
          (EE) fglrx(0): PreInitAdapter for slave 0 failed

          xorg.conf: http://pastebin.com/f9e7eb26
          Xorg.0.log: http://pastebin.com/f5f0bb023

          Comment


          • #15
            Latest bios used? Btw. i would NOT hardcode the device in the configfile. Put a # in front.

            Comment


            • #16
              Originally posted by Kano View Post
              Latest bios used?
              Yes, I have lastest BIOS 207. And unluckily, this BIOS does not allow to enable/disable any of the two graphic cards that M51Ta has (HD3650 & HD3200).

              Btw. i would NOT hardcode the device in the configfile. Put a # in front.
              Ok, I will try that and let you know. Thanks!

              Comment


              • #17
                The hybrid graphics spec requires that the SBIOS include the ability to select "integrated", "discrete" or "switchable" graphics, so that OSes other than Windows will work.

                There seem to be a few models which didn't follow the spec and therefore don't work with the Linux drivers. It's not a bug, but it is a problem for people who buy those laptops and expect to run something other than Windows on them.

                I'm trying to compile a list of offending laptop models to see if there is anything we can do in the driver, assuming we can't get the mfgs to update the BIOS and include the proper selection options.

                EDIT - when I was looking around at other sites to see if anyone had found switching options in the M51TA bios I kept running into your posts on those sites as well. Alex pushed some changes into the radeon driver recently which are not directly targeting this problem but might help - can you try the radeon driver from git master and see if that works for you ?
                Last edited by bridgman; 10-24-2009, 02:59 PM.

                Comment


                • #18
                  Now I didn't specify the PCI of the integrated graphic card. At least now it gave my another error, but it crashed the same:

                  Errors in Xorg.0.log:
                  (EE) AIGLX error: dlopen of /usr/lib/dri/r600_dri.so failed (/usr/lib/dri/r600_dri.so: cannot open shared object file: No such file or directory)
                  (EE) AIGLX: reverting to software rendering
                  ...
                  EE) open /dev/fb0: No such file or directory

                  xorg.conf: http://pastebin.com/f55906554
                  Xorg.0.log: http://pastebin.com/f56ef110

                  Any ideas??

                  Comment


                  • #19
                    The error messages are not a problem; the first two just indicate that you don't have an open source 3D driver built yet. Looking at conf and log files now.

                    EDIT - actually it looks like the X server is choosing the radeon driver anyways, which is good. Can you describe the crash ?
                    Last edited by bridgman; 10-24-2009, 03:04 PM.

                    Comment


                    • #20
                      Originally posted by bridgman View Post
                      The hybrid graphics spec requires that the SBIOS include the ability to select "integrated", "discrete" or "switchable" graphics, so that OSes other than Windows will work.
                      I already did a bug report to ASUS for the lack of BIOS enable/disable options for the graphic cards... But of course no answer.

                      I'm trying to compile a list of them to see if there is anything we can do in the driver, assuming we can't get the mfg to update the BIOS and include the selection options.
                      That would be great! Thanks, if there is anything I can do, please let me now.

                      Comment

                      Working...
                      X