Announcement

Collapse
No announcement yet.

Configure XRandR at Server Start - what am I doing wrong?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Configure XRandR at Server Start - what am I doing wrong?

    I'm trying to configure my dual head to that it's the way I want at server startup. I think I'm doing everything correctly, but it's not working. I'm using fglrx 8.62.4, which is 8.6 I believe. Here is my xorg.conf:

    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
    EndSection
    
    Section "ServerFlags"
    	Option	    "DontZap" "off"
    EndSection
    
    Section "Monitor"
    	Identifier   "Samsung_SM305T"
    	Option	    "PreferredMode" "2560x1600"
    	Option		"DPMS"	"true"
    EndSection
    
    Section "Monitor"
    	Identifier   "GNR_TS2000H"
    	Option "RightOf" "Samsung SM305T" 
    	Option "Rotate" "left"
    	Option "DPMS"	"true"
    EndSection
    
    Section "Device"
    	Identifier  "FGLRX_Video_Device"
    	Driver      "fglrx"
    	BusID       "PCI:3:0:0"
    	Option "DFP1" "Samsung_SM305T"
    	Option "DFP2" "GNR_TS2000H"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "FGLRX_Video_Device"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    		Virtual	4160 1600
    	EndSubSection
    EndSection
    But this doesn't do anything and I have to run the following command when I log in to get the screen looking the way I want it:

    Code:
    xrandr --output DFP1 --auto --output DFP2 --auto --rotate left --right-of DFP1
    Which works. What I am doing wrong?

    Thanks!

  • #2
    In the Device section, try changing

    Code:
    Option "DFP1" "Samsung_SM305T"
    Option "DFP2" "GNR_TS2000H"
    to

    Code:
    Option "Monitor-DFP1" "Samsung_SM305T"
    Option "Monitor-DFP2" "GNR_TS2000H"

    Comment


    • #3
      Just tried it, no joy. It gave me blank screen on startup, with the second monitor powering down into sleep.

      SSH also wouldn't work, so I had to power the machine down and boot into safe mode to change the setting back...

      Any other ideas?

      Comment

      Working...
      X