No announcement yet.

fglrx for mobile radeon x2300

  • Filter
  • Time
  • Show
Clear All
new posts

  • fglrx for mobile radeon x2300


    I have a HP laptop with a X2300 card, I am running 32bit ubuntu 8.04 (kernel is 2.6.24-24server) and fglrx 9.3 driver.

    When I search for linux driver in amd website for mobile radeon, it always give me 9.3 which is quite old. But in the 9.6 release note, it says that it does support mobile radeon x2300.

    But I always failed to install drivers beyond 9.3, say 9.4, 9.5 and 9.6. The error seems to be that the fglrx could not be compiled and installed.

    I have tried the way with automated install, and extract deb for ubuntu 8.04 with no luck at all. Got an error of compiling fglrx when running module-assistant build fglrx.

    Has any one with X2300 installed fglrx beyond 9.3?

    Thanks in advance.
    Last edited by versalar; 06-16-2009, 02:35 AM.

  • #2
    I'll check the release note - might be a typo, the X2300 shouldn't be on the "supported" list for 9.6.


    • #3
      lspci -nn|grep 0300


      • #4
        If X2300 is not supported, does anybody have an estimated timetable of when Mobility Radeon fglrx driver will catch up with Desktop version?

        My lcpci output.

        01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M64-S [Mobility Radeon X2300] [1002:7188]

        Originally posted by Kano View Post
        lspci -nn|grep 0300
        Last edited by versalar; 06-17-2009, 03:10 AM.


        • #5
          It's actually not a question of "catching up"... the mobility driver is in sync with the desktop driver and both of them dropped support for GPUs based on the 3xx-5xx core beginning with the Catalyst 9.4 release.