Announcement

Collapse
No announcement yet.

AMD Releases Catalyst 9.6 For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    That's nice. We've been all asking for Open Source graphics drivers and open specs for years. Now that AMD/ATI do it, we flame them. How cool are we?

    Granted, NVIDIA's binary only support is better as such, so I would probably by an NVIDIA card in the short term if that;s the only thing going (and I've been _this_ close to doing it a lil ago out of frustration with ati + ubuntu 9.04).

    But in the long run ATI and Intel are the way to go. And we should be respectful of them for doing the right thing.

    Comment


    • #17
      Originally posted by mendieta View Post
      That's nice. We've been all asking for Open Source graphics drivers and open specs for years. Now that AMD/ATI do it, we flame them. How cool are we?

      Granted, NVIDIA's binary only support is better as such, so I would probably by an NVIDIA card in the short term if that;s the only thing going (and I've been _this_ close to doing it a lil ago out of frustration with ati + ubuntu 9.04).

      But in the long run ATI and Intel are the way to go. And we should be respectful of them for doing the right thing.
      But providing open specs and drivers didn't fix any problems so of course people are still mad. Things are supposed to be instantly better when you do that.

      Comment


      • #18
        Originally posted by mendieta View Post
        That's nice. We've been all asking for Open Source graphics drivers and open specs for years. Now that AMD/ATI do it, we flame them. How cool are we?

        [...]

        But in the long run ATI and Intel are the way to go. And we should be respectful of them for doing the right thing.
        Their open source driver is a trash for rx600 cards and above, and their closed source drivers is a trash. So, am I going to be happy with buying something that doesn't work as it should because the company that makes it doesn;t even know how to make a driver for it.

        At least NVIDIAs closed source driver is so good that you don;t even wish for an open source one.

        Comment


        • #19
          If you're still using fglrx, you're doing it wrong.

          Comment


          • #20
            Everytime I see a new AMD fglrx release I start to laugh... and I can't stop. AMD Catalyst isn't a driver, it's a joke or just a bad dream.

            Comment


            • #21
              Originally posted by kensai View Post
              At least NVIDIAs closed source driver is so good that you don;t even wish for an open source one.
              It is better, for sure, but I have wished it was open at least once (with a horrible bug not freezing my machine on logout by using KDM. I had to switch to GDM in Kubuntu because of this. This is documented in launchpad, and it could never fixed (because it is closed source).

              Remember, the grass is always greener on the other side.

              Comment


              • #22
                Originally posted by mendieta View Post
                Remember, the grass is always greener on the other side.
                "The grass is always greener where the dogs are sh!tt!ing."

                Comment


                • #23
                  Originally posted by mendieta View Post
                  It is better, for sure, but I have wished it was open at least once ... Remember, the grass is always greener on the other side.
                  I second that. My laptop keeps making the screen a mess when it is on battery...

                  Comment


                  • #24
                    Originally posted by bojo42 View Post
                    oh no, the worst issue ever:
                    "System may stop responding when running Return to Castle Wolfenstein: Enemy Territory"

                    so even if i can have 3D on a 780g with the driver, i might not be able to use it for the only true reason
                    I also have a 780G. Why don't you just use the 3200HD driver?

                    Don't flame me. I am asking, because I don't know the answer
                    Last edited by Louise; 06-15-2009, 05:29 PM.

                    Comment


                    • #25
                      What the fuck! They said that that 9.6 would have support for 2.6.29, yet they FAIL to deliver on their promises ONCE AGAIN! I don't know what the fuck AMD's graphic driver development team has been doing all these months, but maybe they need a pay cut to encourage them to actually get work done. Seriously, this is ridiculous. Once again I will state that AMD needs to be sued for not providing a working product, since the hardware is useless without properly working drivers. And thus be forced to provide full refunds to all those with damages. After all, that's EXACTLY what they've done to those with X1000 and before. At the very LEAST they need to be forced to release the full source code since it does not contain anything that cannot be learned by disassembling the driver.

                      Comment


                      • #26
                        Originally posted by LavosPhoenix View Post
                        What the fuck! They said that that 9.6 would have support for 2.6.29, yet they FAIL to deliver on their promises ONCE AGAIN!
                        Uhm, when has AMD/ATI ever promised this? There was noone officially stating that the 9.6 release will have 2.6.29 support. There were many users speculating that it would be about time, but no single time any AMD/ATI official stated that this support would be included.

                        Comment


                        • #27
                          I am sick of those drivers and I will never buy ATI again even if 3d and KMS support will be added to open source drivers. I preffer Intel and Nvidia.

                          Comment


                          • #28
                            Originally posted by LavosPhoenix View Post
                            What the fuck! They said that that 9.6 would have support for 2.6.29, yet they FAIL to deliver on their promises ONCE AGAIN! I don't know what the fuck AMD's graphic driver development team has been doing all these months, but maybe they need a pay cut to encourage them to actually get work done. Seriously, this is ridiculous. Once again I will state that AMD needs to be sued for not providing a working product, since the hardware is useless without properly working drivers. And thus be forced to provide full refunds to all those with damages. After all, that's EXACTLY what they've done to those with X1000 and before. At the very LEAST they need to be forced to release the full source code since it does not contain anything that cannot be learned by disassembling the driver.
                            Who said that and when did they say that? I never heard AMD making any promisses about future driver releases. And did you really expect that they'd support a new kernel? You guys should know better by now... the first driver to support 2.6.29 or 2.6.30 will be 9.10, because thats when Ubuntu 9.10 gets released. So it will probably be a beta driver for Ubuntu. Don't expect these things earlier...

                            I'm getting a bit sick of all those people whining each month. AMD did lots of work to improve the situation over the last few years and in my opinion they definately succeeded. I agree the driver is not that good as nvidia's one, but it certainly does its work in most cases. Besides that, they opened up every possible document to write open source drivers. You guys really should applaud AMD for that, really... this is a huge step and most people posting here don't seem to appreciate that.

                            Comment


                            • #29
                              Every month the little dogs start yapping. It's hilarious really.

                              Comment


                              • #30
                                Originally posted by Heiko View Post
                                Who said that and when did they say that? I never heard AMD making any promisses about future driver releases. And did you really expect that they'd support a new kernel? You guys should know better by now... the first driver to support 2.6.29 or 2.6.30 will be 9.10, because thats when Ubuntu 9.10 gets released. So it will probably be a beta driver for Ubuntu. Don't expect these things earlier...

                                I'm getting a bit sick of all those people whining each month. AMD did lots of work to improve the situation over the last few years and in my opinion they definately succeeded. I agree the driver is not that good as nvidia's one, but it certainly does its work in most cases. Besides that, they opened up every possible document to write open source drivers. You guys really should applaud AMD for that, really... this is a huge step and most people posting here don't seem to appreciate that.
                                Yes I am with you 100%.

                                In fact AMD is opening their drivers, which nVidia doesn't.

                                We are in a very existing time right now, where AMD is changing how graphics is done on Linux. Forever.

                                To those that complain: Don't you think you are being just a little bit too egoistic?

                                No one have ever done what AMD is doing to Linux right now. Just imagine how much money and risk AMD is putting into Linux, to give us what we really want. Open Source drivers, and in the long run NEVER have to download or think about GFX drivers again. It just works out-of-the-box.

                                Comment

                                Working...
                                X