Announcement

Collapse
No announcement yet.

catalyst 9.6 is out

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by bridgman View Post
    Just so you understand why we aren't spending all our time on the newest kernels, we have a number of workstation customers running on RHEL 4.7 which AFAIK uses a modified 2.6.9 kernel. No that is not a typo. Yes we have to support it.
    I know that - and I am gratefull that people who don't use mainstream distros or compile their own kernels aren't left out. BUT:
    2.6.29 is out for MONTH
    2.6.28 is not supported by the STABLE tree anymore.

    Comment


    • #12
      Originally posted by lordmozilla View Post
      What bridgeman is saying is that their dev team is inferior I think...
      Actually iirc you usually have to use older driver versions with nVidia if you want to have support with older kernels. nVidia and AMD/ATi seem to have different target groups altogether. nVidia targets gamers with new kernels, AMD/ATi targets enterprise distros with older kernels. I doubt you'd get as fast updates with nVidia if they were also required to do backwards compat as far as AMD/ATi apparently does (2.6.9? That's amazing). With nVidia if you want to use older kernels you need to also use older unmaintained drivers so it's as if they think enterprise users wouldn't exist at all.

      Comment


      • #13
        nvidia's latest official driver:
        Software Element
        Min Requirement
        Check With...
        Linux kernel 2.4.7 cat /proc/version
        XFree86/X.Org 4.0.1/6.7 XFree86 -version/Xorg -version
        Kernel modutils 2.1.121 insmod --version

        so your theory has some holes.

        Comment


        • #14
          Originally posted by energyman View Post
          so your theory has some holes.
          It's based on what I've personally experienced. Every nVidia driver version I tried was strictly limited to a range of kernel versions outside which it would either not compile or would run badly. (I did use nVidia for years on Linux before moving to an ATi card)

          Comment


          • #15
            Come on, AMD guys, this is starting to get a bit sad now. As said above 2.6.29 is at least three months old now (because 2.6.30 is out).

            Isn't it time you branch the 2.6.9 code away from the 2.6.29 code in your driver? I can't imagine your code being in a healthy state at the moment, supporting that vast range of kernels.

            Interesting thing here, btw: you are supporting a 2.6.9 kernel for RHEL4.7 and 4.8, but you stopped supporting older cards in the recent drivers? Huh? Wouldn't you expect RHEL4.x workstations to sport those exact old cards? I mean, why have old software on a new machine?
            Last edited by wzzrd; 06-15-2009, 05:22 PM.

            Comment


            • #16
              Originally posted by wzzrd View Post
              Interesting thing here, btw: you are supporting a 2.6.9 kernel for RHEL4.7 and 4.8, but you stopped supporting older cards in the recent drivers? Huh? Wouldn't you expect RHEL4.x workstations to sport those exact old cards? I mean, why have old software on a new machine?
              Good point, I highly doubt the companys using RHEL4 are using R6xx/7xx cards

              Comment


              • #17
                Originally posted by bridgman View Post
                Just so you understand why we aren't spending all our time on the newest kernels, we have a number of workstation customers running on RHEL 4.7 which AFAIK uses a modified 2.6.9 kernel. No that is not a typo. Yes we have to support it.
                I see, workstation customers use Radeon HD 3XXX series+ on RHEL 4.7 and stick to kernel 2.6.9 for stability, and they so much want a Catalyst 8.7 (hint: doesn't support r500). <sarcasm>Mmm, I just got a Core-i7 with RadeonHD 4870 and I would so much want to run a brand new distro called RHEL 4.99 with kernel 2.6.9.137, or better yet, 2.4.31 with nptl.</sarcasm> A wonderful company has wonderful customers too.

                Dude, you guys have been caught slacking . Even if you did spend your time on rhel, please dont say it as it makes your company and customers look silly.

                Comment


                • #18
                  I think the idea is to enable hardware upgrades while still supporting in-house apps which haven't been upgraded for newer systems. I will double-check re: the impact of dropping support for older GPUs though.

                  hdas, if putting in extra work to support what our largest customers ask for is slacking, then I guess we're slacking...
                  Last edited by bridgman; 06-15-2009, 07:31 PM.

                  Comment


                  • #19
                    I thought I read somewhere that the 2.6.30 kernel allowed for installing catalyst without patching. Has anyone tried?

                    So far I've only tried 2.6.30 kernel in 64 bit with catalyst 9-5 and it would not install. I haven't tried with 32 bit yet. Maybe in next couple of days.

                    BTW, for the newer qt4 and kde4 as part of slackware current, I compiled a 2.6.27.15 kernel and catalyst 9-5 installed and worked OK. Besides addition of a wireless driver or two and a TV-card driver, I haven't noticed much improvement in performance with newer kernels. If I wasn't trying out slackware-current I would be perfectly happy with a 2.6.27 kernel.

                    Comment


                    • #20
                      Originally posted by bridgman View Post
                      hdas, if putting in extra work to support what our largest customers ask for is slacking, then I guess we're slacking...
                      And now, guess *why* those are your largest customers Because it sucks for the rest.

                      Comment

                      Working...
                      X