Announcement

Collapse
No announcement yet.

ATI Overclocking Utility

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by brelkl View Post
    I can see the values correctly in the 'Info' tab, and in the 'Overdrive' tab everything looks normal except the voltage, which shows as being set to it's maximum of 1300mV (instead of 1258mV shown in 'Info'). The fan speed is grayed out, but I can activate it by clicking the check box to the left.
    Let's put aside the voltage difference since it might happen because the voltage would be throttled after the app started. However try putting the voltage a little bit lower than the max value, try say 1258mv since that's what it was in the info that. Do you still have the error when you click ok? If so verify with aticonfig if any of the new value shows up.

    Comment


    • Originally posted by sabby View Post
      Let's put aside the voltage difference since it might happen because the voltage would be throttled after the app started. However try putting the voltage a little bit lower than the max value, try say 1258mv since that's what it was in the info that. Do you still have the error when you click ok? If so verify with aticonfig if any of the new value shows up.
      So I did some tests, and this is what I found:
      • I can set the GPU clock lower or higher with atioc, and verify it with 'aticonfig --od-getclocks'
      • I can set the memory clock higher, but not lower (lower gives the "error:-1", and is unchanged in aticonfig)
      • The voltage is the same as the memory--I can go higher (or the same value) but not lower without the "error:-1"; however, even when I set it higher it doesn't show the change on the info tab
      • Also, after I get an "error:-1" I can't change anything any more unless I click "restore defaults"

      Comment


      • Originally posted by brelkl View Post
        So I did some tests, and this is what I found:
        • I can set the GPU clock lower or higher with atioc, and verify it with 'aticonfig --od-getclocks'
        • I can set the memory clock higher, but not lower (lower gives the "error:-1", and is unchanged in aticonfig)
        • The voltage is the same as the memory--I can go higher (or the same value) but not lower without the "error:-1"; however, even when I set it higher it doesn't show the change on the info tab
        • Also, after I get an "error:-1" I can't change anything any more unless I click "restore defaults"
        Just a few more test I would like you to run try with aticonfig to set the memory clock lower at the same value that cause the app to have a -1 error. I don't have the at the aticonfig utility here but I believe it should be something like that

        Code:
        aticonfig --od-setclocks=0,1100
        I suspect that your card might have a gpu bios with wrong values, as in it report min/max range that it won't accept as input value it will only accept value that it reports in its peak range. This would fit what the test result you have seen.

        Comment


        • Originally posted by sabby View Post
          Just a few more test I would like you to run try with aticonfig to set the memory clock lower at the same value that cause the app to have a -1 error. I don't have the at the aticonfig utility here but I believe it should be something like that

          Code:
          aticonfig --od-setclocks=0,1100
          I suspect that your card might have a gpu bios with wrong values, as in it report min/max range that it won't accept as input value it will only accept value that it reports in its peak range. This would fit what the test result you have seen.
          Hi sabby, I tried applying the memory clock value above (1100) via cl and got an error:

          Code:
          ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 3870
                  Please check that input values were valid
          Then I ran 'aticonfig --odgc' again and realized that the results I'm getting are totally consistent with the ranges it reports (I'm not sure if this is what you mean in your comment):

          Code:
          Configurable Peak Range : [300-885]     [1152-1387]
          So I can change the clock values within those ranges--which is ok--but what I'd really like to do if it's possible is change the voltage (undervolt) a little. Do you think my lack of voltage control is a bios limitation/issue?

          Comment


          • How can you set the voltage with "aticonfig"?

            Comment


            • You can't, as far as I understand it. I was talking about the ATI Overclocking Utility.

              Comment


              • Originally posted by brelkl View Post
                Do you think my lack of voltage control is a bios limitation/issue?
                Well at least we found what the problem is. As far as I know those values come from the gpu bios, so I would say that it is a bug in their bios. They could at least return a min/max that is the same as the peak values. I am not sure if you card was meant to support the value reported by min/max and that is the bug or if it wasn't meant to support those value and the bug is the value reported in min/max. In any case, your options are limited. You can contact your card manufacturer, edit your bios to change the value and reflash it or flash another 3870 which is known to work with the value you want on your card. The last two options are riskier, not guaranteed to work and could result in your bricking your card.

                Comment


                • Originally posted by sabby View Post
                  Well at least we found what the problem is. As far as I know those values come from the gpu bios, so I would say that it is a bug in their bios. They could at least return a min/max that is the same as the peak values. I am not sure if you card was meant to support the value reported by min/max and that is the bug or if it wasn't meant to support those value and the bug is the value reported in min/max. In any case, your options are limited. You can contact your card manufacturer, edit your bios to change the value and reflash it or flash another 3870 which is known to work with the value you want on your card. The last two options are riskier, not guaranteed to work and could result in your bricking your card.
                  Thanks sabby, I appreciate your help in trying to figure this out--I may look in to fashing the bios at some point, when I have the time.

                  Comment


                  • Originally posted by sabby View Post
                    I remember releasing a fix that allowed to go lower. However if you are already using the latest version 1.0.5 and that's the lowest you can go then I will check on that. Before I was talking the lowest performance level reported by the card bios in a later version I switch to the lowest frequency reported by the API. Since on my card I couldn't go lower then the lowest setting (it would freeze even with undervolting) reported by the API I couldn't test see if the card accepts lower value then what the API says it will take. Perhaps I can try allowing 1 Mhz and then people can see if it works, worst case there is the same functionality as before and best case it works.
                    Any news on this? I'm using 64 bit version, ATI HD4870.
                    This is the one thing I deeply need on Linux Ubuntu at the moment, save tons of watts by lowering memory.

                    Comment


                    • Hm, apparently I can't edit my post.
                      However, I'm wondering (if you'd like to share it) how you bypass ATI Overdrive's limits? Since apparently using Overdrive only lets me go to 775 MHz/950 MHz (default), but you application lets me go to 390/475. I'm very interested in how.

                      Comment


                      • Originally posted by Glaucous View Post
                        Hm, apparently I can't edit my post.
                        However, I'm wondering (if you'd like to share it) how you bypass ATI Overdrive's limits? Since apparently using Overdrive only lets me go to 775 MHz/950 MHz (default), but you application lets me go to 390/475. I'm very interested in how.
                        Sorry for the late reply I didn't get the new reply notice. I don't bypass anything since I assume the Overdrive command line use the same API that I do. What must be happening is like I did before maybe the command line use the minimum frequency reported in the lowest performance level instead of the lowest frequency reported by the min/max functions.

                        Comment


                        • Originally posted by Glaucous View Post
                          Hm, apparently I can't edit my post.
                          However, I'm wondering (if you'd like to share it) how you bypass ATI Overdrive's limits? Since apparently using Overdrive only lets me go to 775 MHz/950 MHz (default), but you application lets me go to 390/475. I'm very interested in how.
                          At the same time I wanted to clarify that I assume the command line also use the ATI ADL SDK, and I just don't call the overdrive utility command line like a front-end but the API directly. Therefore, if there is a bug in the API it should show up in both application but if we use the API differently, like it seems in this case, the behavior could be different.

                          Comment


                          • Originally posted by sabby View Post
                            At the same time I wanted to clarify that I assume the command line also use the ATI ADL SDK, and I just don't call the overdrive utility command line like a front-end but the API directly. Therefore, if there is a bug in the API it should show up in both application but if we use the API differently, like it seems in this case, the behavior could be different.
                            I see, thanks. As soon as I've learned some more C++ I'll take a look at ATI ADL SDK.

                            Comment


                            • @sabby

                              I've written a Python wrapper of the Overdrive5 functionalty of ADL using Cython. It seems I cannot go over the 1050 mV voltage limit with my 5970 with ADL_Overdrive5_ODPerformanceLevels_Set.

                              Were you able to get around this limit in your over-clocker? I see a screenshot with 1158 mV ... though probably for a different card ...

                              Ideally I would like to explore 5870 voltages ...like 1.1625v

                              Comment


                              • Originally posted by emuller View Post
                                @sabby

                                I've written a Python wrapper of the Overdrive5 functionalty of ADL using Cython. It seems I cannot go over the 1050 mV voltage limit with my 5970 with ADL_Overdrive5_ODPerformanceLevels_Set.

                                Were you able to get around this limit in your over-clocker? I see a screenshot with 1158 mV ... though probably for a different card ...

                                Ideally I would like to explore 5870 voltages ...like 1.1625v
                                All the voltage are card specifics, you can see the maximum I could achieve by running the apps on your card. I assume it should be the same as you. The only thing is that different card have a different number of performance levels which min/max are different from the card min/max if my memory is good. I don't know if it's card specific but on my card I could not set a value for a lower level which was higher than a higher level, e.g. I could not set an idle value higher then the full speed performance level. However, all this is transparent in the app so the maximum it will let you set it should be the maximum your card will take. Unless, like someone else in the forum, your card's bios report the wrong values.

                                Comment

                                Working...
                                X