Announcement

Collapse
No announcement yet.

ATI Overclocking Utility

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    @mtippett & Melcar: thanks


    Btw, its possible to have an integration with the sensor applet in gnome & lm-sensor?

    With my previous 8800gt i had the gpu and ambient temp on the panel.


    Ps: i have a 4870 x2, the temp is referred to just one gpu? And the freq changes to both?

    Comment


    • #92
      I don't have an X2, but according to the author the frequency value applies to both. I'm guessing the temperature reading as well (an average perhaps?) As for the temperature reading, I know you can do it under KDE (there is a plasmoid, and ksysguard can also read it once you set it up), but I'm not sure under GNOME.

      Comment


      • #93
        This software is just what I need. I have HD4870 which I have to underclock, I save at least 30w by underclocking it.

        I'm just wondering if it is possible to bypass your limit on underclocking? My stock clocks are 775/950, and the lowest I can go is 390/475, I'd like to go to at least 150/200.

        Comment


        • #94
          Originally posted by Glaucous View Post
          I'd like to go to at least 150/200.
          Take care, going so low requires undervolt

          Comment


          • #95
            Originally posted by elect View Post
            Take care, going so low requires undervolt
            Not a problem, I can undervolt with this software to 1083 mV, which is what I used in Windows. I'm able to go as low as 0.93 mV in Windows, but that requires me to use RivaTuner and so on.

            Comment


            • #96
              hey I downloaded the b6 version and tried to run but no succes;(
              in my previous install of ubuntu 9.10 i could run it

              ubuntu 9.10 (32) with libqtcore4, libqtgui4 installed

              http://nl.tinypic.com/r/2vwcy2v/6

              Comment


              • #97
                I have to check my email filters all of a sudden and don't get thread notifications anymore... A few answer comments on the last few posts.

                Originally posted by elect View Post
                Ps: i have a 4870 x2, the temp is referred to just one gpu? And the freq changes to both?
                As I am using the ATI ADL SDK it only present x2 card as one, so the frequency changes both but there is just one temp for both gpu. Somebody more familiar with the actual ASIC could comment if there is actually two sensor and if this will be exposed later in the SDK, also if there are actually two sensor how is the temperature exposed via the API calculated in the current API version.

                This software is just what I need. I have HD4870 which I have to underclock, I save at least 30w by underclocking it.

                I'm just wondering if it is possible to bypass your limit on underclocking? My stock clocks are 775/950, and the lowest I can go is 390/475, I'd like to go to at least 150/200.
                I remember releasing a fix that allowed to go lower. However if you are already using the latest version 1.0.5 and that's the lowest you can go then I will check on that. Before I was talking the lowest performance level reported by the card bios in a later version I switch to the lowest frequency reported by the API. Since on my card I couldn't go lower then the lowest setting (it would freeze even with undervolting) reported by the API I couldn't test see if the card accepts lower value then what the API says it will take. Perhaps I can try allowing 1 Mhz and then people can see if it works, worst case there is the same functionality as before and best case it works.

                hey I downloaded the b6 version and tried to run but no succes;(
                in my previous install of ubuntu 9.10 i could run it

                ubuntu 9.10 (32) with libqtcore4, libqtgui4 installed

                http://nl.tinypic.com/r/2vwcy2v/6
                The latest version is 1.0.5, and the later versions requires libqtnetwork because of the System Monitor (ksysguard) daemon.

                Comment


                • #98
                  I have a 5850, but the Voltage is already at the maximum, how can i go over?

                  Comment


                  • #99
                    Originally posted by elect View Post
                    I have a 5850, but the Voltage is already at the maximum, how can i go over?
                    Easily I believe you can't, those parameter coming from the API are taken from the card's bios. You would have to download one of the ati bios editor that is floating around on the internet, change the value and reflash your bios. A little bit troublesome but possible.

                    Comment


                    • and be carefull with flashing the bios and changing parameters. 'Grey screen of death' is probably caused with voltage/clock interacting when changing clock speed and voltage levels.

                      Comment


                      • Hey--I'm running Ubuntu 9.10 (x64), and when I try to change any settings with atioc (1.05) I get "Error setting overdrive parameter, error:-1". I have the requisite qt libs installed and have a HD3870 that supports overdrive (as far as I know)--does any one know what this error means?

                        Comment


                        • Originally posted by brelkl View Post
                          Hey--I'm running Ubuntu 9.10 (x64), and when I try to change any settings with atioc (1.05) I get "Error setting overdrive parameter, error:-1". I have the requisite qt libs installed and have a HD3870 that supports overdrive (as far as I know)--does any one know what this error means?
                          Unfortunately the -1 error is a generic error returned by the API which in this case most likely indicates that overdrive 5 is not supported. What ati catalyst version are you running? Some users with the latest catalyst 10.4 beta reported that overdrive 5 was now working on their HD2600 when before it wasn't. So you might want to try the latest driver. I don't remember the catalyst release note mentioning new OD5 support but maybe they don't put that in the release notes, someone else can comment on that. You can always verify if it's something wrong with my application by using aticonfig to see if OD5 support is working

                          Code:
                          aticonfig --od-getclocks
                          I believe the command line utility aticonfig also use the amd adl sdk api.

                          Comment


                          • Thanks for the reply sabby--I'm running Catalyst 10.3. When I run aticonfig this is what I get:
                            Code:
                            $ aticonfig --od-getclocks
                            
                            Default Adapter - ATI Radeon HD 3870
                                                        Core (MHz)    Memory (MHz)
                                       Current Clocks :    300           1152
                                         Current Peak :    800           1152
                              Configurable Peak Range : [300-885]     [1152-1387]
                                             GPU load :    0%
                            Does this mean OD5 support is active? Or do I need to try the latest Catalyst?

                            Thanks again!

                            Comment


                            • Originally posted by brelkl View Post
                              Thanks for the reply sabby--I'm running Catalyst 10.3. When I run aticonfig this is what I get:
                              Code:
                              $ aticonfig --od-getclocks
                              
                              Default Adapter - ATI Radeon HD 3870
                                                          Core (MHz)    Memory (MHz)
                                         Current Clocks :    300           1152
                                           Current Peak :    800           1152
                                Configurable Peak Range : [300-885]     [1152-1387]
                                               GPU load :    0%
                              Does this mean OD5 support is active? Or do I need to try the latest Catalyst?

                              Thanks again!
                              That means that at least the major part of OD5 is supported, you should be seeing those value also in the GUI? Does the app contains those value when you start it or is it all blank? If it does contain those value then I'm assuming the error is probably related to fan speed throttling not being supported, I have seen that many time so far. It would show up as the fan control area being grayed out.

                              Comment


                              • Originally posted by sabby View Post
                                That means that at least the major part of OD5 is supported, you should be seeing those value also in the GUI? Does the app contains those value when you start it or is it all blank? If it does contain those value then I'm assuming the error is probably related to fan speed throttling not being supported, I have seen that many time so far. It would show up as the fan control area being grayed out.
                                I can see the values correctly in the 'Info' tab, and in the 'Overdrive' tab everything looks normal except the voltage, which shows as being set to it's maximum of 1300mV (instead of 1258mV shown in 'Info'). The fan speed is grayed out, but I can activate it by clicking the check box to the left.

                                Here's some screenshots of the tabs:

                                Comment

                                Working...
                                X