No announcement yet.

Multiseat getting closer.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Multiseat getting closer.

    Well so I finally managed to get my multi-seat up and running. Its pretty stable, screens turn off (DPMS). The last big remaining problem i have is I can only seeming shutdown the computer by pulling the plug. Shutdown hangs, also having issues with suspend( but I can understand that not working). Any suggestions, is there at least some way i can make it so I don't have to run fsck on next boot. Like forcing it to write all data to disk. Note I can login, logoff ok. If ok means that it takes logon screen about 20 seconds to appear from last logoff. I think my computer boots quicker than the time it takes for switch users. I can't find anything in my xorg log that looks suspicious any other logs I should be looking at? I hope there's some sort of hack job i can do so i don't have to worry about corruption

  • #2
    I read you did this with 2 ATi cards. Could you tell me how you did this?

    For the shutdown problem, same here.
    • When 2 users are logged in and 1 of them decides to shutdown, it just doesn't.
    • It does not shutdown from within Gnome/KDE. Only gdm.
    • "shutdown -P now" always works somehow.
    It seems the xserver / gdm does not get killed properly.


    • #3
      My Setup for multi Seat

      heres xorg.conf
      HTML Code:
      then in gdm.conf
      command=/usr/X11R6/bin/X -novtswitch -sharevts -nolisten tcp -layout Seat0
      command=/usr/X11R6/bin/X -nolisten tcp -novtswitch -sharevts -layout Seat1

      Note: I am messing with the isolatedevice command, but I haven't been able to get that from freezing up on login. If u tell me specifics I might be able to help as I have reconfigured more times than there is sand in the sea. I will give that shutdown thing u mentioned a shot after i post this.


      • #4
        nope that didn't work

        yeah i tried that shutdown command.
        It says its shutting down, but it lies
        It freezes computer very similar to regular shutdown.


        • #5
          Oh just to be clear I can't even properly shutdown if both seats are on login screen.


          • #6
            My Bad

            I put wrong file up, here's my current stable xorg.conf
            HTML Code:


            • #7
              I thought you managed it through OSS drivers. Too bad .


              • #8
                In my multiseat setup using nvidia cards (proprietary driver) I can shut down if all screens except one are at the login manager (kdm).

                Attempts to shutdown the system when more than one person has an active session results in the shutdown hanging.


                • #9
                  Thanks Cmorrow, Well I guess that means its either gdm or fgrlx.

                  As far as the radeon oss drivers go, I have tried them but the best I could do was get people loged in, logout crashed and burned with one of the two seats always.


                  • #10
                    I originally started my multiseat setup with ATI hardware. There's a few postings about it buried in this forum.

                    I was able to get 2 seats setup using a Radeon 3850 and a 4850 using the fglrx driver (Catalyst 9.4). Both seats were hardware accelerated and ran pretty reliably. For kicks, I tested out playing Unreal Tournament 2004 (linux amd64) on both seats at the same time (worked great).

                    I was never able to get the OSS drivers to work reliably, although I admittedly didn't test much because I was looking for 3D acceleration.

                    The biggest issue I had was that I could not get DPMS to work in the setup.

                    I'm not sure if that information will help your case testing at all since I have not used GDM at any point in the process. The process took some time to work out and I had to do a lot of xorg.conf editing to get it to work.

                    I'm very excited to see that Multiseat is getting some much needed love in Fedora 12s upcoming features (although I switched away from Fedora to Ubuntu several years ago) and I imagine that it will only get better from here.


                    • #11
                      yes i remember your posts i referred to them a couple of times. Yeah i think the DPMS issue you had is solved, I had exact same problem. Maybe 9.5 fixed it(I'm not sure but thats my guess). but monitors will, turn off, not just blank. Yeah of course, I haven't gotten suspend, resume to work yet. I've been concentrating on this shutdown problem.

                      I think all these issues really get better once they get consolekit up and running with multiseat. Anyone good ideas with sound in multiseat. I've seen some stuff on pulseaudio. It would be nice if could throw the usb sound devices in xorg.conf as another device. Maybe you can but i haven't seen anything on that.


                      • #12
                        I've been meaning to try this out (

                        The MDM (Multiseat Display Manager) WIKI seems like it has some good resources regarding some of these issues.

                        For me, I eventually ended up removing PulseAudio and have been using standard ALSA. I don't have it running perfectly, as very occasionally other users will login and my speakers will start playing their sounds.

                        If you do try the solution I posted, please let me know how well it works. I just haven't had the time / patience to mess around with it right now.


                        • #13
                          Well, I got the sound working. I actually used kind of a derivation of the method cmorrow pointed to. I used pulseaudio with user sessions, and writing a short script that launches pulseaudio with different (eg. Doing this you have to modify . Comment out all the restore default devices options ( at least I did) And then add one line to set the default sink as the one you want per seat. This allows hotseating. The sound card will be now tied to the seat instead of the user. I talked to some of the pulseaudio developers. And they recommended that I should fix console kit. And not do this hackery with there precious. They also suggested if i wanted a temporary fix I should make some udev rules and disable something with hal. But it is all working perfect for me so.