No announcement yet.

AMD Catalyst 9.5 Driver For Linux Released

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Why disable legacy code if you have not removed it, for two drivers releases yet, as far as I can tell people with older cards could still have used 9.5 if only the legacy code was enabled. You are keeping it there, so why not enable it, until you remove it completely?
    The main reason is that we are not testing it at any part in our development process. The change was made in sync with Windows.


    • #12
      "The Catalyst 9.5 driver release notes do not mention much, in fact they are basically a facsimile of the Catalyst 9.4 driver release notes. "

      It's 3 years I read this sentance. 3 years.


      • #13
        Originally posted by Kano View Post
        [30761.185566] [fglrx:firegl_find_any_map] *ERROR* Invalid map handle!<3>[fglrx:drm_vm_close] *ERROR* map not found -> inconsistent kernel data!!! vma_start:0xb7de2000,handle:0xd0100000

        errors when you run dmesg?
        These error message would be considerably more valuable with a quick summary of the system information that it is occuring on.


        Is a great start. If it looks like it is a broad-based issue, then a report makes a world of difference rather than disparate messages in the forums.


        • #14
          It's a shame. I can see a video with compositing active on Hackintosh and Windows but not in Linux.

          Fglrx is trash


          • #15

            Host/Kernel/OS "Kanotix" running Linux 2.6.30-5-generic i686 [ Kanotix Excalibur 20090506-17:27 ]
            CPU Info (1) Intel Core2 Duo E8400 @ clocked at [ 1999.000 MHz ]
            (2) Intel Core2 Duo E8400 @ clocked at [ 2999.000 MHz ]
            Videocard ATI Mobility Radeon HD 3450 X.Org 1.4.2 [ 1680x1050 ]
            Processes 153 | Uptime 10:47 | Memory 640.5/1977.8MB | HDD Size 1000GB (7%used) | GLX Renderer ATI Radeon HD 3450 | GLX Version 2.1.8664 | Client Shell | Infobash v2.67.1

            Of course there are unofficial patches used, one of it is a kernel patch.


            • #16
              For those of you who saw a regression in ubuntu 9.04 (cards that used to work in 8.10 and no longer work with catalyst) ... did this fix the issue?

              Thank you


              • #17
                again, who is forcing you to use some unsupported kernels? Stick with the stuff the distributions give you and stop whining.


                • #18
                  I create the distro, i patch the kernel, the driver...


                  • #19
                    and what forces you to use the latest kernel for your distro?


                    • #20

                      I don't see a reason why a 3d driver should force me to use an older one.