Announcement

Collapse
No announcement yet.

catalyst 9.5 seems to be out.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by NeoBrain View Post
    Did anyone try to create a second X server instance with this release?
    (i.e. "xinit -- :2")
    I'll try as soon as I can get an ebuild made. But I normally run with two x servers - is there any reason to believe it shouldn't work?

    Comment


    • #47
      ebuild is easy: copy/reanme the ebuild you used for 9.4. Change 9.4 to 9.5 in the download-url in the ebuild. Copy the patches dir in files/ ebuild ....ebuild manifest... done. Less than a minute.

      Comment


      • #48
        Originally posted by energyman View Post
        ebuild is easy: copy/reanme the ebuild you used for 9.4. Change 9.4 to 9.5 in the download-url in the ebuild. Copy the patches dir in files/ ebuild ....ebuild manifest... done. Less than a minute.
        I timed you, it took 63 seconds.

        Comment


        • #49
          Can any one sucessfully run 9.5 on a gentoo machine with xorg-server-1.5.3-r6? X server reports failing to start xwindow but no error shown in the log...

          These are last lines from the log...
          (II) AIGLX: Loaded and initialized /usr/X11R6/lib/modules/dri/fglrx_dri.so
          (II) GLX: Initialized DRI GL provider for screen 0
          (II) fglrx(0): Enable the clock gating!
          (II) fglrx(0): Setting screen physical size to 376 x 301
          (II) fglrx(0): Shutdown CMMQS
          (II) fglrx(0): [drm] removed 1 reserved context for kernel
          (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x34000 at 0xb8099000

          Comment


          • #50
            I am sure there is a lot more in the log that that useless snippet.

            Comment


            • #51
              In other words please use pastebin to show the entire log (http://www.pastebin.com, .ca, .whatever).

              Comment


              • #52
                Ok, my entire log can be readed at:
                http://pastebin.ca/1425026

                Comment


                • #53
                  retry with 2.6.28 and 2.6.29 without patches. Does it work?

                  Comment


                  • #54
                    Originally posted by doubledr View Post
                    Can any one sucessfully run 9.5 on a gentoo machine with xorg-server-1.5.3-r6? X server reports failing to start xwindow but no error shown in the log...

                    These are last lines from the log...
                    (II) AIGLX: Loaded and initialized /usr/X11R6/lib/modules/dri/fglrx_dri.so
                    (II) GLX: Initialized DRI GL provider for screen 0
                    (II) fglrx(0): Enable the clock gating!
                    (II) fglrx(0): Setting screen physical size to 376 x 301
                    (II) fglrx(0): Shutdown CMMQS
                    (II) fglrx(0): [drm] removed 1 reserved context for kernel
                    (II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x34000 at 0xb8099000
                    Can you post your xorg.conf?

                    Comment


                    • #55
                      fglrx + wine = hard lockup

                      I am getting hard lockups (can't ctrl+alt+backspace out) only when I use wine...

                      I am using the latest Wine + the latest fglrx, what should I log? Can anyone point that out?

                      Thanks.

                      Comment


                      • #56
                        Originally posted by energyman View Post
                        retry with 2.6.28 and 2.6.29 without patches. Does it work?
                        Same result. But I have to patch catalyst 9.5 for installing in 2.6.29.

                        Originally posted by mtippett View Post
                        Can you post your xorg.conf?
                        here it is: http://pastebin.ca/1425198

                        and the full xorg log is here: http://pastebin.ca/1425026

                        BTW, I don't know if this is related, I installed libdrm-2.4.11 package for my xserver 1.5.3-r6.

                        Comment


                        • #57
                          Catalyst 9.5 is still crashing Counter-Strike 1.6 on startup, in very similar way 9.4 was doing, even with old XServer 1.4. I'm stick with 9.3 and XServer 1.4 now, and I must block package upgrading on my Debian machine, which makes me sad I didn't test any other wine-powered game yet, but I can do it if it would be useful.

                          Comment


                          • #58
                            Hello!

                            Anyone getting these kind of wierd messages:
                            [fglrx:firegl_find_any_map] *ERROR* Invalid map handle!<3>[fglrx:drm_vm_close] *ERROR* map not found -> inconsistent kernel data!!! vma_start:0x7f2bf5b2a000,handle:0xd10a0000

                            Full dmesg here: http://pastebin.com/m7a2eeb9d
                            xorg.conf: http://pastebin.com/m4d62215a

                            Using Archlinux with latest updates. Kernel is 2.6.29. Catalyst is installed from AUR(http://aur.archlinux.org/index.php).
                            Last edited by Zetbo; 05-17-2009, 09:16 AM.

                            Comment


                            • #59
                              AFAIK Catalyst 9.5 doesn't support Linux kernel 2.6.29.
                              Last edited by Wielkie G; 05-17-2009, 12:28 PM.

                              Comment


                              • #60
                                Originally posted by Wielkie G View Post
                                Catalyst 9.5 is still crashing Counter-Strike 1.6 on startup, in very similar way 9.4 was doing, even with old XServer 1.4. I'm stick with 9.3 and XServer 1.4 now, and I must block package upgrading on my Debian machine, which makes me sad I didn't test any other wine-powered game yet, but I can do it if it would be useful.
                                I can confirm that . Bad news for Ubuntu 9.04 users - we can't go back with Catalyst 9.3 for some reason.

                                Comment

                                Working...
                                X