Announcement

Collapse
No announcement yet.

catalyst 9.5 seems to be out.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by RealNC View Post
    Yeah, it's the video I usually stick to someone's face when they say "there's no tearing" :P
    I don't see why a video contructed to be bad shows anything...

    with 'normal' material there is no tearing - normal like 30FPS.

    Comment


    • #32
      Now just listen to yourself...

      The video is *not* constructed to be bad. It's the drivers that make it look bad. The video is just fine. Care explaining why you think it's "constructed to be bad?"

      Comment


      • #33
        well, it has 60FPS, right? and shows the problem, right?
        But I have never seen similar with 30FPS video material which is also a standard, while 60FPS is not.

        Comment


        • #34
          RealNC... does playing your movie super smooth with no tearing on 9.4 with no composite counts too ?

          Comment


          • #35
            Originally posted by lem79 View Post
            Alpha blur still doesn't work (apparently it never has, according to another member here .. as if, ATI devs, come on ).
            It worked fine before they introduced their new codebase (maybe even with the first few release after that, but since 8.47 I can tell for sure)... That's still quite some time now though, I wonder how hard it can be to fix a simple effect like that :-/

            Comment


            • #36
              Upgraded my Arch to 9.5 right now (4850), first impressions below.

              Improvements:
              • resizing / restoring windows is noticeably faster with Compiz. Still far from instantaneous, but better than before.
              • GLSL support officially bumped to 1.3. This was actually supported before, but the drivers still reported 1.2.
              • Plain 2d seems somewhat faster than before, e.g. when scrolling a terminal. Could be the placebo effect.

              Regressions: no visible regressions.

              Remaining issues:
              • No VSync with GLX_ARB_create_context. VSync with obsolete contexts works fine (i.e. via glXCreateContext). This is ridiculous, this issue was reported in January! Makes me wonder, are there no partners using OpenGL 3.0 on FireGL boards for VR? I know we are using Nvidia exclusively (precisely because of issues like this), but it's somewhat disappointing.
              • No vertical synchronization in plain 2d, Xv or compiz.
              • Scrolling under Compiz is still (IMHO, unusably) slow.

              Comment


              • #37
                I've noticed that when running KDE4's kwin with desktop effects on. It vsync's videos automatically when using opengl as renderer.
                Might be because kwin with DE's uses vsync by default...Im not sure could it be because of that?

                Comment


                • #38
                  And it works great

                  Comment


                  • #39
                    Originally posted by energyman View Post
                    well, it has 60FPS, right? and shows the problem, right?
                    But I have never seen similar with 30FPS video material which is also a standard, while 60FPS is not.
                    The problem is there with every video. 60FPS just makes it more apparent to people who don't perceive it otherwise. Videos are tearing for me regardless of FPS. DVDs too, and they're 25FPS.


                    Originally posted by Tares View Post
                    RealNC... does playing your movie super smooth with no tearing on 9.4 with no composite counts too ?
                    No. The point was Xv, not OpenGL. In any case, having to disable composite every time I wish to watch a video is rather suboptimal, I'd say :P


                    Originally posted by blindfrog View Post
                    I've noticed that when running KDE4's kwin with desktop effects on. It vsync's videos automatically when using opengl as renderer.
                    Might be because kwin with DE's uses vsync by default...Im not sure could it be because of that?
                    KDE 4 disables compositing automatically every time you switch an application to full screen, but it's not much help. As soon as you invoke the media players controls, it has to switch compositing back on and hell arrives :P The GUI goes into a "slow as molasses" mode and graphical glitches show up.

                    Comment


                    • #40
                      My understaning is that OpenGL compositors *can* sync their output to vblank, if their implementors choose so. From discussions I have read, Compiz uses a sync method (glXWaitVideoSyncSGI) that does not, and indeed cannot, work in systems with preemptive multitasking. Their reasoning is that regular VSync (via glXSwapControlSGI and glXSwapBuffers) require an approach with a large performance impact.

                      Interestingly, Compiz does fall back to regular VSync under heavy load. Try running the Compiz benchmark: windows start moving smoothly, exactly as they should. Independent contributors have created patches that fix this issue, but the patches were rejected.

                      In any case, I am intrigued by your post, blindfrog. Last time, I rejected KDE4 because of broken font rendering (issue allegedly fixed in Qt 4.5). A tear-free compositor may be just enough to get me to switch DEs.
                      Last edited by BlackStar; 05-16-2009, 07:36 AM.

                      Comment

                      Working...
                      X