Announcement

Collapse
No announcement yet.

FGLRX 9.4 and F11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FGLRX 9.4 and F11

    Hi,
    I finally got fglrx 9.4 working on fedora 11 preview.
    The problem is, as soon as NetworkManager wants to connect to the W-LAN network the Xserver freezes. I have a rt61 w-lan chipset and a rv700 graphics chipset.
    Xorg.log doesn't have any error message in it.
    Would be great if anyone had a solution for that serious problem

    greetings

    Domi

  • #2
    Are you sure that just X freezes? Currently there seems to be a problem in the rt2x00 drivers that locks up the whole system. I have no problem with kernel 2.6.28 (which uses rt61pci driver ver. 2.2.1) but as soon as i try a newer kernel, the compat-wireless package or the backports package which all use ver 2.3.0 of the driver my machine starts experiencing lock-ups even when idling without any significant traffic. AFAIK F11 uses kernel 2.6.29 so the problem is likely in the driver.

    Comment


    • #3
      the thing is, that the problem only occurs when I try to start X with the fglrx driver. If I use the open source radeon driver, everything works fine.
      I am not sure if only X freezes or the whole system, because I can't do anything but pressing the reset button when this problem occurs.

      Comment


      • #4
        fglrx 9.4 doesn't support x700 cards anymore...

        edit: oops How did I read it as x700?

        You could try to paste Xorg.0.log.old and kern.log after failed startup. Also you can remove NetworkManager packet to test if it is realy causing the freeze. (The bests way to debug what realy is freezing is to use another box and ssh to inspect what is going on after output to screen have frozen)
        Last edited by suokko; 05-03-2009, 11:10 AM.

        Comment


        • #5
          I finally got fglrx 9.4 working on fedora 11 preview.
          Can you please tell me how you created the fglrx 9.4 RPMs or if you did not do that, how you installed fglrx 9.4 on F11 Preview. Thanks!

          Comment


          • #6
            I also would be interested in how your got 9.4 running with f11. I really tried a lot yesterday to get it somehow working. Would be looking forward in a brief description what you did to manage it running. Especially I am looking for a patch to get the driver running somehow. thx

            Comment


            • #7
              HOW DID YOU DO IT???? PLEASE TELL US!!!

              I have Fedora 11 beta installed and its ready but I am a NOOB as I cant get these drivers to work on anything....

              Comment


              • #8
                I investigated further and found a version of the patch that finally "seems to work". I posted a thread in the german fedora forum:
                http://www.fedoraforum.de/viewtopic.php?f=31&t=17841
                Is german, but might be better than nothing.

                However: If you are a newbie... simply wait. The way I decribed there does not work (!). The driver seems to compile and load fine. However after starting up a DE the x server just have a few seconds to live. It is absolutly unusable and you are risking to brick your system (especially, if you are not good in console). You'll have to wait. I finally give up on getting it somehow working. If anyone got it running, would be great

                Comment


                • #9
                  *sigh* Hope it is working soon.. Could you please let me know if you get it?

                  Comment


                  • #10
                    I am guessing the new 9.5 Driver wont help ???

                    Comment


                    • #11
                      Wow 933 views and only 9 replies

                      Comment


                      • #12
                        @ phobeus
                        I am not a newbie, and I understand German perfectly well ...
                        I am just not sure if I should risk it again to destroy my GUI or not

                        Comment


                        • #13
                          @Domi09: In fact my post was directed to ap90033, because you didn't react on his post. So I am still interested in who you did try it and especially which from the patches you used. I already wrote, I am also start to think that it is not a problem with the graphic driver directly. I also think that the problem might have something todo with the network manager. However, I have no clue about what's the problem. I have no wlan chip... but I am quite sure that not every RTL Chip should be effected. So I am still looking for any interesting idea ... and willed to risk the GUI ... fixing it again is getting very easy after some tries

                          In fact these strange freeze are quite common. However the only issue is the map problem in the dmesg that fills the logs. All are reporting this problem, but there are quite many systems it is working very well. So I guess this one is not "our" problem. But I ran out of ideas ...

                          @ap90033: No 9.5 does not fix the problem at all.

                          Comment


                          • #14
                            Any idea as to when we can expect a working driver? Sad that I have a $400 ATI 4870X2 video card with a Core i7 running 3.8 GHZ and cant even run Unreal Tournament in Linux.. lol
                            Last edited by ap90033; 06-14-2009, 01:17 AM.

                            Comment


                            • #15
                              ap90033, are you also running F11 ? Are you also having the same network manager issue ?

                              There are working Catalyst drivers today for the directly supported OSes (Ubuntu, RHEL, SLE*), but sounds like there are may be issues with F11.

                              Comment

                              Working...
                              X