No announcement yet.

FGLRX 9.4 and F11

  • Filter
  • Time
  • Show
Clear All
new posts

  • FGLRX 9.4 and F11

    I finally got fglrx 9.4 working on fedora 11 preview.
    The problem is, as soon as NetworkManager wants to connect to the W-LAN network the Xserver freezes. I have a rt61 w-lan chipset and a rv700 graphics chipset.
    Xorg.log doesn't have any error message in it.
    Would be great if anyone had a solution for that serious problem



  • #2
    Are you sure that just X freezes? Currently there seems to be a problem in the rt2x00 drivers that locks up the whole system. I have no problem with kernel 2.6.28 (which uses rt61pci driver ver. 2.2.1) but as soon as i try a newer kernel, the compat-wireless package or the backports package which all use ver 2.3.0 of the driver my machine starts experiencing lock-ups even when idling without any significant traffic. AFAIK F11 uses kernel 2.6.29 so the problem is likely in the driver.


    • #3
      the thing is, that the problem only occurs when I try to start X with the fglrx driver. If I use the open source radeon driver, everything works fine.
      I am not sure if only X freezes or the whole system, because I can't do anything but pressing the reset button when this problem occurs.


      • #4
        fglrx 9.4 doesn't support x700 cards anymore...

        edit: oops How did I read it as x700?

        You could try to paste Xorg.0.log.old and kern.log after failed startup. Also you can remove NetworkManager packet to test if it is realy causing the freeze. (The bests way to debug what realy is freezing is to use another box and ssh to inspect what is going on after output to screen have frozen)
        Last edited by suokko; 05-03-2009, 11:10 AM.


        • #5
          I finally got fglrx 9.4 working on fedora 11 preview.
          Can you please tell me how you created the fglrx 9.4 RPMs or if you did not do that, how you installed fglrx 9.4 on F11 Preview. Thanks!


          • #6
            I also would be interested in how your got 9.4 running with f11. I really tried a lot yesterday to get it somehow working. Would be looking forward in a brief description what you did to manage it running. Especially I am looking for a patch to get the driver running somehow. thx


            • #7
              HOW DID YOU DO IT???? PLEASE TELL US!!!

              I have Fedora 11 beta installed and its ready but I am a NOOB as I cant get these drivers to work on anything....


              • #8
                I investigated further and found a version of the patch that finally "seems to work". I posted a thread in the german fedora forum:
                Is german, but might be better than nothing.

                However: If you are a newbie... simply wait. The way I decribed there does not work (!). The driver seems to compile and load fine. However after starting up a DE the x server just have a few seconds to live. It is absolutly unusable and you are risking to brick your system (especially, if you are not good in console). You'll have to wait. I finally give up on getting it somehow working. If anyone got it running, would be great


                • #9
                  *sigh* Hope it is working soon.. Could you please let me know if you get it?


                  • #10
                    I am guessing the new 9.5 Driver wont help ???