Announcement

Collapse
No announcement yet.

FGLRX 9.4 and F11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi bridgeman, first thanks for taking care for this old post. I am actually seems having a similiar problem. I am running F11 since Beta times and the main problem is that "fglrx" does not support the kernel 2.6.29. There are some fixes out there and it seems to be possible to compile and load the fglrx with F11. However, after a period of time < 15 seconds there is going something terribly wrong and the whole system hangs completly.

    It might be related to the network. The system does not seems to freeze in the login manager and it seems also to run for a while fine if using a very simple DE without accessing the net. But I was not able to trace down the problem into any direction, so I give up. I am without any 3D support since a month for now and really hoping that official support for the kernel 2.6.29 might fix the problem. This situation is totally nasty ... how can we ask for support, if we have to fix with inofficial patches that might be also the problem? As far as I know it is not possible to get working 3D with 48xx cards under F11... and the nearest solution seems to be the oss drivers.

    Comment


    • #17
      whoa stop the press, there are drivers out that work? I have tried Suse, Fedora, Ubuntu and NONE worked for me with Catalyst 9.3 and 9.4... I have an 4870X2 and it is hooked to a 1080P LCD TV BTW.
      So the latest drivers dont screw up the system?

      Comment


      • #18
        Originally posted by ap90033 View Post
        Any idea as to when we can expect a working driver? Sad that I have a $400 ATI 4870X2 video card with a Core i7 running 3.8 GHZ and cant even run Unreal Tournament in Linux.. lol
        Money spent on NVIDIA would be better investment NVIDIA has no problems providing drivers on Fedora 11 for old GeForce MX 4 440 and ATI has got problems with providing working drivers for they new graphic cards Isn't it ridiculous

        BTW. I remember when F10 came out then there were also issues with FGLRX drivers. They just suck and that's all

        Comment


        • #19
          I agree but I REALLY WOULD HATE TO get RID OF A $400 card just to spend more on one with same performance you know? It would be nice to know that it works in Linux current distros. I am wanting to try Fedora 11 will it work? ATI has 9.6 drivers out now...

          Comment


          • #20
            Fglrx 9.6 does NOT support kernel 2.6.29 which is default in F11. I'm praying that fglrx 9.7 will have support.

            There are instructions on fedoraforum.org (here) on how to downgrade the kernel for fglrx in F11. But don't be deceived, the default kernel will not load an unmodified fglrx module.
            Last edited by mklean; 07-10-2009, 03:36 PM.

            Comment


            • #21
              Well why do they LIE in the Release Notes and Say Kernel 2.6 and UP? That is very Misleading!

              Comment

              Working...
              X