Announcement

Collapse
No announcement yet.

Making ati fan speed persistent.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Making ati fan speed persistent.

    Hi,
    I want to make my fan speed persistent and want to set it to 100%. I am right now doing (which is not persistent across boots.)
    Code:
    aticonfig --pplib-cmd "set fanspeed 0 100"
    My Card is ATI Radeon 4670 HD running on ubuntu.
    Listing powerplay says :
    Code:
    aticonfig --lsp
    Error: POWERplay is not supported on your hardware.
    When I query for the fan speed it shows as
    Code:
    aticonfig --pplib-cmd "get fanspeed 0"
    Fan speed query:
    Query Index: 0, Speed in percent
    Result: Fan Speed: 23%
    When under load. If it is idle the Fan Speed would be 0. Load was tested as
    Code:
    atiode -P 600 -H localhost:0
    When it was showing as fan speed 0 I opened the cabinet and saw the fan was running though. So I am guessing it is running at minimum speed.
    Last edited by nascentmind; 04-18-2009, 03:55 PM.

  • #2
    Originally posted by nascentmind View Post
    Hi,
    I want to make my fan speed persistent and want to set it to 100%. I am right now doing (which is not persistent across boots.)
    Code:
    aticonfig --pplib-cmd "set fanspeed 0 100"
    My Card is ATI Radeon 4670 HD running on ubuntu.
    Listing powerplay says :
    Code:
    aticonfig --lsp
    Error: POWERplay is not supported on your hardware.
    When I query for the fan speed it shows as
    Code:
    aticonfig --pplib-cmd "get fanspeed 0"
    Fan speed query:
    Query Index: 0, Speed in percent
    Result: Fan Speed: 23%
    When under load. If it is idle the Fan Speed would be 0. Load was tested as
    Code:
    atiode -P 600 -H localhost:0
    When it was showing as fan speed 0 I opened the cabinet and saw the fan was running though. So I am guessing it is running at minimum speed.
    In Ubuntu what I did is simply go into "Startup Applications" found under "preferences" in the menu then created a new startup app, gave it the name "ATI Fanspeed" but name doesn't matter then simply pasted " aticonfig --pplib-cmd "set fanspeed 0 100" " in the line named "command"

    This should work with any linux OS. Simply paste aticonfig --pplib-cmd "set fanspeed 0 100" as the command to be executed at startup.

    Comment


    • #3
      I put the command in Xsetup for kdm. Located for me at /usr/share/config/kdm/Xsetup.

      Comment


      • #4
        More logical would be /etc/X11/Xsession.d .

        Comment

        Working...
        X