Announcement

Collapse
No announcement yet.

Catalyst 9.4, Ubuntu 8.10 -- Video Tearing -- Help!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 9.4, Ubuntu 8.10 -- Video Tearing -- Help!

    Even the low resolution video I am trying to play these days has tearing. Is there any hope for a solution?

    Here are the details of the system:

    Distribution: Ubuntu 8.10
    Kernel: 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux
    CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4000+
    Memory: 2Gb
    X.org: X.Org X Server 1.5.2
    GPU: X1250 Integrated into Motherboard (Chipset: "ATI Radeon X1200 Series" (Chipset = 0x791e))
    ati driver: Catalyst 9.4
    Video Player: mplayer and xine
    Output Device: HDMI
    Display: Sony KDL-52XBR4
    Desktop: KDE and Ratpoison both with the same results.

    xorg.conf: created and using only: aticonfig --initial

    Symptom: Tearing across the screen on video playback for all resolution video. (320x200, 540x260, 640x480, 800x600, 1280x720, 1920x1080) XVID, MPEG2, H264. The higher the resolution, the worse the tear and the worse the Audio sync. Constant 3inch border around the entire screen.

    I am sure there you will probably need more info, so please let me know what other details you need.

    thanks for any help,

    -A
    Last edited by Antharian; 04-18-2009, 04:59 PM.

  • #2
    You mentioned CPU but I couldn't see any info on which GPU you are using. I don't think the driver has tear-free code for Xv yet, although playing through OpenGL with vsync enabled should work as long as you don't have a compositor running (not sure about compositor vs vsync status).

    The audio sync seems unrelated to graphics driver, not 100% sure though.

    Is the border only when playing videos or all the time ? If all the time, there should be a setting in CCC to get rid of the underscan now.

    Comment


    • #3
      Well a/v sync problems can be because of high cpu load, that cpu is too slow for h264 in full hd. Get a nvidia 8+ card, use vdpau enabled mplayer or xine-lib with vdpau and forget ATI.

      Comment


      • #4
        Originally posted by bridgman View Post
        You mentioned CPU but I couldn't see any info on which GPU you are using. I don't think the driver has tear-free code for Xv yet, although playing through OpenGL with vsync enabled should work as long as you don't have a compositor running (not sure about compositor vs vsync status).

        The audio sync seems unrelated to graphics driver, not 100% sure though.

        Is the border only when playing videos or all the time ? If all the time, there should be a setting in CCC to get rid of the underscan now.
        I knew I would miss something....

        GPU: X1250 Motherboard Integrated for an HTPC
        Chipset: "ATI Radeon X1200 Series" (Chipset = 0x791e)

        I'll update the original post to contain it as well.

        -A

        Comment


        • #5
          Originally posted by bridgman View Post
          You mentioned CPU but I couldn't see any info on which GPU you are using. I don't think the driver has tear-free code for Xv yet, although playing through OpenGL with vsync enabled should work as long as you don't have a compositor running (not sure about compositor vs vsync status).

          The audio sync seems unrelated to graphics driver, not 100% sure though.

          Is the border only when playing videos or all the time ? If all the time, there should be a setting in CCC to get rid of the underscan now.
          The border is all the time... what is the CCC and where would I locate the changes to try fixing the underscan?

          As for the compositor, I couldn't honestly answer you. I've not purposefully turned anything on... so unless Ubuntu 8.10 does it by default, then I don't believe it's on.

          Thanks again for all the help.

          -A

          Comment


          • #6
            CCC is the Catalyst Control Center, ie the control panel. It normally gets installed along with the driver IIRC.

            Ubuntu turns on compositing automatically when you enable Desktop Effects.

            Comment


            • #7
              Originally posted by bridgman View Post
              CCC is the Catalyst Control Center, ie the control panel. It normally gets installed along with the driver IIRC.

              Ubuntu turns on compositing automatically when you enable Desktop Effects.
              I just finished going through the settings in the amdcccle and twiddling with them. The only one that really looked promising was under the Display Manager.

              DTV(1): Image Scaling -> Scale Image to full panel size.

              This option is selected and the border remains.

              The Max Resolution is detected at 1920x1080 and Max Refresh Rate of 60Hz.

              Any hints on where to look for the overscan settings?

              Additionally, there are no Desktop Effects turned on.

              Thanks in advance,

              -A

              Comment


              • #8
                As mentioned, the tearing is expected with this driver. The only solution is to disable desktop effects.

                The underscanning is also a driver issue. When the driver detects that you are connected to a TV, it automatically underscans (despite the fact that nobody uses CRTs anymore...).

                You can fix it by manually setting the display window and position like so:
                Code:
                aticonfig --set-dispattrib=tmds2i,positionX:0
                aticonfig --set-dispattrib=tmds2i,positionY:0
                aticonfig --set-dispattrib=tmds2i,sizeX:1920
                aticonfig --set-dispattrib=tmds2i,sizeY:1080
                Obviously change the above to match your display port and resolution. I always do this after gdm/kdm have started.

                Comment


                • #9
                  Believe it or not, modern LCD TVs overscan too, not just CRTs. A number of HDMI-attached, HD, LCD TVs enlarge the center section of the image by default in order to simulate CRT overscan. There's usually a menu option in the TV with a name like "show all pixels" to turn it off.

                  The result is that the user can't see menus etc on first boot. The driver (and apparently BIOS) default to underscanning on HDMI-connected HD TVs to compensate for this frequent default overscan.

                  Comment


                  • #10
                    Interesting. It seems bizarre that LCD TVs would overscan. Maybe it's to maintain compatibility with older video sources...

                    It's frustrating that there's no way to fix this through the Control Centre AFAIK.

                    Comment


                    • #11
                      Originally posted by James View Post
                      Interesting. It seems bizarre that LCD TVs would overscan. Maybe it's to maintain compatibility with older video sources...
                      Maybe - but then I read once that the reason CRTs overscan so much was to do with marketing, as it was found that when next to other Tvs in a shop the ones that overscaned more were perceived to be bigger and sold better than the ones that didn't.

                      Comment


                      • #12
                        Interesting. That might explain why so many modern TVs have the overscan enabled by default.

                        Comment


                        • #13
                          Bridgman, you're an AMD employee?

                          Comment


                          • #14
                            Yes, based out of Toronto (Markham). Joined ATI in 1998.

                            Comment


                            • #15
                              Neat. I actually did an internship at 55CV last year.

                              Comment

                              Working...
                              X