Announcement

Collapse
No announcement yet.

Suspend fails with fglrx 9.2/9.3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Suspend fails with fglrx 9.2/9.3

    Hello all,
    I have an old Dell D610 (R300) which was doing
    what I wanted (films, openarena, tv-out, suspend) with Fedora
    10 until 9.2 (or was it 9,1) arrived. Anyway 9.3 didn't help.

    Now suspend fails. Black screen as you try. The log file
    after reboot,thinks it succeeded. Does anyone have it working?
    Do I have to unload fglrx manually?
    Thanks for any clues - its a major hassle for me.
    Bill

  • #2
    Well hey! 9.3-2 fixed it. Thank you

    Comment


    • #3
      Hello,

      I've got the same kind of problem with OpenSuse 11.1.

      Where can I get this version 9.3-2 ?

      Thanks,
      Alexander

      Comment


      • #4
        Interesting how beta drivers fix problems. I notice nvidia do the same thing...

        Comment


        • #5
          Oops..I spoke too soon.
          9.3-2 is RPMfusions second packaging for Fedora
          of the AMD 9.3 driver.
          I think I got lucky - it did suspend a couple of times,
          but no longer does. It is probably not even anything to do with
          the driver...
          Sorry for the confusion.
          Bill

          Comment


          • #6
            I had problem originally resuming from a suspend, but I had compiz/beryl on (Ubuntu 8.10 64b + cat 9.2), and I eventually turned it off as it caused any windows opengl app to flicker crazily.

            Then at some point I suspended, and the machine resumed. (I assumed that something else that I did produced a fix as a side effect.)

            Fast forward a few weeks(today), I install 9.3 and turn on compiz/beryl again as it's supposed to be fixed. Well... it is. Opengl apps no longer flicker crazily with compizberyl enabled.

            Few hours later, nb has entered suspend, so I attempt to resume, freezes while drawing password entry dialog and fails to respond to crtl-alt-backspace, etc. Force power off -> turn off compositing.

            So it looks like enabling compositing + cat driver 9.2 & .3 are doing something that causes resume from suspend to fail.

            [EDIT]
            BTW This is on an MSI GT725-074US.
            [/EDIT]
            Last edited by cutterjohn; 04-13-2009, 07:38 AM.

            Comment

            Working...
            X