Announcement

Collapse
No announcement yet.

AMD Catalyst 9.3 Brings OpenGL Composite Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Originally posted by dcarpenter85 View Post
    Video playback with VideoOverlay on and opengloverlay off is black, and obviously not composited.
    Video output through the overlay can not be composited, since it bypasses the frame buffer completely. Can you try with VideoOverlay off and TexturedVideo on ?

    The black image is because Compiz over-writes the keying colour which would have otherwise made the video overlay pop up in that area. Video processing via the overlay doesn't fit with composited desktops, that's why we dropped it in later cards..
    Last edited by bridgman; 03-28-2009, 07:34 AM.

    Comment


    • #62
      @bridgman
      I see people here claiming that window resizes with composite active work for them now while others (including me) are still getting the 1FPS performance while resizing. And still others claim it sometimes works and sometimes doesn't.

      If possible, can you ask around if this was actually supposed to be addressed at all with 9.3?

      Comment


      • #63
        Crash when launching CCC

        I've just upgraded to 9.3 and I cannot launch CCC. It crashes the system with a black screen. I cannot switch to console - just hard reset.
        The performance seems similar to 9.2. I'm running Ubuntu 8.10 on HD2600 Mobility.

        Comment


        • #64
          Originally posted by bridgman View Post
          Video output through the overlay can not be composited, since it bypasses the frame buffer completely. Can you try with VideoOverlay off and TexturedVideo on ?

          The black image is because Compiz over-writes the keying colour which would have otherwise made the video overlay pop up in that area. Video processing via the overlay doesn't fit with composited desktops, that's why we dropped it in later cards..
          I will try this fix, but it still doesn't explain why open gl is not being composited.

          Comment


          • #65
            I just tried TexturedVideo on, and after opening a video my screen turns black and my system locks up forcing me to do a hard reboot. This is the same behavior I observed when trying to run glxgears or fgl_glxgears. Something is not right with this driver. Whenever I install catalyst drivers on linux I always follow wiki.cchtml.com just to make sure I install correctly. Is compositing supposed to work with the 9800 series cards or not?

            Here is a system log output for when the crash occurs.

            Mar 28 12:06:03 ubuntu kernel: [ 1175.021244] [fglrx] It's not necessary to adjust system aperture on this ASIC
            Mar 28 12:06:04 ubuntu gdm[6655]: WARNING: gdm_slave_xioerror_handler: Fatal X error - Restarting :0
            Mar 28 12:06:04 ubuntu kernel: [ 1175.815930] compiz.real[6881]: segfault at 5411 ip 08055c8c sp bfa46e50 error 4 in compiz.real[8048000+34000]
            Mar 28 12:06:04 ubuntu console-kit-daemon[5025]: GLib-GObject-WARNING: instance of invalid non-instantiatable type `(null)'
            Mar 28 12:06:04 ubuntu console-kit-daemon[5025]: GLib-GObject-CRITICAL: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
            Mar 28 12:06:04 ubuntu console-kit-daemon[5025]: GLib-GObject-CRITICAL: g_object_unref: assertion `G_IS_OBJECT (object)' failed
            Mar 28 12:06:05 ubuntu acpid: client connected from 7097[0:0]
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515009] [fglrx] AGP detected, AgpState = 0x1f004a1b (hardware caps of chipset)
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515020] [fglrx] [agp] enabling AGP with mode=0x1f004b1a
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515026] agpgart-intel 0000:00:00.0: AGP 3.0 bridge
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515059] agpgart-intel 0000:00:00.0: putting AGP V3 device into 8x mode
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515111] fglrx_pci 0000:01:00.0: putting AGP V3 device into 8x mode
            Mar 28 12:06:06 ubuntu kernel: [ 1177.515166] [fglrx] AGP enabled, AgpCommand = 0x1f004312 (selected caps)
            Mar 28 12:06:08 ubuntu kernel: [ 1180.145469] [fglrx] Setup AGP aperture
            Mar 28 12:06:08 ubuntu kernel: [ 1180.145749] [fglrx] GART Table is not in FRAME_BUFFER range
            Mar 28 12:06:08 ubuntu kernel: [ 1180.151111] [fglrx] Firegl kernel thread PID: 7107
            Mar 28 12:06:08 ubuntu kernel: [ 1180.153342] [fglrx] Reserved FB block: Shared offset:0, size:40000
            Last edited by dcarpenter85; 03-28-2009, 12:09 PM.

            Comment


            • #66
              For my HD3450 + HD3200 hybrid crossfire machine, with two screens connected to the HD3450 (a lcd monitor and a tv, not able to drag windows between them, so separate desktops), this is the first driver since 8.9 that allows me to change underscan/overscan/screensize options for my tv, without booting in a black screen afterwards!!!

              With the 9.2 release I couldn't play some dvd's (image was all blocky, very strange, even for different episodes of Heroes on a single dvd, the first episode worked fine, the second didn't...). This seems to be fixed in 9.3 again.

              I don't use desktop effects, but on my other pc (has an HD4870) I tried whether it works with OpenGL compositing. Glxgears behaves very nicely like shown on the video of the news article.

              There are still a few problems though:
              • Can't switch user on my HD3450+HD3200 box with two monitors, the screens turn black and the only option left is reset.
              • Can't turn desktop effects on on my HD3450+HD3200 box with two monitors, the screens turn black in this case as well... reset only option.
              • Glxgears gives an error message when the program ends. I have seen this error message many many times in many different driver releases. With some driver releases its there, with some others it isn't. Not sure whether it does harm... but it doesn't look nice.

              Would be great if these were fixed, I really would like to use some degree of desktop effects, but at the moment I can't because my HD3450+HD3200 machine won't work anymore then.

              Comment


              • #67
                I was expecting support for the 2.6.9 kernel, but I was disappointed.

                Comment


                • #68
                  Originally posted by glock24 View Post
                  I was expecting support for the 2.6.9 kernel, but I was disappointed.
                  I expected a working driver for my card since it is the last release supporting legacy hardware, but I was disappointed...

                  Comment


                  • #69
                    Does this support Fedora 10 ?

                    Comment


                    • #70
                      not happy about dropped support.

                      Comment


                      • #71
                        hm, is it possible that there are some AA related improvements? I am not sure but it seems like vegastrike looks a lot better - it might be wishfull thinking, so ....

                        Comment


                        • #72
                          Moronix; does not work with F10 AFAIK.

                          Comment


                          • #73
                            Overall it seems like a good release but it has introduced graphical corruption in Savage 2.

                            Comment


                            • #74
                              Originally posted by RealNC View Post
                              @bridgman
                              I see people here claiming that window resizes with composite active work for them now while others (including me) are still getting the 1FPS performance while resizing. And still others claim it sometimes works and sometimes doesn't.

                              If possible, can you ask around if this was actually supposed to be addressed at all with 9.3?
                              Is in CCC vsync set to always on ? I have the same issue. but if i turn it off it works like a charm.

                              Comment


                              • #75
                                For me the new driver does not work (as promised in the article).

                                My chipset is "ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP]".
                                The system is Ubuntu Linux 8.10 / amd64 / Gnome with compiz.

                                Has anyone had success with this or a similar configuration?

                                Moving a glxgears window looks like in the first movie.
                                Apparently the driver is not released yet - I hope this will be fixed before the last official release for my system!

                                Comment

                                Working...
                                X