Announcement

Collapse
No announcement yet.

Catalyst 9.2 on Fedora 10 x86_64 hangs on building

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 9.2 on Fedora 10 x86_64 hangs on building

    Hi

    After being on F8 for a LONG time (and never updating my driver once I got it working!!) I have installed Fedora 10 x86_64. My X1300 card desperately craves the ATI driver, so I tried to install it. Using the many FAQ's with the pre-built rpm's have not been successful. So I want to build my own packages.

    I have a fully patched Fedora 10 PC, running kernel 2.6.27.19-170.2.35.fc10.x86_64. I have downloaded the 9.2 Catalyst package from AMD, and extracted this. Then I downloaded the latest (2009-03-07) fglrx-packaging.git scripts from Phorogit and applied those to the extracted Fedora folder.

    When I run the ati-installer.sh script, it hangs after a little disk activity and the CPU usage goes to 100%. After adding a few echo lines to the packages/Fedora/ati-packager.sh script, I have discovered that the process hangs once it hits the RPMBUILD line.

    After removing the 2>&1 from the rpmbuild line, I can tell you that the last line printed to the screen before the 100% CPU occurs is:
    bash make.sh verbose
    Finally, if I make the script echo the rpmbuild line, this is what it produces:
    rpmbuild -bb --define _topdir /tmp/ATI-fglrx-8.582-1-7237-root --define _builddir /tmp/ATI-fglrx-8.582-1-7237-root/BUILD --define _rpmdir /tmp/ATI-fglrx-8.582-1-7237-root/RPMS --define _sourcedir /tmp/ATI-fglrx-8.582-1-7237-root/SOURCES --define _specdir /tmp/ATI-fglrx-8.582-1-7237-root/SPECS --define _srcrpmdir /tmp/ATI-fglrx-8.582-1-7237-root/SRPMS --define _tmppath /tmp/ATI-fglrx-8.582-1-7237-root/tmp --define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm --target x86_64 /tmp/ATI-fglrx-8.582-1-7237-root/SPECS/ATI-fglrx.spec > /tmp/ATI-fglrx-8.582-1-7237-root/ATI-fglrx_build.log
    So what do I do now? Your help is GREATLY appreciated.

    Louis

  • #2
    Bad parameters passed to make.sh

    Hi

    Sadly nobody has replied to my request yet. But I have done more debugging and discovered the following:
    • packages/Fedora/ati-packager.sh calls rpmbuild, as described in my post above.
    • ATI-fglrx_build.log confirms that the last line it parses is
    • + bash make.sh verbose
    • when the CASE statement is executed, the only Poitional Parameter is "verbose", and so no matches occur in the case statement, and an infinite LOOP is the result.
    • the make.sh file is found in the extracted folder ATI-9.2/fglrx-install.xxxxxx/common/lib/modules/fglrx/build_mod/make.sh

    Please help me to solve this problem.

    Thanks
    Louis

    Comment


    • #3
      I guess nobody bothered to answer because these things have been discussed here multiple times before in the last months...

      The fglrx developers don't really care about Fedora at all. They develop primarily for RedHat EL and Ubuntu. And with your GPU, you will soon be out of luck anyway (see recent posts about dropping support for R500 chips). If you plan to do frequent updates (like getting F11 as soon as it's out), you might just want to try whether radeon or radeonhd is already good enough for your needs.

      If not, see this thread for getting the current fglrx working on your machine: http://forums.fedoraforum.org/showthread.php?t=155503

      Comment


      • #4
        Thank you for the reply!

        Actually I have already been to that page and followed their method. I have also tried the one on the www.fedorafaq.org page. Both of them have not worked for me.

        Fedora 10 boots, but shows that blue and white text block line instead of the wispy planet (Plymouth). But when it boots, the glxgears drops from about 1350 FPS to 150 FPS.

        So the default boot uses OpenGL renderer string: Mesa DRI R300 20060815 TCL giving me 1350 FPS on glxgears, but my CPU usage goes to 80% (with glxgears using 55%).

        All I am asking is how to get the package to successfully build the rpm's.

        Again, thanks for the reply. Any more ideas will be willingly attempted.

        Louis

        Originally posted by Christian_L View Post
        I guess nobody bothered to answer because these things have been discussed here multiple times before in the last months...

        The fglrx developers don't really care about Fedora at all. They develop primarily for RedHat EL and Ubuntu. And with your GPU, you will soon be out of luck anyway (see recent posts about dropping support for R500 chips). If you plan to do frequent updates (like getting F11 as soon as it's out), you might just want to try whether radeon or radeonhd is already good enough for your needs.

        If not, see this thread for getting the current fglrx working on your machine: http://forums.fedoraforum.org/showthread.php?t=155503

        Comment


        • #5
          RPMBUILD in Infinite Loop running "bash make.sh verbose"

          One more bit of information:

          When I run the --buildpkg command it gets stuck with these processes:
          Code:
           3699 pts/0    S+     0:00 -bash
           3753 pts/0    S+     0:00 /bin/sh ./ati-installer.sh 8.582 --buildpkg Fedora/F10
           3777 pts/0    S+     0:00 /bin/sh ./packages/Fedora/ati-packager.sh --buildpkg F10
           3851 pts/0    S+     0:00 rpmbuild -bb --define _topdir /tmp/ATI-fglrx-8.582-1-3777-root --define _builddir /tmp/ATI-fglrx-8.582-1-3777-root/
           3919 pts/0    S+     0:00 /bin/sh -e /tmp/ATI-fglrx-8.582-1-3777-root/tmp/rpm-tmp.uLYTPN
           3928 pts/0    R+     1:58 bash make.sh verbose
          and the last lines of /tmp/ATI-fglrx-8.582-1-3777-root/ATI-fglrx_build.log shows:
          Code:
          + export AS_USER=y
          + AS_USER=y
          + pushd /tmp/ATI-fglrx-8.582-1-3777-root/BUILDROOT/ATI-fglrx-8.582-1.f10.x86_64/lib/modules/fglrx/build_mod
          /tmp/ATI-fglrx-8.582-1-3777-root/BUILDROOT/ATI-fglrx-8.582-1.f10.x86_64/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.582-1-3777-root/BUILD/ATI-fglrx-8.582
          + bash make.sh verbose
          My question is ... WHY?

          Has anyone successfully built this driver on Fedora 10 x86_64?

          Comment


          • #6
            I never succeeded in installing fglrx on F10 from the official installer, but the method described in the link I've posted before worked for me. However, I am on a 32bit system. Depending on the things you've already tried, you may have to clean something up first before trying that approach, like uninstalling the non-working official installer, or forcing a reinstall of the Xorg-server package. Or it may just be broken right now for your system and the current packages...

            I know it's tedious to search through the 215 pages (hint: use "Show Results as posts"), but that thread on fedoraforums really is your best chance of finding information about how to get it running!

            To reactivate plymouth, follow the description in the 3rd post here: http://forums.fedoraforum.org/showthread.php?t=204551

            Comment


            • #7
              Originally posted by Christian_L View Post
              The fglrx developers don't really care about Fedora at all.
              It's not about caring, they're being paid, they just can't keep up. I suggest you stick with at least one version back if you're going to use Fedora. I only moved to 10 now because of mencoder, but now I find firefox is screwed. Horribly slow free driver.

              Comment


              • #8
                Originally posted by Moronix View Post
                It's not about caring, they're being paid, they just can't keep up.
                Not paying enough people and not caring for decent driver support is really the same to me...

                Originally posted by Moronix View Post
                I suggest you stick with at least one version back if you're going to use Fedora. I only moved to 10 now because of mencoder, but now I find firefox is screwed. Horribly slow free driver.
                Radeonhd works already pretty well on my machine for everything except 3D, which I sometimes need for work. Luckily, I've been planning to get a new work laptop in the near future even before that recent announcement from ATI, so now I'll just buy that one earlier. And guess what, it won't have an ATI card (and I'll keep using the latest Fedora ).

                Comment


                • #9
                  Originally posted by Christian_L View Post
                  Not paying enough people and not caring for decent driver support is really the same to me...


                  Radeonhd works already pretty well on my machine for everything except 3D, which I sometimes need for work.
                  I'd say 3d support is a major thing. It's almost pointless to use a 3d card just for 2d. But besides that, last time I checked radeonhd doesn't work on all chips that fglrx works with, like some IGP crap I have.

                  Comment


                  • #10
                    Just curious which hardware you have. If it's 5xx or higher then radeonhd should support it, unless it's just a set of IDs we haven't heard about yet (in which case we'd want to get them added to both drivers).

                    The last holdout was acceleration on rs600 (the Intel FSB version of RS690), but I think agd5f got that working recently.

                    Comment

                    Working...
                    X