Announcement

Collapse
No announcement yet.

AMD solve the Wine Problem with Cat/Fglrx 9-4alpfa

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by tball View Post
    Actually resizing with compositing seems a lot faster than without composition :P That said, resizing isn't slow without resizing, don't worry.
    It looks they found magic fix for slow resizing - do it without resizing

    Comment


    • #32
      Originally posted by Game_boy View Post
      So the first driver with the fix is also the first driver that my X1950 PRO isn't supported in? Thanks AMD.
      LOL! My thought as well with my X1400 laptop chip. Well we can always find some comfort in that what 9.4 giveth, 9.5 taketh away.

      Comment


      • #33
        Originally posted by korpenkraxar View Post
        I guess you have not signed an NDA anyway so you are probably free to blab on. That said, how does suspend/resume, --set-powerstate and multiple screens work? The 2.6.29 linux kernel?
        I haven't signed a NDA

        suspend = works / resume = doesn't. But i don't know if it is gfx driver related.

        I don't got any multiple screens to try it on :-) But what version of opengl does 9.2 states? I mean when you run fglrxinfo?
        Last edited by tball; 03-10-2009, 05:16 PM.

        Comment


        • #34
          Originally posted by kraftman View Post
          It looks they found magic fix for slow resizing - do it without resizing
          Haha Changed now. Thx

          Comment


          • #35
            Originally posted by Game_boy View Post
            So the first driver with the fix is also the first driver that my X1950 PRO isn't supported in? Thanks AMD.
            Life gives, Life takes.

            Comment


            • #36
              I tried this one, but if i watch a (non hd) video with xv and compiz on then xorg eats up all the cpu even if it's only windowed. If compiz is switched off it's nearly perfect: very low cpu usage, but sadly there is tearing as well...

              Comment


              • #37
                So great news for ati 9-4 rc1 .
                If I want test this great work ,can some dear baby PM me how and where I can get it ?

                so thanks .

                Comment


                • #38
                  me too, I'd love to have a go with this

                  Comment


                  • #39
                    Originally posted by Game_boy View Post
                    So the first driver with the fix is also the first driver that my X1950 PRO isn't supported in? Thanks AMD.
                    the driver with the fix is the 9-3 catalyst... there is a beta to!

                    but·.. why not use the Opensource driver in the future ?

                    or buy a new cart ? for wine you need OpenGL3 ! X1950 only supports DX9!

                    Comment


                    • #40
                      Originally posted by RealNC View Post
                      Usually someone leaks them on the "dark" places. IRC and Usenet for example. Google doesn't find them, you have to know where to look. But it's nothing to go crazy about. If you find them, the result is simply a disappointment that comes earlier than if you had waited for the final version
                      uuuhhh Dark places ??? Like www.microsoft.com ?

                      or nvidia.com ?

                      Comment


                      • #41
                        Originally posted by questioneer View Post
                        with 9.4 videoproblems with compiz are gone
                        gtkperf delivers much better results
                        quakewars runs smoother

                        (thats compared to 9.2)

                        9.4 is no disappointment at all
                        uuuhh nice... the driver is much much much better as i use the driver,,,

                        i only use kde3,5 and no compisite ...

                        so i sould put the shit on

                        Comment


                        • #42
                          Originally posted by tball View Post
                          OMG, this 9.4 RC1 driver is awesome. KDE 4.2 resizing is fixed! Its very very fast, no latency at all and with composition on.
                          XV video with compositing also works very smooth now. I don't got misplaced video output or anything odd. I don't even get crashes when playing a video in fullscreen??? :O
                          Is this really the driver version we have waited so long for? Is this really THE driver without disappointments?
                          Everyone waiting for this driver to be released really has something to be excited over.
                          <<If this is something I should not be talking about, feel free to delete my post. I don't know how phoronix / ati takes thiese discussions.>>
                          EDIT:
                          Actually resizing with compositing seems a lot faster than without composition :P That said, resizing isn't slow without compositing, don't worry.
                          Be Happy AMD Rocks da House

                          and yes if you saying 9-2 is bad thats legal.. if you say 9-4 is "OMG, this 9.4 RC1 driver is awesome." thats agains the LAW !!!

                          LOL ..

                          I love AMD :-) and i do this agains the LAW !

                          Comment


                          • #43
                            Originally posted by korpenkraxar View Post
                            LOL! My thought as well with my X1400 laptop chip. Well we can always find some comfort in that what 9.4 giveth, 9.5 taketh away.
                            Be happy !!! BEEE HABBY nice Opensource driver's will come :-)

                            and for wine buy a new cart OpenGL3 is needet!

                            Comment


                            • #44
                              It can not work for me :
                              I use RHEL 5.3 server ,kernel 2.6.27.18 ,
                              with VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300] on my Dell inspiron 6000
                              ati-9.2 works fine .but when I install this rc1, fail for me

                              Code:
                              [Message] Kernel Module : Trying to install a precompiled kernel module.
                              [Message] Kernel Module : Precompiled kernel module version mismatched.
                              [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
                              AMD kernel module generator version 2.1
                              doing Makefile based build for kernel 2.6.x and higher
                              rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
                              make -C /lib/modules/2.6.27.18/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
                              make[1]: Entering directory `/usr/src/linux-2.6.27.18'
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_SetPageCache’:
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1205: warning: passing argument 1 of ‘set_memory_wb’ makes integer from pointer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1209: warning: passing argument 1 of ‘set_memory_uc’ makes integer from pointer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_SetPageCache_Array’:
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1236: warning: passing argument 1 of ‘KCL_SetPageCache’ makes pointer from integer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MEM_VM_GetRegionPhysAddrStr’:
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3269: warning: return makes pointer from integer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3270: warning: return makes pointer from integer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3271: warning: return makes pointer from integer without a cast
                              /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3273: warning: return makes pointer from integer without a cast
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
                                CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
                                LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
                                Building modules, stage 2.
                                MODPOST 1 modules
                                CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
                                LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
                              make[1]: Leaving directory `/usr/src/linux-2.6.27.18'
                              build succeeded with return value 0
                              duplicating results into driver repository...
                              done.
                              You must change your working directory to /lib/modules/fglrx
                              and then call ./make_install.sh in order to install the built module.
                              - recreating module dependency list
                              - trying a sample load of the kernel modules
                              failed.
                              [Error] Kernel Module : Failed to install compiled kernel module - please consult readme
                              I try use ./make_install.sh ,show out:
                              - recreating module dependency list
                              - trying a sample load of the kernel modules
                              failed

                              error inserting fglrx (/lib/modules/2.6.27.18/kernel/drivers/char/drm/fglrx.ko) cannot allocate memory

                              how do it ?
                              Last edited by hades; 03-11-2009, 12:21 AM.

                              Comment


                              • #45
                                Originally posted by hades View Post
                                It can not work for me :
                                I use RHEL 5.3 server ,kernel 2.6.27.18 ,
                                with VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300] on my Dell inspiron 6000
                                ati-9.2 works fine .but when I install this rc1, fail for me

                                Code:
                                [Message] Kernel Module : Trying to install a precompiled kernel module.
                                [Message] Kernel Module : Precompiled kernel module version mismatched.
                                [Message] Kernel Module : Found kernel module build environment, generating kernel module now.
                                AMD kernel module generator version 2.1
                                doing Makefile based build for kernel 2.6.x and higher
                                rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
                                make -C /lib/modules/2.6.27.18/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
                                make[1]: Entering directory `/usr/src/linux-2.6.27.18'
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_SetPageCache’:
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1205: warning: passing argument 1 of ‘set_memory_wb’ makes integer from pointer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1209: warning: passing argument 1 of ‘set_memory_uc’ makes integer from pointer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_SetPageCache_Array’:
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1236: warning: passing argument 1 of ‘KCL_SetPageCache’ makes pointer from integer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MEM_VM_GetRegionPhysAddrStr’:
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3269: warning: return makes pointer from integer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3270: warning: return makes pointer from integer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3271: warning: return makes pointer from integer without a cast
                                /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3273: warning: return makes pointer from integer without a cast
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
                                  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
                                  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.o
                                  Building modules, stage 2.
                                  MODPOST 1 modules
                                  CC      /lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
                                  LD [M]  /lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
                                make[1]: Leaving directory `/usr/src/linux-2.6.27.18'
                                build succeeded with return value 0
                                duplicating results into driver repository...
                                done.
                                You must change your working directory to /lib/modules/fglrx
                                and then call ./make_install.sh in order to install the built module.
                                - recreating module dependency list
                                - trying a sample load of the kernel modules
                                failed.
                                [Error] Kernel Module : Failed to install compiled kernel module - please consult readme
                                I try use ./make_install.sh ,show out:
                                - recreating module dependency list
                                - trying a sample load of the kernel modules
                                failed

                                error inserting fglrx (/lib/modules/2.6.27.18/kernel/drivers/char/drm/fglrx.ko) cannot allocate memory

                                how do it ?
                                "Mobility Radeon X300"

                                this cart is not supportet sorry.

                                the R300 parts still in the driver but its pointsless to hack this.

                                install the 9-2 or 9-3 !

                                Comment

                                Working...
                                X