Announcement

Collapse
No announcement yet.

AMD solve the Wine Problem with Cat/Fglrx 9-4alpfa

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Tares View Post
    Anyway, one thing is bugging me, if this 9.4RC is stripped from support of legacy cards, why it's bigger than 9.2 ?
    its bigger becourse they hold more files in it to support debian and xorg 7.2 7.3 they hat dev some xorg7.4 stuff and backport it to the 7.3 for debian!!!

    so overall they support more platformes and have a much much better driver becourse the driver do not fail if there diverenz programm versions!

    for me i use debian SID the driver works much better becourse the driver have more own files that not linket on the system files...

    Comment


    • Is there any patch removing "Testing use only"? Where can i find it?

      On my system (Arch x64 with KDEmod 4.2.1 and Qt4.5), unfortunately scrolling and resizing windows in kwin is much slower than on 9.2 catalysts.

      Comment


      • Originally posted by Qaridarium View Post
        its bigger becourse they hold more files in it to support debian and xorg 7.2 7.3 they hat dev some xorg7.4 stuff and backport it to the 7.3 for debian!!!

        so overall they support more platformes and have a much much better driver becourse the driver do not fail if there diverenz programm versions!

        for me i use debian SID the driver works much better becourse the driver have more own files that not linket on the system files...
        dude... seriously... dictionary.com -_-;

        Originally posted by Dinth
        Is there any patch removing "Testing use only"? Where can i find it?
        You have to copy signature file from official release to /etc/ati ;-)

        Comment


        • Hmm anybody know any patch I should patch wine with to get it working properly with fglrx? I can't get any direct3d apps to run.

          This is an example of running counter-strike:

          Code:
          $ wine hl.exe -console -game cstrike
          fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
          err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
          err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
          fixme:d3d:IWineD3DImpl_FillGLCaps OpenGL implementation supports 16 vertex samplers and 16 total samplers
          fixme:d3d:IWineD3DImpl_FillGLCaps Expected vertex samplers + MAX_TEXTURES(=8) > combined_samplers
          fixme:win:EnumDisplayDevicesW ((null),0,0x32f524,0x00000000), stub!
          err:wgl:X11DRV_wglGetPixelFormatAttribivARB unexpected RenderType(8)
          err:wgl:X11DRV_wglGetPixelFormatAttribivARB unexpected RenderType(8)
          fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 16
          fixme:shdocvw:ViewObject_SetAdvise (0x16d7d8)->(1 00000002 0x10ec410)
          fixme:shdocvw:PersistStreamInit_InitNew (0x16d7d8)
          fixme:shdocvw:WebBrowser_put_RegisterAsBrowser (0x16d7d8)->(ffffffff)
          fixme:shdocvw:WebBrowser_put_RegisterAsDropTarget (0x16d7d8)->(ffffffff)
          fixme:dsalsa:IDsDriverBufferImpl_SetVolumePan (0x180190,0x180118): stub
          fixme:winmm:MMDRV_Exit Closing while ll-driver open

          Comment


          • Originally posted by Tares View Post
            dude... seriously... dictionary.com -_-;
            You have to copy signature file from official release to /etc/ati ;-)
            yes... my english is bad but my nativ language german is bad to!

            he can use the cracket installer if he want...

            but yes the torrent file is not cracket

            Comment


            • Originally posted by RealNC View Post
              I don't think Kano's installer is supposed to work on Gentoo. I'm using Gentoo's "installer" (ebuild).
              copy&rename the 582 ebuild. Change SRC_URI to this:
              SRC_URI="${ATI_URL}/ati-driver-installer-8.60_RC1-x86.x86_64.run"
              remove the xen-patch from the ebuild (look for epatch)
              copy the files directory
              copy the installer to /usr/portage/distfiles (or whereever your DISTDIR) resides
              ebuild ebuild.ebuild manifest

              and then update the driver:
              quit X
              eselect opengl set xorg-x11
              emerge -u ati-drivers
              eselect opengl set ati
              reboot

              Comment


              • Originally posted by RealNC View Post
                I can't find anything I didn't already know in it :P The driver gets installed OK. But it's simply broken with KDE4 compositing. The last one that works is 9.1.
                works here with kde4.2.1....

                Comment


                • Can someone please run a direct3d app with wine? And see if they are able to do that.

                  Comment


                  • Can someone please run a direct3d app with wine? And see if they are able to do that.
                    Someone should test Oblivion. This is propably one of most problematic games under fglrx, which work perfect on other drivers.

                    Comment


                    • I haven't had breakages on any game in wine since the upgrade.

                      Can someone please run a direct3d app with wine? And see if they are able to do that.

                      Comment

                      Working...
                      X