Announcement

Collapse
No announcement yet.

Catalyst 9.2 Released, Still Fails To Deliver XvBA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by JeanPaul145 View Post
    I'm talking about simple basic operations like moving a program window or scrolling through something (like a website or a list of contacts, both work far from smooth).

    Here are the Xorg.0.log and the dmesg output.
    I've taken both snapshots of these logs while having fglrx uninstalled and my xorg.conf set to
    Code:
    Section "Device"
    	Identifier  "Configured Video Device"
    	Driver      "radeonhd"
    	Option      "AccelMethod" "exa" # default shadowfb
            Option      "DRI" "on"
    EndSection
    So drm module fails to load. be sure you compile r6xx-r7xx brunch of mesa/drm and be sure you copied drm.ko and radeon.ko to right places. It depends on distros. So you have to overwrite the existing ones.

    Comment


    • Originally posted by JeanPaul145 View Post
      I'm talking about simple basic operations like moving a program window or scrolling through something (like a website or a list of contacts, both work far from smooth).

      Here are the Xorg.0.log and the dmesg output.
      I've taken both snapshots of these logs while having fglrx uninstalled and my xorg.conf set to
      Code:
      Section "Device"
      	Identifier  "Configured Video Device"
      	Driver      "radeonhd"
      	Option      "AccelMethod" "exa" # default shadowfb
              Option      "DRI" "on"
      EndSection
      @rahman.duran:
      Yeah, I just did the whole process again, just to be sure I didn't miss anything on [url=http://xorg.freedesktop.org/wiki/radeonhd:r6xx_r7xx_branch]this page[/url. But I followed those instructions to the letter.
      You should note that I have a R7xx gfx card, for which the support is still quite incomplete, and I imagine that the HD3200 igp uses the R6xx driver. That might make a huge difference.
      Weird. I have the same IGP as you. Have you copied drm.ko and radeon.ko to the right places? On Ubuntu, it should be:

      /lib/modules/kernel-version/kernel/drivers/gpu/drm/drm.ko
      and
      /lib/modules/kernel-version/kernel/drivers/gpu/drm/radeon/radeon.ko

      check with lsmod if the drm module is really inserted and whether it's used by radeon (module).
      Last edited by susikala; 02-22-2009, 05:16 PM.

      Comment


      • Originally posted by rahman.duran View Post
        So drm module fails to load. be sure you compile r6xx-r7xx brunch of mesa/drm and be sure you copied drm.ko and radeon.ko to right places. It depends on distros. So you have to overwrite the existing ones.
        Ah. That might be the problem, as I actually mkdirred a drm dir in /lib/modules/2.6.27-11-generic/kernel/drivers/char/.
        OK, I'll try and fix that, and let you guys know what happens.

        EDIT: it is a big difference indeed!
        Scrolling works as smoothly as with fglrx now. nice!
        I can't wait to use this fulltime!
        Right now the main thing is working compiz with radeonhd, so I guess that would mean waiting for 3D support.
        Maybe someone can tell me: is 3D acceleration a must for compiz as a whole, or just for certain plugins? I ask because most (if not all) of the plugins I use look fairly 2D to me (think fadein and fadeout, and although not a compiz plugin, I also want/need AWN support).

        Also, I can't really test how radeonhd holds its own against fglrx in fullscreen video until compiz support is in a working state, since that was my problem in the first place - the whole gdm/X/fglrx/Mesa stack locks up if I forget to turn off compiz when watching a video.
        Last edited by JeanPaul145; 02-22-2009, 05:44 PM.

        Comment


        • Originally posted by bridgman View Post
          I *think* the "Unredirect Fullscreen Windows" option should let the video accel code go straight to the front buffer and skip the extra overhead.
          OMG! "Unredirect..." has been enabled for sooo long I completely forgot about it!
          I unchecked it & now have stable flicker free XV playback!

          My only trouble now is X going blank whenever I switch from battery to AC. I can CTRL-ALT into console & then back to X & problem is resolved...any ideas anyone?

          Comment


          • Same problem here, Powerplay seems to be broken in this release. I have a x1600 mobility but aticonfig say my hardware doesn't support powerplay. And just like you or Oyvind I have a blank screen when I switch form battery to AC (the auto-powerstate is still enabled??).

            So I'm back to 9-1 and I hope this will be fixed in the Catalyst 9-3.

            I'm using Kubuntu 8.10 x86
            Last edited by rafi; 02-22-2009, 05:43 PM.

            Comment


            • Same problem here, Powerplay seems to be broken in this release. I have a x1600 mobility but aticonfig say my hardware doesn't support powerplay. And just like you or Oyvind I have a blank screen when I switch form battery to AC (the auto-powerstate is still enabled??).
              It seems
              Code:
              aticonfig --auto-powerstates=off
              solves the problem for now.

              Comment


              • Originally posted by JeanPaul145 View Post
                Ah. That might be the problem, as I actually mkdirred a drm dir in /lib/modules/2.6.27-11-generic/kernel/drivers/char/.
                OK, I'll try and fix that, and let you guys know what happens.

                EDIT: it is a big difference indeed!
                Scrolling works as smoothly as with fglrx now. nice!
                I can't wait to use this fulltime!
                Right now the main thing is working compiz with radeonhd, so I guess that would mean waiting for 3D support.
                Maybe someone can tell me: is 3D acceleration a must for compiz as a whole, or just for certain plugins? I ask because most (if not all) of the plugins I use look fairly 2D to me (think fadein and fadeout, and although not a compiz plugin, I also want/need AWN support).

                Also, I can't really test how radeonhd holds its own against fglrx in fullscreen video until compiz support is in a working state, since that was my problem in the first place - the whole gdm/X/fglrx/Mesa stack locks up if I forget to turn off compiz when watching a video.
                Well, we have gone a lot off topic If you want to use compiz composite then you have to wait for 3D support. It is not about the effects dimension but it is about how compositing manager does its job; via OpenGL or Xrender. compiz only supports opengl as I know. But kde 4.x compositing supports both opengl and xrender. So you can use composite effects on kde 4.x with xrender option (as we have nice exa accel for our radeonhd ).

                Comment


                • If you're running Gnome you might want to give Metacity a try.

                  Comment


                  • Originally posted by susikala View Post
                    Weird. I have the same IGP as you. Have you copied drm.ko and radeon.ko to the right places? On Ubuntu, it should be:

                    /lib/modules/kernel-version/kernel/drivers/gpu/drm/drm.ko
                    and
                    /lib/modules/kernel-version/kernel/drivers/gpu/drm/radeon/radeon.ko

                    check with lsmod if the drm module is really inserted and whether it's used by radeon (module).
                    Sorry for more offtopic, but i tried radeonhd as well and i wasn't successful. I'm using Ubuntu Hardy, but i don't have a directory named 'gpu' in /lib/modules/kernel-version/kernel/drivers .

                    Comment


                    • I think Hardy has the older drm layout; the gpu folders were added fairly recently. Look for an existing file called radeon.ko ; that's the folder you want.

                      Comment

                      Working...
                      X