Announcement

Collapse
No announcement yet.

Compiz blur with fglrx

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiz blur with fglrx

    Hi,

    When using the blur plugin in compiz on ubuntu intrepid, the window borders that should be blurred simply turn dark grey. I'm told this is because of the fglrx driver missing something.
    Is there any chance that fglrx will pickup support for this, or is there a known workaround?

  • #2
    Hi,

    I have noticed this too.

    I've been searching for an answer on this question for a long time.

    Here, it doesn't work on the open source (radeon) driver either.

    I think that blurred window borders still are not possible with ATI AMD cards.

    Comment


    • #3
      Maybe it's just Compiz? A lot of people like to blame everyone else's code except theirs, which makes it really hard to troubleshoot for endusers. The blur effect does nothing on my HD3850 (fglrx) or on a 9800pro (radeon) I have on a spare machine.

      Comment


      • #4
        fglrx doesnt support it

        Comment


        • #5
          Originally posted by Melcar View Post
          Maybe it's just Compiz? A lot of people like to blame everyone else's code except theirs, which makes it really hard to troubleshoot for endusers. The blur effect does nothing on my HD3850 (fglrx) or on a 9800pro (radeon) I have on a spare machine.
          (Bumping this because it still doesn't work)
          The Compiz blur effect requires OpenGL 2.0 to work which is not available in radeon, but it should work in fglrx. It actually worked once, but it has been broken for nearly two years now.

          Comment


          • #6
            Originally posted by NeoBrain View Post
            (Bumping this because it still doesn't work)
            The Compiz blur effect requires OpenGL 2.0 to work which is not available in radeon, but it should work in fglrx. It actually worked once, but it has been broken for nearly two years now.
            I can confirm this. The Compiz devs changed something and broke the blur plugin around Ubuntu 7.10/8.04. It's been broken ever since.

            Comment


            • #7
              Originally posted by BlackStar View Post
              I can confirm this. The Compiz devs changed something and broke the blur plugin around Ubuntu 7.10/8.04. It's been broken ever since.
              This was not change in compiz that caused this problem, but a change in fglrx. I don't remember what version of fglrx this breakage happened with, but in one release it worked fine, and in the next it didn't, without any upgrades to compiz at all.

              Adam

              Comment


              • #8
                Originally posted by adamk View Post
                This was not change in compiz that caused this problem, but a change in fglrx. I don't remember what version of fglrx this breakage happened with, but in one release it worked fine, and in the next it didn't, without any upgrades to compiz at all.

                Adam
                Could be - I observed the breakage soon after a dist-upgrade, so I don't know if it was caused by a driver or a new compiz version.

                Comment


                • #9
                  /bump

                  Some people said the blur plugin got fixed in fglrx 9.11. Anyone confirming? For me it doesn't work at all, maybe it needs some special settings to work.

                  Comment


                  • #10
                    Confirm. Blur works with 9.11 driver.

                    Comment

                    Working...
                    X