Announcement

Collapse
No announcement yet.

Catalyst 9.1 is out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by RealNC View Post
    The drivers suck.
    thank you for your in depht analyzation.

    The driver works great here. No problems so far.

    But I am not using ubuntu nor compiz - that might help a lot.

    Comment


    • #32
      no improvements in playing 1080p in some quick scenes i get the known tearing issues... frequently the pictures freezes.
      same hardware no windows no problems..

      hardware 4850 Athlon BE2400 @ 2.3Ghz
      OS Ubuntu 8.10 64bit Player: vlc/mplayer

      I'm getting bored waiting for one relase to another..for fixes..
      Last edited by jimmal; 01-29-2009, 06:58 PM.

      Comment


      • #33
        Originally posted by linuxjacques View Post
        R300 support?
        This is the first release since 8.10 that works for my 9600.

        Comment


        • #34
          Originally posted by energyman View Post
          thank you for your in depht analyzation.
          That would be duplicating the stuff I wrote in the official 9.1 thread. Go there read Mr. Smartguy.

          Comment


          • #35
            Originally posted by RealNC View Post
            That would be duplicating the stuff I wrote in the official 9.1 thread. Go there read Mr. Smartguy.
            http://phoronix.com/forums/showpost....1&postcount=23

            this one?

            oh yes, very thoughtfull. Btw, opening menus is an instantly action here. What do I wrong?

            Comment


            • #36
              9,1 HD3450 and Intel G33

              ASUS EAH3450
              Gigabyte GA-G33M-S2H
              Ubuntu 8.10 x86_64

              Videos play smoothly under compiz, but do not fit in window properly, ie start a third of the way down VLC or GMplayer window. Player controls disappear and reappear. OK if maximise window, but still issue with player controls. Works well when Compiz turned off, but then other 2d apps run slowly (still no 2d accel?).

              ACPI still not working corrctly, screen goes to sleep at appropriate time then wakes up again a few seconds later.

              Back to onboard Intel, try again next month.

              Comment


              • #37
                Kde 4.2:
                xine with xv and tvtime:
                no flickering, fast but: video is a bit shoved to the top. Resizing the window - making it a bit bigger vertically, solves that. Ok, you get a little black bar on top and bottom ... nothing that really disturbs me. No lockups, no problems.

                Only problem still unsolved: manually resizing is still slow. Not unusable, bad slow. Menus pop up instantly, windows move around without lag. Maximising has a very short lag. Like a tenth of a second. Switching between windows is lag free. Minimizing them to the task bar is an instant action.

                Comment


                • #38
                  Driver is mostly regressions for me.
                  After 5 minutes...
                  plus
                  + Firefox seems to scroll faster, less lag

                  minus
                  - Setting video of xvideo will do what is described above, the video fills the whole window, ignoring controls and menus. Trying to resize video crashes X
                  - Resizing windows waaaaaay slower under compiz

                  Will see what else it does.

                  Is there an option for xorg.conf that might help speed up window resizing?

                  Edit - I have a 4850 with an amd athlon x2, ubuntu 8.10

                  Comment


                  • #39
                    The driver doesn't work at all for me

                    It unpacks and installs correctly.After doing an 'aticonfig --initial -f' and (re)starting X,all I get is a black screen.
                    The screen remains black even after exiting from X.There's no commandline or anything,so the only thing I can do is soft restart.

                    I had the exact same problem with 8.11, 9.1 beta and 9.2 beta.

                    8.12 works,but with some serious issues.No black screen,but starting CCC results in a segfault and the overall (2D and 3D) performance is terrible.

                    With 8.5 - 8.10 I don't have any of these issues,but these drivers have other major problems:

                    - When X is started,there are two instances of the Xserver running at the same time.The fake Xserver starts after the real one and has a higher PID.Aside from being an annoyance,it consumes resources and reduces performance,so I always have to end it manually.

                    - I can't play any video (in any player) or use anything that uses Xv output with these drivers. Playing a video in Xine results in a garbled image (a small part of the video is zoomed in with 1/2-inch thick double scanlines,flicker and wrong colors)

                    - Scrolling text in a terminal window is unbearably slow.It uses 100% CPU and feels 10x slower than Windoze in 'Safe Mode'.Resizing windows is another area that's extremely slow.The crappy VESA driver with shadow buffer is infinitely faster.

                    - Bad performance.
                    The fgl_glxgears score has dropped by more than 40% since Cat. 8.5 and it's getting a lot worse with every release after Catalyst 8.7

                    The glxgears score in 8.12 has dropped threefold (!) compared to 8.5.

                    I know glxgears isn't a 3D benchmark,but it can be used to evaluate the 2D performance (without compositing) and efficiency (CPU load) of the driver if tested with the exact same method on the same box.

                    I don't use compositing,KWin or anything,just a basic lightweight window manager and all I need is solid 2D performance,Xv and efficient HD video playback acceleration.

                    It's sad to see how an 'ancient' Radeon 8500 can do much more than this relatively powerful (modern) card.
                    With the 8500 and fglrx,2D was really fast with XAA and it was even possible to play some 1080p videos with a lowly single core


                    Sapphire Radeon HD 2600 Pro AGP 512M
                    AMD AthlonXP 2800+
                    2GB RAM
                    X.org 7.3

                    Really bad experience on Linux,but everything works great on Windows (even if it requires hacking the driver and using a 'third party' SocketA BSOD patch)
                    Last edited by tuxdriver; 01-30-2009, 09:32 AM.

                    Comment


                    • #40
                      On my X1300 PRO, the last few drivers took a few minutes to a few hours to send my screen to garbage. Now it sends the screen to garbage right from the login screen.

                      Comment


                      • #41
                        angus77, does your system use AGP or PCIE bus ?

                        Comment


                        • #42
                          No go with 9.1 for me, Fedora 10 just boots to a black screen and no further.

                          8.12 was working OK with just a minor change of:

                          sudo ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

                          I've had to roll back to 8.12 until I get time to look into the Xorg logs in detail.

                          Andrew

                          Fedora 10, 2.6.27.9-159.fc10.x86_64, 8GB
                          ATI Radeon HD 4870 X2 (2GB)

                          Comment


                          • #43
                            Guys I face a strange problem here with official 9.1 driver...
                            My setup is an HD 3450 card with an asus motherboard containing RS 780 chip=HD 3200 Xserver 1.5.2 Xorg 7.4 64-bit.
                            I was able to boot correctly and I have to mention that the wrong route the driver was seeking the fglrx_dri.so file for 64-bit systems is fixed in the new driver!(it now correctly searches at /usr/lib64/ and not /usr/lib/)
                            Well happy from this fact I tried to use Hybrid Crossfire..
                            Followed the instructions from aticonfig I typed:
                            aticonfig --lscc
                            It correctly showed me my 2 graphic processors
                            0:HD 3450
                            1:HD 3200 as slave

                            OK I said and gave the command for creating a chain:
                            aticonfig --cfa --adapters=0,1

                            It said chain is created (should I have restarted X here??)
                            Then I gave the command to start crossfire
                            aticonfig --cf=on --adapters=0,1

                            And said crossfire enabled I had to restart X (I didn't restarted X here too)
                            Then I added my monitor resolutions via aticonfig again as I always did in the past:
                            aticonfig --input=/etc/X11/xorg.conf --resolution=0,1152x864,1024x768,800x600,640x480

                            Then I logged out in order to restart X and KDE 4.2 normally and the system never made it!!
                            I pressed ctrl+alt+delete to reboot by hand
                            Then when the system rebooted at the time for X to arrive it showed me the black screen but cursor never appeared!!
                            I am at failsafe mode with radeonhd driver writing those lines and I also checked the previous Xorg.0.log for details.
                            Guess what it stops at "CF ribbon cable is not connected trying software CF mode"
                            And that's it!! At this line the log ends! What can I do?? Any help?
                            Last edited by djdoo; 01-30-2009, 09:53 AM.

                            Comment


                            • #44
                              Originally posted by eurodrew555 View Post
                              No go with 9.1 for me, Fedora 10 just boots to a black screen and no further.

                              8.12 was working OK with just a minor change of:

                              sudo ln -s /usr/lib64/dri/fglrx_dri.so /usr/lib/dri/fglrx_dri.so

                              I've had to roll back to 8.12 until I get time to look into the Xorg logs in detail.

                              Andrew

                              Fedora 10, 2.6.27.9-159.fc10.x86_64, 8GB
                              ATI Radeon HD 4870 X2 (2GB)
                              Thank you for your reply. I'm very disappointed with fglrx compatibility with non-Ubuntu distributions.

                              Comment


                              • #45
                                I am confused here...
                                Whenever I enable the cf chain I made for my adapters=0,1 with the command:

                                aticonfig --cf=on --adapter=0

                                I get the black screen of death!
                                When I set this value to 'off' I get my system back!
                                But the strange thing is that when I opened /etc/ati/amdpcsdb file with Kwrite app it writes these:
                                HybridCrossFire=V1
                                RowTilingDowngrade=V0
                                BankSwapDowngrade=V0
                                SampleSplitDowngrade=V0
                                [AMDPCSROOT/SYSTEM/Crossfire/chain]
                                NumChains=V1
                                [AMDPCSROOT/SYSTEM/Crossfire/chain/0]
                                Enable=V0
                                Master=V512
                                NumSlaves=V1
                                Slaves=R28010000
                                Anyone knows if Hybrid Crossfire is working now without having to add a cf chain somehow automatically or what the hell is going on here??

                                Comment

                                Working...
                                X