Announcement

Collapse
No announcement yet.

ATI Mobility Radeon X1400 - fglrx Problems (Goes to Mesa)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Mobility Radeon X1400 - fglrx Problems (Goes to Mesa)

    Originally posted by Michael View Post
    Can you post your xorg.conf (found in /etc/X11/) and cat /var/log/Xorg.0.log | grep "EE" That would help in diagnosing the problem.
    Hi there,
    I'm pretty new with Linux myself and am also running FC6. I'm basically in the same situation as the topic starter in that I didn't seem to have much luck with the drivers from the ATI website, but when I installed the xorg-X11-drv-fglrx drivers using yum I was able to get the resolution working.

    However more recently when I tried to run Google Earth, I found out that my 3D support was not enabled. I'm currently running the ATI Mobility Radeon X1400 using the latest drivers from yum (xorg-X11-drv-fglrx 8.33.6-4.lvn6 and kmod-fglrx#8.33.6-1.2.6.19_1.2911.fc6)

    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: Mesa project: www.mesa3d.org
    OpenGL renderer string: Mesa GLX Indirect
    OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
    aticonfig --initial
    Found fglrx primary device section
    Nothing to do, terminating.
    xorg.conf (after aticonfig --initial)
    # Xorg configuration created by system-config-display

    Section "ServerLayout"
    Identifier "single head configuration"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Synaptics" "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "gb"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics"
    Driver "synaptics"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "auto-dev"
    Option "Emulate3Buttons" "yes"
    Option "SHMConfig" "on"
    EndSection

    Section "Monitor"

    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    ### Comment all HorizSync and VertSync values to use DDC:
    Identifier "Monitor0"
    ModelName "LCD Panel 1440x900"
    ### Comment all HorizSync and VertSync values to use DDC:
    HorizSync 31.5 - 100.0
    VertRefresh 59.0 - 75.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "fglrx"
    Option "UseInternalAGPGART" "no"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection
    and

    cat /var/log/Xorg.0.log | grep "EE"
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (II) Loading extension MIT-SCREEN-SAVER
    (EE) AIGLX: Screen 0 is not DRI capable
    Yesterday, I tried to uninstall the drivers from the livna repository and attempted to install the drivers from the ATI website again. I got an error but I can't remember exactly the output, but I think it was something about multiple versions of fglrx in the kernel. I didn't really want to mess around with it so I uninstalled those and reinstalled the livna drivers. Just wondering if anyone can help me as I still don't know a lot about Linux.

    Thanks

  • #2
    Install Livna again. What you were missing were disabling AIGLX and Composite.

    Add:

    Section "Extensions"
    Option "AIGLX" "off"
    Option "Composite" "off"
    EndSection

    to the end of your xorg.conf, and then restart.
    Michael Larabel
    http://www.michaellarabel.com/

    Comment


    • #3
      Originally posted by Michael View Post
      Install Livna again. What you were missing were disabling AIGLX and Composite.

      Add:

      Section "Extensions"
      Option "AIGLX" "off"
      Option "Composite" "off"
      EndSection

      to the end of your xorg.conf, and then restart.
      Thanks for the very quick reply.

      That seems to have worked great. glxgears seems to be running much more smoothly than before. Thanks for the help, I really appreciate it!

      EDIT: I didn't want to double post so I decided to edit this message. I just wanted to make sure really. Is it still supposed to be using Mesa for 3D? I get the same output from fglrxinfo as I posted previously and I wasn't sure if it was supposed to be something else. Just checking to make sure if everything I have now is as it should be or if I'm still neglecting something.

      Thanks
      Last edited by gigabz666; 02-23-2007, 04:49 AM.

      Comment


      • #4
        I just checked what was going on with a couple of commands and noticed something different from the previous outputs.

        cat /var/log/Xorg.0.log | grep "EE"
        (II) Loading extension MIT-SCREEN-SAVER
        (EE) AIGLX error: dlopen of /usr/lib/dri/fglrx_dri.so failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __glXFindDRIScreen)
        (EE) AIGLX: reverting to software rendering
        Also this morning, I used yum update and it has now updated the livna fglrx drivers to 8.34.8-3.lvn6 but no difference. As I mentioned in the previous post with my update, glxgears was running much faster compared to before, but it's not running smoothly. I thought it was supposed to be like that but I'm guessing with the above error, mentioning software rendering, then that's not true.

        Comment


        • #5
          Do you have

          Section "Extensions"
          Option "AIGLX" "off"
          Option "Composite" "off"
          EndSection

          in your xorg.conf?
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            Yes I do. I did that and restarted yesterday and glxgears was running much more smoothly than before. However when I checked the info, it still had mesa as the 3D support. I also found out more recently about fgl_glxgears to see what that produced but that doesn't even run.

            fgl_glxgears
            Using GLX_SGIX_pbuffer
            X Error of failed request: GLXUnsupportedPrivateRequest
            Major opcode of failed request: 143 (GLX)
            Minor opcode of failed request: 16 (X_GLXVendorPrivate)
            Serial number of failed request: 30
            Current serial number in output stream: 32
            Here is the xorg.conf
            # Xorg configuration created by system-config-display

            Section "ServerLayout"
            Identifier "single head configuration"
            Screen 0 "Screen0" 0 0
            InputDevice "Keyboard0" "CoreKeyboard"
            InputDevice "Synaptics" "CorePointer"
            EndSection

            Section "InputDevice"
            Identifier "Keyboard0"
            Driver "kbd"
            Option "XkbModel" "pc105"
            Option "XkbLayout" "gb"
            EndSection

            Section "InputDevice"
            Identifier "Synaptics"
            Driver "synaptics"
            Option "Device" "/dev/input/mice"
            Option "Protocol" "auto-dev"
            Option "Emulate3Buttons" "yes"
            Option "SHMConfig" "on"
            EndSection

            Section "Monitor"

            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            ### Comment all HorizSync and VertSync values to use DDC:
            Identifier "Monitor0"
            ModelName "LCD Panel 1440x900"
            ### Comment all HorizSync and VertSync values to use DDC:
            HorizSync 31.5 - 100.0
            VertRefresh 59.0 - 75.0
            Option "dpms"
            EndSection

            Section "Device"
            Identifier "Videocard0"
            Driver "fglrx"
            Option "UseInternalAGPGART" "no"
            EndSection

            Section "Screen"
            Identifier "Screen0"
            Device "Videocard0"
            Monitor "Monitor0"
            DefaultDepth 24
            SubSection "Display"
            Viewport 0 0
            Depth 24
            Modes "1440x900" "1400x1050" "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
            EndSubSection
            EndSection

            Section "Extensions"
            Option "AIGLX" "off"
            Option "Composite" "off"
            EndSection
            Last edited by gigabz666; 02-23-2007, 09:03 AM.

            Comment


            • #7
              Did you try generating the packages then and not using Livna?
              Michael Larabel
              http://www.michaellarabel.com/

              Comment


              • #8
                Originally posted by Michael View Post
                Did you try generating the packages then and not using Livna?
                When I tried this yesterday I had something about the kernel. The exact output I couldn't remember. So I'm not going to attempt to try and state what it was. Anyway, I've tried using the installer just now after uninstalling the livna packages and this is what I get.

                sh ./ati-driver-installer-8.34.8-x86.x86_64.run --buildpkg Fedora/FC6
                Creating directory fglrx-install
                Verifying archive integrity... All good.
                Uncompressing ATI Proprietary Linux Driver-8.34.8............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..................................
                ==================================================
                ATI Technologies Linux Driver Installer/Packager
                ==================================================
                Generating package: Fedora/FC6
                ./packages/Fedora/ati-packager.sh: line 172: /etc/profile.d/qt.sh: No such file or directory
                Removing temporary directory: fglrx-install

                Comment


                • #9
                  Run as root:

                  yum install qt-devel
                  Michael Larabel
                  http://www.michaellarabel.com/

                  Comment


                  • #10
                    Must be really annoying with people like me, lol

                    Ok just done that and tried again and now have another error. The problem is that it's extremely long so don't think I can post it all in here. But the immediate error is this.

                    sh ./ati-driver-installer-8.34.8-x86.x86_64.run --buildpkg Fedora/FC6
                    Creating directory fglrx-install
                    Verifying archive integrity... All good.
                    Uncompressing ATI Proprietary Linux Driver-8.34.8............................................ .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..................................
                    ==================================================
                    ATI Technologies Linux Driver Installer/Packager
                    ==================================================
                    Generating package: Fedora/FC6
                    install: cannot stat `fireglcontrolpanel': No such file or directory
                    Package build failed!
                    Package build utility output:
                    Building target platforms: i386
                    Building for target i386
                    This then continues on for a hundred lines or so. I'm sure I've seen this fireglcontrolpanel somewhere before in a search on this forum or on google, but can't seem the find the solution.

                    Really appreciate all the help here, I know it must be annoying.

                    EDIT: Ok, just noticed this at the end of that long output
                    RPM build errors:
                    File not found: /tmp/ATI-fglrx-8.34.8-1-8897-root/tmp/ATI-fglrx-8.34.8-1.fc6-root-root/usr/bin/fireglcontrolpanel
                    Removing temporary directory: fglrx-install

                    Comment

                    Working...
                    X