Announcement

Collapse
No announcement yet.

Fix for black screen on reboot?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fix for black screen on reboot?

    I just tried installing the catalyst 8.12 driver on my ubuntu 64 8.04 for my hd4870... I followed the instructions at:

    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    But when I reboot after installing the driver, it just goes to a black screen after the progress bar finishes. I can't do anything at this point except hit the reset button on the pc. I'd like to be able to run something newer than catalyst 8.9, but at least 8.11 and 8.12 are just giving me black screens on reboot.

    I seem to remember reading about black screen after installation of newer ati drivers, but cannot find a solution...

  • #2
    Try

    http://kanotix.com/files/install-fglrx-debian.sh

    Comment


    • #3
      If you hit ctrl+alt+f1 and you get to a tty console then your machine did not crash and you don't need to hit your reset button. Your monitor might just be loosing signal because xorg.conf is telling your display to to do something it cannot do (resolution or other params. out of it's range)

      Comment


      • #4
        i got a 4850 card and used the Script from Kano. Works good.
        without this i had the same issue you mentioned..system freezes after the progress bar. Nothing but hardware reset helped. Could not switch VT oder anything else Magic Keys (REISUB) did fail also.

        Comment


        • #5
          I guess the main reason is that I clean /etc/ati before installing the new driver.

          Comment


          • #6
            if i change some settings (TV pictures scaling) via amdcccle the same problem appears.
            cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb helps out.

            Comment


            • #7
              If it's actually freezing when the desktop starts up then I might be having the same problem, I'll give kano's script a try. The really strange thing is I used to be able to boot into X with fglrx multiple times on 1080p resolution and I thought I was all done with video and then I started locking up on reboots and had to revert to a non-fglrx xorg.conf to launch X/GDM.

              Comment


              • #8
                it seems that the aticonfig tools writes some extra settings in /etc/ati/amdpcsdb which makes fglrx crash on reboot. I'll try again to make some adjustments an post Xorg.0.log.

                Comment


                • #9
                  I just ran the script kano provided, and it looked good. It was showing direct rendering and everything checked out, but on reboot back to the black screen

                  I re-setup my 8.9 drivers and everything is working... What is with ati past 8.10 that is screwing me up?

                  Comment


                  • #10
                    for me is the blackscreen (freeze) gone on the next reboot after this command:
                    try cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb

                    Comment

                    Working...
                    X