Announcement

Collapse
No announcement yet.

Mythbuntu 8.10 on 690G board, TV-out?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mythbuntu 8.10 on 690G board, TV-out?

    For a while I was trying to get Myth running under Mandriva 2008.0 on a 690G board, and there I was able to get TV-OUT to work, at least in the regular video mode. However, there were problems with Myth.

    So I installed Mythbuntu 8.10 and Myth works, but now TV out won't go. amdccle sometimes shows the TV option, but grayed out. It shows the driver as 8.54.3.

    The TV is hooked up with both an S-video and Composite cable, but nothing ever shows up there. The BIOS is set to "CRT Force, TV Force".

    sudo aticonfig --initial --force-monitor=crt1,tv --tvf NTSC-M --tvs VIDEO
    Found fglrx primary device section
    Warning: Failed to set tv format immediately.
    Warning: Option 'ForceMonitors' doesn't affect running session.
    Warning: Option 'TVStandard' doesn't affect running session.
    Using xorg.conf
    Saved back-up to xorg.conf.fglrx-9

    but nothing on the TV, even after reboot.

    What magic incantaion do I need to employ to turn TV-OUT on for this driver/distro?

    Thanks

  • #2
    well,
    I have a similar issue.
    I have an RS690 and sometimes the screen goes black.
    Have you tried to delete /etc/amd/atipcsdb and restart X?

    See:
    http://www.phoronix.com/forums/showthread.php?t=14483

    Comment


    • #3
      Originally posted by kkkk View Post
      well,
      I have a similar issue.
      I have an RS690 and sometimes the screen goes black.
      Have you tried to delete /etc/amd/atipcsdb and restart X?

      See:
      http://www.phoronix.com/forums/showthread.php?t=14483
      Ok, read that. Will try deleting
      /etc/ati/amdpcsdb
      and starting over.

      You used amdccle to enable tv-out. How exactly? Either it shows no TV-out options, or it shows that grayed out. I once seemed to get both screens set to be on for the next boot, but at the reboot nothing came up on the TV, and amdccle was back to the original settings.

      Do you know the equivalent aticonfig command? I'm trying to find\ something like this:

      sudo aticonfig --initial --force-monitor=crt1,tv --tvf NTSC-M --tvs VIDEO

      that correctly sets up the tv out everytime so that I can at least have a script to recover, along the lines of:

      %!/bin/sh
      #runs as root before X starts
      rm -f /etc/ati/amdpcsdb
      aticonfig --initial --force-monitor=crt1,tv --tvf NTSC-M --tvs VIDEO
      #plus other magic parameters


      In my BIOS (in the IGA section) the Video setting defaults to "Auto" but is currently set to "CRT Force, TV Force". What is the equivalent setting on your machine? I used this just in case for some reason the 690G could not detect the TV, and so wasn't reporting it to X11.

      The CRT monitor attached to this machine is VGA. I'm thinking that may be a problem, with the "analog" part of the 690G somehow defaulting over to VGA if both a VGA monitor and a (composite/S-Video/Component) TV are plugged in.

      Finally, what is the mapping between catalyst numbers (8.12) and the driver numbers shown in amdccle (8.54.3)? I can't even tell at the moment which version of the driver is loaded since the ATI site and most of the posts on this forum use one numbering convention, and the ubuntu packages use another!

      Thanks.

      Comment


      • #4
        Originally posted by mathog View Post
        ...so that I can at least have a script to recover, along the lines of:

        %!/bin/sh
        #runs as root before X starts
        rm -f /etc/ati/amdpcsdb
        aticonfig --initial --force-monitor=crt1,tv --tvf NTSC-M --tvs VIDEO
        #plus other magic parameters
        Some progress doing this after booting "single" mode:

        rm -f /etc/ati/amdpcsdb
        aticonfig --initial --force-monitor=crt1,tv --tvf NTSC-M --tvs VIDEO
        reboot

        brings it up next time in composite video. Using this instead

        aticonfig --initial --force-monitor=crt1
        reboot

        puts it back to the monitor. It only works reliably with the reboot though.

        In the TV mode on a normal boot Myth starts, but trying to watch TV does nothing (it just flickers for a second and goes back to the Myth menu.) Unfortunately with the video on the TV it isn't possible to read any terminal or amdcccle text, so it isn't really possible to reconfigure further using the TV as the single display. Sigh.

        I'll scrounge up 3 video cables and try --tvs YUV, as the TV has component video, maybe that will be more legible.

        Comment


        • #5
          Summary so far:

          For component or S-video, and this seems to be set in hardware somehow depending on what cables are plugged in, use:

          Code:
          rm -f /etc/ati/amdpcsdb
          aticonfig --initial --force-monitor=tv --tvf NTSC-M --tvs VIDEO \
            --resolution=0,640x480
          reboot
          For component use instead:

          Code:
          rm -f /etc/ati/amdpcsdb
          aticonfig  --initial --force-monitor=tv --tvf NTSC-M --tvs YUV \
           --resolution=0,640x480
          reboot
          (This only works reliably for me with an immediate reboot.)
          The composite image is not right, it is sort of blue. Currently
          the connections are:

          Code:
          Mobo Header       Jacks        TV
          3 Luminance       Green        Green Y
          5 Chroma          Red          Red   Pr
          2 Composite       Blue         Blue  Pb
          and that seems not to be right. I never could find the documentation
          for the 690G which described the mapping of Y,Pr, and Pb onto the header
          pins, so this may not be the correct connection. All the diagrams I have found so far only list Luminance, Chroma, and Composite.

          It is possible to switch on the fly between the VGA crt and the TV with

          sudo aticonfig --enable-monitor=crt1
          sudo aticonfig --enable-monitor=tv

          with no reboot needed.

          It still won't let me watch TV though, not even on the crt at higher resolutions, which could be a driver issue or a Myth issue.

          Too many variables....

          Comment


          • #6
            Originally posted by mathog View Post
            The composite image is not right, it is sort of blue. Currently
            the connections are:

            Code:
            Mobo Header       Jacks        TV
            3 Luminance       Green        Green Y
            5 Chroma          Red          Red   Pr
            2 Composite       Blue         Blue  Pb
            and that seems not to be right. I never could find the documentation
            for the 690G which described the mapping of Y,Pr, and Pb onto the header
            pins, so this may not be the correct connection. All the diagrams I have found so far only list Luminance, Chroma, and Composite.
            Well, played with the cables and no setting was great. The mapping of
            pin 3 to Luminance/Y seems to be right, since if the other cables are pulled there is an accurate grey scale image. However, there is very little signal coming off of pin 5. and swapping around the Pr Pb cables just resulted in a very blue, or very red image. Others have reported similar results, so I don't think that it is just my board:

            http://www.phoronix.com/forums/showthread.php?t=10869

            aticonfig has a bunch of "cvdongle" related commands, which suggests to me that perhaps the ATI driver expects some sort of active circuit in order to map these 3 pins to component. I could be wrong, but since I could not find any relevant documentation, this is all guess work.

            In short, I'm tired of beating my head on the wall over this. Guess I'll buy a cheap Nvidia card and throw in the towel on the X1250 graphics.

            Comment


            • #7
              Originally posted by mathog View Post
              Guess I'll buy a cheap Nvidia card and throw in the towel on the X1250 graphics.
              If that's what you end up doing, make sure you don't get an 8x00 series card - the tvout support on that hardware is completely oblivious to the overscan settings and your tvout will be horribly overscanned. 6x00 and 7x00 series cards actually respond to the TVOverscan xorg.conf option and the related nvidia-settings option so they are a way better choice for an HTPC (however Nvidia's UNIX drivers don't have an option for tvout position at all and the picture is invariably off-centre, so Nvidia still isn't a spectacular option for an HTPC - except that their driver is actually remotely dependable).

              Have you tried using the ati or radeonhd drivers? I thought that the ati driver at least had tvout support on r5xx cards, but I guess it's still not 100%.

              And now, a brief lament for fglrx. .... *sigh* ...

              Comment


              • #8
                tvout with r690 is not yet supported in radeon drivers

                Comment


                • #9
                  Originally posted by mathog View Post
                  Guess I'll buy a cheap Nvidia card and throw in the towel on the X1250 graphics.
                  Yesterday I put in an ASUS EN8400GS and had component out working in about 15 minutes once the case was screwed shut again, including loading the Nvidia drivers. It isn't quite done because I have to resize things to compensate for the overscan, or figure out how to turn that off, but otherwise, it was incredibly easy.

                  Comment

                  Working...
                  X