Announcement

Collapse
No announcement yet.

HD 3850 AGP lockup with OpenGL load

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by monomakh View Post
    aticonfig --adapter=0 --od-getclocks
    ERROR - Could not find library: libatiadlxx.so
    I think that's down to which fglrx you are using - it works with 8-10

    I have installed windows xp sp2. GPU always works at 669Mhz by default, neither 324Mhz.
    Strange, mine shows 324 when there is no GPU load.

    Comment


    • #32
      9.1 is works better

      I've installed 9.1 and its works really better than 9.2 beta. aticonfig --adapter=0 --od-getclocks works without errors and I've seen 669Mhz. I get really better result by benchmark tool and no problems with fullscreen.

      Comment


      • #33
        Could not find library: libatiadlxx.so was at 9.2 beta.
        At windows drivers version was 8.12.

        Although 9.1 is better than 8.12, I still have critical issues:
        Hangs at 8x agp speed after few seconds or one when opengl application started. I have not these issue at windows.
        Hangs at 4x agp speed often but randomly. I can work hour or two minutes without this hangs. Computer never hangs if radeonhd used (but 3d is not supported )

        Ogh, hangs now have some change. With 9.1, now my cursor is not hanging
        I want to check tv-out support. My monitor dont works with tv-out at 8.12, 9.1 beta or 9.2 beta... I don't think that something have been changed.

        My card just 1 month old... It's time to think to sale it...
        I have problems with nvidia, but they are just nothing comparing with ati.

        Comment


        • #34
          The Windows drivers stress-test the AGP bus and automatically downgrade it to a slower speed if necessary. They also turn off fast writes (and a couple of other things I forget) if required to get the bus running reliably.

          I suspect the Windows driver is automatically slowing the AGP bus to make your system run reliably; sounds like that would be 2X for your system. The Linux driver does not have this mechanism (called SmartGART).

          Does the system run reliably at 2X ?

          Comment


          • #35
            Tv-out problem is remains. Just connect tv-out, goes to runlevel 3, configure display to fglrx and start runlevel 5... All hangs and nothing at output... Just reboot... oh, reboot to runlevel 3 or it hangs again.
            Or just disconnect s-video and connect it to my new notebook with nvidia. Or just disconnect this card and install back old nvidia card, that I changed and all problem will be solved.
            Brrr...
            Looks like the only way to solve problem is to buy nvidia and forget amd forever.

            Comment


            • #36
              My motherboard doesnt support 2x agp mode. I have option to disable or enable AGP at 8x or 4x. But my old Nvidia GeForce Ti 4200 with 8x support works with 8x normally at the same linux or windows versions. My old GF 4200 supports 3d, tv-out, 8x, OpenSuse at the same hardware...
              Looks like HD 3850 doesn't support any of these.

              Comment


              • #37
                I don't know the details, but my understanding is that the drivers can adjust the bus speed even if you don't have a BIOS option for the lower speeds.

                Comment


                • #38
                  I found a workaround how to watch dvb-s using xine (I have not this issue on nvidia cards). I need to run watching dvb-s, press alt+F11 (goes to console), and back from it (alt+F7) - than video looks like normal.
                  This is not a very good workaround, because after switch a channel or stop playback - all hangs and monitor goes to black screen.
                  I've switched back to stable but 3d and tv-out unsupported radeonhd and start search of ways to sold this unstable for linux card.
                  Last edited by monomakh; 01-31-2009, 04:50 AM.

                  Comment


                  • #39
                    Maybe radeonhd works not so good as it can?
                    (--) PCI:*(0@1:0:0) unknown vendor (0x1002) unknown chipset (0x9505) rev 0, Mem @ 0xb0000000/0, 0xc2000000/0, I/O @ 0x0000c000/0, BIOS @ 0x????????/131072

                    Comment


                    • #40
                      fglrx works really better with tv-out after I change from one DVI connector to another

                      Comment

                      Working...
                      X