Announcement

Collapse
No announcement yet.

Catalyst 9.1 with "Composite & Video Support" leaked!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by Erektium View Post
    What's wrong with the open source drivers? I'm using them and getting good video playback with compiz enabled. I have R430
    uhm.. something between OpenGL 2.0 support and worse 3d accel?

    However, I'm asking myself how fglrx and radeon compare at OGL 1.x performance... perhaps the difference there is not /that/ big?

    Comment


    • #22
      the leaked driver seems to be ok. I am using kwin 4.1.85+effects and watch tv with tvtime - and so far no problems. Resizing windows is as slow as always and at one point the kmenu was stuck until I closed tvtime. Apart from that there doesn't seem to be any problems. I will try 3d later.

      Comment


      • #23
        To clarify some things, I regularly use an r300 card and as far as i am concerned it behaves remarkably well with the fglrx driver.
        I used to have another also, but in the last month upgraded, and IMO the driver works much better on the r300 cards than r700 ones.
        I don't understand why some of you are having these issues, as the driver works fine on my older cards. This is with catalyst 8.10, 8.11, and 8.12.



        With my new card, I have updated to the 9.1b (removed pesky watermark), and it is about as stable as all the previous releases - ie - random crashes persist
        A notable regression from 8.12 has been fixed.

        What bothers me most with the drivers is the lack of support for shaders in wine, which makes many games unplayable or not desirable for play.
        For example with command and conquer 3, shaders and shadows must be turned to lowest to be playable, but certain things still trigger the 'stretched triangle' corruption, and also the game slows down immensely when there too many effects.

        Comment


        • #24
          how did you remove the watermark?

          Comment


          • #25
            Originally posted by poofyyoda View Post
            What bothers me most with the drivers is the lack of support for shaders in wine, which makes many games unplayable or not desirable for play.
            For example with command and conquer 3, shaders and shadows must be turned to lowest to be playable, but certain things still trigger the 'stretched triangle' corruption, and also the game slows down immensely when there too many effects.
            Are you sure this isn't more a limitation of Wine or the hardware itself?
            AFAIK, Wine needs many OpenGL extensions for e.g. DX Shader 2.0 support and those may not be supported by r300 chips.

            Comment


            • #26
              Removing the watermark is simple. Just copy /etc/ati/signature over from another driver.

              Comment


              • #27
                Originally posted by NeoBrain View Post
                Are you sure this isn't more a limitation of Wine or the hardware itself?
                AFAIK, Wine needs many OpenGL extensions for e.g. DX Shader 2.0 support and those may not be supported by r300 chips.
                Nah, the only people with problems on the appdb, are those with ati cards. The issue exists exactly the same on my new HD 4650 as my older cards also.

                Comment


                • #28
                  ah, thanks.

                  Comment


                  • #29
                    Composite isn't working on its own as it should, really, so instead of Composite+Video, how about we get Composite first? Then you can think about +Video.

                    Comment


                    • #30
                      what does not work?

                      Comment

                      Working...
                      X