Announcement

Collapse
No announcement yet.

AMD Catalyst 8.12 Linux Driver

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    If you have:

    (EE) module ABI major version (0) doesn't match the server's version (1)
    (EE) Failed to load module "dri" (module requirement mismatch, 0)
    dlopen: /usr/lib/xorg/modules/drivers//fglrx_drv.so: undefined symbol: miZeroLineScreenIndex
    (EE) Failed to load /usr/lib/xorg/modules/drivers//fglrx_drv.so
    (EE) Failed to load module "fglrx" (loader failed, 7)
    (EE) No drivers available.
    Install from command line. It solves Xorg ABI problem..

    root # ati-driver-installer-8-12-x86.x86_64.run --install

    Comment


    • #32
      Can anyone paste here his amdcccle, cause i think my is a little messed up ;/

      Anyway I'm still unable to remove the libatiadlxx.so error. Did the clean install, but the result is the same, but there is a one thing that makes me wonder.
      In my /usr/lib/ there is a libatiadlxx.so with size :
      Code:
      -rw-r--r--   1 root root   104232 2008-12-10 22:12 libatiadlxx.so
      but when I extract the ati driver, search for that file, the result will guide me to ./arch/x86/usr/X11R6/lib/ and x86_64, since im using 32bits so the file i want looks like this :
      Code:
      -rwxr--r-- 1 tares tares  128766 2008-12-04 23:56 libatiadlxx.so
      Can anyone tell me why those two files are different ? Since I've removed anything related to fglrx before installing now driver, I dont have a clue why installing 8.12 it gives me different file.

      Comment


      • #33
        Originally posted by Inkaine View Post
        For me the main concern is: does it support the soon-to-be-released kernel 2.6.28 yet. Anyone tried on an rc?

        Great to hear it supports Hybrid CF now. I might give it a try even. But not before April 2009 as I won't see my desktop pc for 3 months from tomorrow. See ya at Catalyst 9.3.
        I'm running the latest 2.6.28-rc on Ubuntu Jaunty with 8.11, works great for me. Going to upgrade today later on, Jaunty seems to already have 8.561.

        By the way, has anyone tested mplayer -vo gl with its several options? Particularly, force-pbo/ati-hack. Maybe that works again.

        Comment


        • #34
          I gave it a quick try yesterday evening, after having problems with 8.10 and 8.11 (X failed to start, probably had something to do with my dual head setup with my (analog) TV).

          So, I was hoping 8.12 would finally work again for me and I was eager even to try Hybrid Crossfire (HD3200 and a HD3450). Turned on Surround view in my Bios (only option looking relevant that I could find in my Asus M3A78-EM bios) and installed the driver. So I used something like:

          aticonfig --adapters=0,1 --cfa --cf=on --initial=dual-head -f

          Didn't work at once I think (it was the --cfa or --cf=on option that didn't work the first time, so I applied these options running aticonfig a second time). With aticonfig I could also list the crossfire chain, showing both graphics cards. But after a restart of my system, Ati Catalyst was showing three displays (two on the HD3450, that is correct) and one on the HD3200 (not correct, there is none, I want to use it for Crossfire).

          When I rebooted my computer this morning I had the same problem as with 8.10 and 8.11 (X did not start). So I immediately went back to 8.9, but later on I though: lets try 8.12 without Hybrid Crossfire. So tried that, restarted a few times, X came up nicely every time.

          So I'll give it a few more days, see if X starts correct every time. Maybe give crossfire another go (I assume I did something wrong in the setup). Meanwhile, I have CrossFingers that everything will work...

          Actually, yesterday I was this close to typing a huge rant on this forum about the `crap' we get each month (after 1.5 year telling everybody that it gets better, that we see improvements and that it probably will take another half year before the drivers are perfect). Lets hope 8.12 proves to work on my setup properly (with or without Hybrid Crossfire).

          Comment


          • #35
            AMD/ATI... ATI/AMD... aTi? Amd? Ooooh it is written AMD/ATI Mobility X160... Blah blah blah blah........... Guys, stop writing videocard drivers. It's absolutely pointless.

            The only chance 'AMD/ATI' great future to come true some day is with nVIDIA - as the code-maker of amd/ati video drivers.
            Last edited by Xtigyro; 12-11-2008, 05:46 AM.

            Comment


            • #36
              The only bad thing for me in this release is that the graphical corruption in Savage2 has gotten worse.

              Comment


              • #37
                A good tester for tear-free driver - http://vbox7.com/play:a8b71ae3

                Comment


                • #38
                  Just upgraded. Well, again, I'm pretty impressed. Some problems I had with heavy h.264 videos on mplayer -vo gl are gone, the videos play with no hiccups. force-pbo doesn't work, but it doesn't matter as long as everything I have plays fine -- I don't even have to use ffmpeg-mt anymore.

                  I compiled mplayer with xvmc support but as expected, XvBA doesn't work.

                  Overall, once again kudos to AMD for a good release.

                  By the way, would anyone be interested in the binary of mplayer-mt or the source code I used to compile it?

                  Comment


                  • #39
                    Could someone try with a R300 with an other distro than Ubuntu(or debian) please?

                    Comment


                    • #40
                      It's a shame!!! xvmc XvBA are they crazy???
                      And when i try to play a video with compiz?????
                      It's time to AMD/ATI for wake-up!!! I wait for a decent driver since 2006... i'm discouraged...

                      Why the radeon OpenSource driver can play Textured Video with Composite, and propretary can't??? AnyOne can clarify it to me, please?

                      ..i'm thinking to buy an nVidia video adapter.....

                      Comment


                      • #41
                        yodash, what the hell are you talking about?

                        Comment


                        • #42
                          Does Kano going to create a script for this driver too??

                          I wont install FGLRX without Kano scripts anymore, its impressive how everything just goes right with that.

                          But if you do a new script kano please create a proper xorg.conf! (Aticonfig complains a lot about it "Proper device section not found" or something like this)

                          Anyway this weekend going to give 8.12 a chance.

                          Comment


                          • #43
                            Originally posted by energyman View Post
                            yodash, what the hell are you talking about?
                            He wants it to be non-glitchy.

                            I for one am excited about the progress. I believe that next year, graphics driver will be close to on-par with the windows drivers as far as "it just works" goes. For the amount of implemented features in the last year I'm not disappointed to see the driver being still buggy.

                            On the other hand, the open drivers are making great progress as well. I speculate that they are probably cleaner and better adapted for the Linux environment than fglrx but also under-optimized. This could very well be very untrue but it's just the feeling that I get from the situation.

                            Though I can't really blame anyone for not wanting ATI on Linux at the present moment. My Phenom 9500 w/ HD3650 DDR2 is unstable when using OpenGL. I'm replacing the 3650 for a 4850 in January hoping that this will resolve the issue. I really want to play Doom3, Nexuiz, Q4, Savage2, Guild Wars on my 56 inch tv Working and intuitive HDMI audio would also be really nice.

                            I'm not exactly sure if the stability problem is caused by Core3 of my Phenom as it is a common issue. I may also replace the cpu for a Deneb core when they are available at a good consumer price.

                            Wish me luck :P

                            Comment


                            • #44
                              @cjr2k3

                              It is always the same script, of course it is updated too for that driver and it even installs the .cap file which would not be installed with the standard Ubuntu packageing. I don't know how to use it however Also for now the video overrides are disabled by default in the xorg.conf, but you can of course activate em if needed by uncommenting.

                              Comment


                              • #45
                                Originally posted by Kano View Post
                                @cjr2k3

                                It is always the same script, of course it is updated too for that driver and it even installs the .cap file which would not be installed with the standard Ubuntu packageing. I don't know how to use it however Also for now the video overrides are disabled by default in the xorg.conf, but you can of course activate em if needed by uncommenting.
                                Ty for the information. I'll post later (When I get home) what is the error Aticonfig tool gives, since I'm almost sure is not related to video options.

                                @BlueKoala

                                My new setup is a phenom X3 with a HD4850 and I have no problems at all. Running Ubuntu 8.10 x64 here. I'm waiting to FGLRX support Crossfire in any OpenGL app so I can put in another HD4850. Still confuses me why is difficult to make Crossfire Generic (I think some optimizations may be made and all, but in non-optimized app just split the frames or one frame for each card?).

                                Comment

                                Working...
                                X