No announcement yet.

No Xvideo sync on 780G

  • Filter
  • Time
  • Show
Clear All
new posts

  • No Xvideo sync on 780G

    I bought a computer with a 780G motherboard this summer to use as HTPC and I have it hooked up to my TV with DVI. I thought it would be perfect with AMD's renewd focus on Linux etc.

    But the lack of vsync for the video is driving me nuts! It really looks terrible. It's got to be fixed! :-P

    (Nothing works, textured video sync, xvideo sync, opengl sync...)

  • #2
    Did you try disabling compiz?


    • #3
      I got rid of video tearing and heres how...

      I use vlc media player and change the video output to opengl. Then in the ati Catalyst Control Center, go to

      3d Settings > More Settings

      and change "Wait for vertical refresh" to "On unless application specifies".

      I also changed some xorg.conf settings to improve video quality somewhat, heres the appropriate excerpt...

      	Driver      "fglrx"
      	Option	    "VideoOverlay" "off"
      	Option	    "OpenGLOverlay" "off"
      	Option	    "TexturedVideo" "on"
      	Option	    "XAANoOffscreenPixmaps" "on"
      	Option	    "AccelMethod" "EXA"
      	Option	    "ExaNoComposite" "false"
      	Option	    "MigrationHeuristic" "greedy"
      I find that these settings give me the best performance for watching avi's etc.

      hope this helps you!
      Last edited by duncan_nz; 12-03-2008, 06:02 AM.


      • #4
        Are you certain the last three options work? They are options for EXA support and I doubt Catalyst provides that yet. At least it'd be a pleasant surprise that would have passed me unnoticed. Where did you find these provided? I only know them from my intel based netbook but no surprise there as the open source drivers all provide EXA support.

        Well, I tried your config on my HD3200 and - surprise, surprise - they did NOT work with Catalyst 8.11 and Xorg 7.4. Xorg.0.log is telling me it's running on XAA and
        (WW) fglrx(0): "AccelMethod" is not used
        (WW) fglrx(0): "ExaNoComposite" is not used
        (WW) fglrx(0): "MigrationHeuristic" is not used
        As for all other options by duncan_nz except these three, I've been using them for performance improvement on my board for half a year already successfully as well. That's your way to go, ernstp.


        • #5
          Well I'm not sure about the last few lines, I was searching on the Ubuntu forums for ways to improve video performance, and people had posted their xorg.conf's.

          Also you have to run an aticonfig command for it to re-read the xorg settings so it will use them, did you try that?

          I forgot what it was though >.<

          Anyways I don't get video tearing any longer running vlc in opengl and forcing vsync on in graphics settings.


          • #6

            opengl is way too slow for video playing, especially videos with huge dimensions. I guess that's why Xv is disabled by default, but I don't exactly get lack of vsync when using it. It tends to flicker a lot, that's what happens; like the bottom part of the video will shake around, and when it's not shaking it all appears to be vsynced. The amount depends on the size I guess. I wonder if regular Xv will be fixed or if it's just going to be XvMC (for the new cards)?

            And speaking of this, I meant to ask: How exactly are applications supposed to specify the vsync switch for opengl? When you set those settings in amdcccle, On by default, off, etc, I can never get it to work. None of the apps I use can use it, it's all either on or off, the "* unless application specifies" switches don't work. Is there a variable you can export for this purpose?
            Last edited by Moronix; 12-04-2008, 05:08 AM.