Announcement

Collapse
No announcement yet.

fixing underscan might crash X

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Mr. Hilarious View Post
    For me, I fixed the problem in 8.12 (might have been 9.1 or 8.11, I really don't recall) by running:

    Code:
    aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
    and, I believe something was recorded in my grapchics BIOS, since once I upgraded I've never had a ******d up scan on my TV since. I believe the above doesn't record anything into amdbcsdb, but the

    Code:
    aticonfig --set-dispattrib=tmds2i,positionX:0
    aticonfig --set-dispattrib=tmds2i,positionY:0
    aticonfig --set-dispattrib=tmds2i,sizeX:1920
    aticonfig --set-dispattrib=tmds2i,sizeY:1080
    on the other hand, does, and locks up the Xorg at the next start. So, if you get a hang system at X.org start, make sure you delete the amdpcsdb (or move it away) while X.org is not running to make sure you start clean (the file gets written again at every X.org exit so deleting it while X.org is running will not work).

    Oh, and I using:
    • Gentoo
    • Gigabyte GA-MA78GM-S2H (with the builtin 780G integrated HD3200)
    • Catalyst 9.2 currently

    Hope this helps someone =)
    Well, as I understand, both options are not working on the 9.2 driver.

    I used the underscan options before, and it worked well. It saved the info in the amdpcsdb.

    /Söder

    Comment


    • #32
      Originally posted by soder View Post
      Well, as I understand, both options are not working on the 9.2 driver.
      This is how I've understood it, too. At some point the first solution stopped working (might have been around 8.12~ish) and then the latter solution stopped working. In addition, the latter solution always hung up peoples boxes at the next X.org sartup, so people needed to use some script to delete the amdpcsdb.

      So, you might want to downgrade to a some earlier version, run the first fix, and downgrade again if it doesn't work. If it does, you could then upgrade back to the newest version and pray. I'd presume this would work, since I don't have this problem; though I've never actually done the above (I just used the fix when a version where it worked was recent).

      Yeah, this sucks.

      Comment


      • #33
        Now it has become very bad on my install: I am no longer able to use the 9.2 catalyst, X server produces a seg fault at start up.

        With ati driver, at X startup, 50% of the time the Samsumg TV indicates a "not supported mode". I have to switch from terminal mode to X mode (Ctl+Alt+F2 / Alt+F1) many times until eventually I get the TV displays the Gnome desktop (or until I am tired) !

        It is really depressing to have reached such a usefulness state after so many efforts...

        Will CC 9.3 version be our saver ?

        Regards

        Comment


        • #34
          You probably need to remove your /etc/ati/amdpcsdb file. If I use amdcccle at some point it (or driver or whatever) saves current resolution there just to set it again when X is restarted. For some unknown reason that causes crash on startup.

          By removing the whole file or just needed lines in the file you can probably start it again.

          Comment


          • #35
            At last I can insert happy face to the title

            New 9.3 release actually fixes overscan perfectly. It also seems to have as good performance as 9.2. So good work ATI!

            The issue mentioned in previous message (crash on startup if amdpcsdb contains resolution set on startup) is still available, but if this driver is as stable as previous I don't care for now. I rebooted this computer about twice when 9.2 was used (and neither of boots was caused by ATI drivers).

            Comment


            • #36
              Originally posted by Peruna View Post
              New 9.3 release actually fixes overscan perfectly. It also seems to have as good performance as 9.2. So good work ATI!
              .
              In 9.3 Catalyst Centre there is a setting (slider) for adjusting the underscanning that when put to 0% fixes the problem. However next time X will start it will crash (fix is to restore /etc/ati/amdpcsdb file to the default before starting X).

              I could not find the equivalent aticonfig for adjusting the underscanning. Any idea ? (ps.*I tried aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 and aticonfig --set-dispattrib tmds2i,positionX:0... without any success).

              Thanks

              Comment


              • #37
                Originally posted by mrechte View Post
                In 9.3 Catalyst Centre there is a setting (slider) for adjusting the underscanning that when put to 0% fixes the problem. However next time X will start it will crash (fix is to restore /etc/ati/amdpcsdb file to the default before starting X).

                I could not find the equivalent aticonfig for adjusting the underscanning. Any idea ? (ps.*I tried aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 and aticonfig --set-dispattrib tmds2i,positionX:0... without any success).

                Thanks
                Using 9.3 and the Control panel to set underscan to 0% does not crash X for me. Work perfectly. It is about time ATI fixed that issue.

                Comment


                • #38
                  mrechte, can you give some info about your configuration (GPU, bus, distro etc...) ?

                  Comment


                  • #39
                    Originally posted by bridgman View Post
                    mrechte, can you give some info about your configuration (GPU, bus, distro etc...) ?
                    I confirm that X start up crashes at the nex start-up unless I reset the default values.

                    My config is Fedora 10 on a Gigabyte MA78GPM-DS2H mother boeard (HD3200 chipset with 128MB of dedicated video RAM). Monitor a Samsumg TV (LEA52) on HDMI port.

                    Please, if at least I could issue an aticonfig command to restore my parameters automatically when Gnome session is opened, that would be nice (rather than going manually into CCC each time)

                    Thanks

                    Comment


                    • #40
                      I just picked up my new Nvidia GeForce 9400 GT. Not ATI for me for a while...

                      /Söder

                      Comment


                      • #41
                        Originally posted by mrechte View Post
                        I confirm that X start up crashes at the nex start-up unless I reset the default values.

                        My config is Fedora 10 on a Gigabyte MA78GPM-DS2H mother boeard (HD3200 chipset with 128MB of dedicated video RAM). Monitor a Samsumg TV (LEA52) on HDMI port.

                        Please, if at least I could issue an aticonfig command to restore my parameters automatically when Gnome session is opened, that would be nice (rather than going manually into CCC each time)

                        Thanks
                        I was having the same issue when fixing underscan using CCC. What worked for me was to fix the underscan in CCC for the display and then clicking the override default button right below it. The settings were saved on the next reboot. No more underscan.

                        I could not, however, change the refresh rate from 24Hz to 60Hz.

                        Hope this helps.

                        Comment


                        • #42
                          I am pleased to inform that my HD3200 is now working fine (on Fedora 10) with catalyst 9.5 (including desktop effects and video playback and no more under-scanning).

                          Thanks to Fedora and AMD.

                          Please don't break it again.

                          Comment


                          • #43
                            WARNING:

                            With Catalyst 9.6., you might get Overscan breakage AGAIN. I couldn't find a way to fix it quickly but I will post here again if I do.

                            I already tried:

                            Code:
                            aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
                            And I will now try the other fix. EDIT: The other way (with aticonfig --set-dispattrib) doesn't work, either. Also, in amdcccle, the option is greyed out. Also, I still can only run amdcccle as root, btw (if I run it as a regular user, all it's bits and segments fault terribly).

                            Good work AMD!

                            If anyone has any suggestions, they are deeply appreciated.
                            Last edited by Mr. Hilarious; 06-16-2009, 05:16 AM.

                            Comment


                            • #44
                              Wondering if it might be some kind of permission issue. Maybe try renaming or deleting the amdpcsdb and running aticonf --initial again. Try not to run aticonfig --initial as root.

                              Comment


                              • #45
                                Originally posted by Mr. Hilarious View Post
                                With Catalyst 9.6., you might get Overscan breakage AGAIN. I couldn't find a way to fix it quickly but I will post here again if I do.
                                I was able fix it, but then I was hit by a different bug. The:

                                Code:
                                aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
                                did eventualy fix the underscan, but I needed to 1) run it when X.org was NOT running (i.e. from a VC), and, also I needed to 2) delete the amdpcsdb file prior to running it. If I didn't do either one of those, then there was the underscan still present next start of Xorg.

                                BUT, while figuring that out, I got the other problem. At some point the fonts got all screwy, probably because of deleting the amdpcsdb file. After upgrading to 9.6, initially the fonts were OK (with the underscan), but then, suddenly all the fonts were changed to unreadable size; i.e. 3 pixels high (and at this point I got the underscan fixed). There used to be a very old bug in X.org that caused the same issue (but that was fixed). I got the dimensions of my LCD TV told (or lied, because Xorg does not have settings for viewing distance) in xorg.conf.

                                After deleting everything in /etc/ati and re-installing the 9.6, I gave up and downgraded to 9.5 (aka. 8.612 - previosly I had 9.4), and all the fonts are puffy again as they should be. If someone is interested, I got the Xorg.0.log file for 9.6 when the fonts didn't work, and one right after the downgrade to 9.5 (where everything is as it should be).

                                Originally posted by bridgman
                                Wondering if it might be some kind of permission issue. Maybe try renaming or deleting the amdpcsdb and running aticonf --initial again. Try not to run aticonfig --initial as root.
                                Bridgman: I didn't try your suggestion, as I red it after I downgraded. I did run 'aticonfig --initial', but I did so as root. It added one line to my Xorg.conf (a line for PCIID of the card, but that didn't change anything, since the driver did find the card without one). I thought running aticonfig --initial only checks the current xorg.conf (or one given to it on the command line) and makes changes if needed - and as such it would not make sense to run it as non-root. Am I missing something? Maybe I should try it again at some point.

                                You might be right in that there might have been some permission issue somewhere for a long time, since suddenly I am able to run amdcccle as a regular user, after this upgrade-downgrade hassle.

                                Comment

                                Working...
                                X