No announcement yet.

Long pauses

  • Filter
  • Time
  • Show
Clear All
new posts

  • Long pauses

    I'm seeing long pauses happen in some 3d applications or ones that use opengl. I'm talking about complete system pauses, total lag of some sort. Compiz does this, it seems to degrade so that it happens more often and the pauses are longer. It doesn't happen for all 3d, but I assume for the ones that does it's the same bug. This seems to happen particularly when opengl is used for 2d like for playing video. It doesn't seem to happen with regular 3d applications like games and such. Is this known and is there a work around?

  • #2
    You could try using the kernel boot option



    • #3
      Thanks, looks like that was it. At least it's back to how it used to be, pauses very short if anything, much better. I should have known about a PAT issue but I just didn't see it posted anywhere.


      • #4
        What's this "PAT" thing anyway? I can imagine it being enabled must be "a good thing" and Catalyst getting broken by it "a bad thing?"


        • #5
          As I understand it, it's a newer type of MTRR (memory type range register) in more recent linux.


          • #6
            Funny thing is, fglrx says "[fglrx] PAT is enabled successfully!" regardless of whether the nopat kernel option is used or not. The difference is that the freezes are gone with nopat.


            • #7
              My dim understanding is that MTRR lets you set memory attributes (cached, write combining etc..) on an entire range at a time (easy but not precise) while PAT allows the driver or OS to adjust the settings on a page-by-page basis.