Announcement

Collapse
No announcement yet.

Catalyst + Compiz = GUI lag

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst + Compiz = GUI lag

    I've had Compiz Fusion working very nicely with the radeon driver on an X1950XT. I've also tried the Catalyst drivers back then, but it was crap. The GUI was lagging (menus open up with big delay, likewise for maximizing and minimizing windows).

    With the HD4870, the only driver that works is Catalyst. But even in the latest version (8.11) the lag is not gone. Will we get decent performance this century or should I go on and apply for the cryostasis program and tell them to wake me up in 2100?

    PS:
    It's funny that the open source radeon driver beats Catalyst by orders of magnitude in this one.

  • #2
    Originally posted by RealNC View Post
    I've had Compiz Fusion working very nicely with the radeon driver on an X1950XT. I've also tried the Catalyst drivers back then, but it was crap. The GUI was lagging (menus open up with big delay, likewise for maximizing and minimizing windows).

    With the HD4870, the only driver that works is Catalyst. But even in the latest version (8.11) the lag is not gone. Will we get decent performance this century or should I go on and apply for the cryostasis program and tell them to wake me up in 2100?

    PS:
    It's funny that the open source radeon driver beats Catalyst by orders of magnitude in this one.
    Wait for OSS R600 accel :-)

    To be fair to fglrx I think it's because radeon uses EXA. If you set it to use XAA then you get the same delay as fglrx.

    Comment


    • #3
      I remember some older GeForce cards not having this problem, even long before EXA actually existed, so that can hardly be the problem.

      Comment


      • #4
        Originally posted by RealNC View Post
        I remember some older GeForce cards not having this problem, even long before EXA actually existed, so that can hardly be the problem.
        I though nvidia used some of its own X stuff, but I've never had one to test.

        Whatever the cause, using radeon[hd] on my R500 card with the latest xorg behaves the same as fglrx in compiz if XAA is used.

        Comment


        • #5
          Which is not really good :P I mean, we *pay* for this. We should expect good performance.

          Comment


          • #6
            Originally posted by RealNC View Post
            I've had Compiz Fusion working very nicely with the radeon driver on an X1950XT.
            Hi, can you show me your xorg.conf?
            regards

            Comment


            • #7
              These are the relevant parts:

              Code:
              Section "Device"
                      Identifier  "X1950XT"
                      Driver      "radeon"
                      Option      "UseAtomBIOS" "true"
                      Option      "AccelMethod" "EXA"
                      Option      "AccelDFS" "on"
                      Option      "EnablePageFlip" "on"
                      Option      "TripleBuffer" "true"
                      Option      "DMAForXv" "true"
                      Option      "DynamicClocks" "on"
                      Option      "VGAAccess" "off"
                      Option      "DRI"
              EndSection
              
              Section "Screen"
                      Identifier "Screen 1"
                      Device     "X1950XT"
                      DefaultDepth     24
                      SubSection "Display"
                              Viewport   0 0
                              Depth     8
                              Modes    "1280x1024" "1024x768" "800x600" "640x480"
                      EndSubSection
                      SubSection "Display"
                              Viewport   0 0
                              Depth     16
                              Modes    "1280x1024" "1024x768" "800x600" "640x480"
                      EndSubSection
                      SubSection "Display"
                              Viewport   0 0
                              Depth     24
                              Modes    "1280x1024" "1024x768" "800x600" "640x480"
                      EndSubSection
              EndSection
              
              Section "DRI"
                      Mode         0666
              EndSection
              Note: the "DRI" section with "Mode 0666" is crucial. It won't work without it.
              Last edited by RealNC; 11-28-2008, 01:34 PM.

              Comment


              • #8
                Originally posted by RealNC View Post
                These are the relevant parts:

                Note: the "DRI" section with "Mode 0666" is crucial. It won't work without it.
                Thanks a lot.
                Regards

                Comment

                Working...
                X