Announcement

Collapse
No announcement yet.

How to Catalyst 8.11 on Ubuntu 8.10?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The new script worked perfectly for me. Thanks for the help!

    Comment


    • #17
      No problem, it took a bit time to discover what was going on wrong, but then it was easy. I am used to fix ati packageing faults or adding extra kernel hotfixes - you see that when you look at the size of the script Saidly I can not fix the driver itself. Try nexuiz and change res inside the game for example...

      Comment


      • #18
        I had success with Kano's script, fglrx is installed and working on 8.10 kubuntu, the process takes a fair bit of time on satelite.

        Comment


        • #19
          Perfect Script!! Amd should Hire you kano!

          Just run it and everything is done for you... I'm... gratefull

          Comment


          • #20
            I'm having a very odd problem. I've got a fresh install of Intrepid, and I've attempted to install the new Catalysts with both this script and the standard ATI installation script. I can get both to work correctly after the first reboot. However, after I reboot again the machine crashes hard and falls to a blank screen when X tries to start. The module seems to be loaded correctly. The log is basically the same as the one posted earlier that ends with "(EE) No devices detected." Between reboots I'm doing nothing other than a glxinfo | grep render to make sure things are working. Anyone have any ideas?

            Comment


            • #21
              Kano,

              Your script worked like a charm to install the driver, which is great.

              What doesn't make sense is why the xorg.conf file the script creates has the following in the Device section:

              Code:
              Section "Device"
              	Identifier  "aticonfig-Device[0]-0"
              	Driver      "fglrx"
              	Option      "UseInternalAGPGART" "no"
              	Option      "VideoOverlay" "on"
              	Option      "OpenGLOverlay" "off"
              	Option      "MonitorLayout" "LVDS, AUTO"
              	BusID       "PCI:1:0:0"
              EndSection
              VideoOverlay is only applicable to the pre-R500 cards, it is replaced by TexturedVideo in the later cards. Also, the AGPGART option only applies to AGP cards, and OpenGLOverlay is disabled by default.

              Why not just have the script run a standard sudo aticonfig -f --initial to create a standard default configuration? Recent fglrx versions have ceased to use xorg.conf as the primary configuration file anyway, it's all done in /etc/ati/amdpcsdb now.

              Fill me in, if there's something that I'm missing?

              Comment


              • #22
                Well the script is older than you might think. Maybe I disalbe the 2 Overlay options. But I never tested something newer than RV410 and usually nobody reported errors with those settings. A clever driver would ignore those options anyway if the hardware is not there. aticonfig creates absolutely stupid looking xorg.conf files and also segfaults from time to time. The /etc/ati dir is of course cleaned before driver install.

                Comment


                • #23
                  This version of fgrx does not play nicely with the EDID modes reported by my HTPC's display, which is a Westinghouse 37" monitor. This is true of both Catalyst 8.10 (ubuntu provided) and the Catalyst 8.11 installed by the script.

                  The radeon driver works perfectly and displays flawless 1920x1080, while fglrx refuses to display at all, it fails with "no screens found" and won't even display text modes properly.

                  Unfortunately, when I tried to roll back to the radeon driver, I discovered that YOUR SCRIPT HAD UNINSTALLED IT.

                  This was incredibly frustrating, because I had to reinstall the radeon and ati (wrapper) drivers manually from Tormod Volden's PPA, as well as reinstall and reconfigure Mesa. There is no reason to uninstall these! Why does your script do this?
                  Last edited by Porter; 12-07-2008, 10:31 AM.

                  Comment


                  • #24
                    Nope, it did not uninstall radeon. You just have to correctly switch back. You have to do 3 things:

                    a) sudo apt-get remove --purge $(dpkg -l|cut -f3 -d' '|grep -e fglrx -e libamdxvba)
                    b1) mv /etc/X11/xorg.conf.pure /etc/X11/xorg.conf
                    b2) if there is no xorg.conf.pure: mv /etc/X11/xorg.conf.1st /etc/X11/xorg.conf
                    c) reboot or shutdown X, rmmod fglrx; start X.

                    Comment


                    • #25
                      Similar Error with radeon hd 4350

                      Originally posted by Porter View Post
                      This version of fgrx does not play nicely with the EDID modes reported by my HTPC's display, which is a Westinghouse 37" monitor. This is true of both Catalyst 8.10 (ubuntu provided) and the Catalyst 8.11 installed by the script.

                      The radeon driver works perfectly and displays flawless 1920x1080, while fglrx refuses to display at all, it fails with "no screens found" and won't even display text modes properly.

                      Unfortunately, when I tried to roll back to the radeon driver, I discovered that YOUR SCRIPT HAD UNINSTALLED IT.

                      This was incredibly frustrating, because I had to reinstall the radeon and ati (wrapper) drivers manually from Tormod Volden's PPA, as well as reinstall and reconfigure Mesa. There is no reason to uninstall these! Why does your script do this?
                      I am getting the exact same error as above. BUT... Without the FGLRX driver video acelleration will not work. I am thinking of trying the radeon hd drivers, as they might support it.

                      Comment


                      • #26
                        Originally posted by LinuxID10T View Post
                        I am getting the exact same error as above. BUT... Without the FGLRX driver video acelleration will not work. I am thinking of trying the radeon hd drivers, as they might support it.
                        You're using an R5xx or newer card?

                        Video acceleration works with the radeon driver on recent cards if you install the latest version from Tormod Volden's PPA, and specify EXA as the render method in xorg.conf. Once you do that, Xv acceleration should work.

                        Assuming you are running Ubuntu, install the latest latest (non debug) video-ati and video-radeon packages from http://ppa.launchpad.net/tormodvolde...org-video-ati/

                        Comment

                        Working...
                        X