Announcement

Collapse
No announcement yet.

AMD Catalyst 8.11 Linux Driver Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    ok, I found the problem. Had to change x710 to x740 in the ebuild. Well, I should have read and think first, instead of half a douzend upgrade/downgrade cycles. The good thing, it is cold outside, but my room is nice an cozy now

    Comment


    • #17
      Originally posted by energyman View Post
      that is probably some update error, not a xorg.conf problem. Somewhere are files from the old driver - like the old fglrx module still loaded. Hard to say without the log file.
      My 8.10 was from synaptic, so I've uninstalled it with --purge. I think its clean enough (searched for a *fglrx* on / but didnt found anything).

      I don't know much about installing fglrx driver, cause I've bought ATI recently, so I've just installed it with this guide
      but I couldn't make it work.

      Comment


      • #18
        I don't use ubuntu - with gentoo it is a bit of ebuild editing&renaming - still, your Xorg.0.log would be very helpfull. You find it in /var/log

        Comment


        • #19
          Ah well, another confirmation, Xorg 7.4 / XServer 1.5 working with Ubuntu 8.10. I had a little trouble trying to generate distro packages, but I just removed everything ati and used the automated installer for a change... Still reporting 1.2 glx server version, and only GLX_SGIX_pbuffer...

          Comment


          • #20
            Originally posted by energyman View Post
            I don't use ubuntu - with gentoo it is a bit of ebuild editing&renaming - still, your Xorg.0.log would be very helpfull. You find it in /var/log
            Well, that was the first thing I've checked, but I dont know really whats going on there. Ill be very glad if you can find a solution here :
            Xorg.log
            xorg.conf

            Comment


            • #21
              Tares, just remove all packages and use the automated installer... I can't do packages anymore unless they are synaptic based... Some glitch in the installer causes a version mismatch with one of the modules...

              Long story short I just used the automated installer.

              Comment


              • #22
                Also if you haven't gotten backing store to work with the new xorg/xserver using the synaptic package, turn it off... It didn't work for me, and with 1066 dual channel I really don't notice a difference so I haven't bothered testing it again...

                Comment


                • #23
                  Tares, your installation is messed up. You are loading the glx module from X instead of the driver and you are trying to load the 8.10 or earlier driver and not 8.11.

                  Comment


                  • #24
                    I still cant minimize 3d applications.
                    http://ati.cchtml.com/show_bug.cgi?id=1278
                    Back to 8.8.

                    Comment


                    • #25
                      Originally posted by Methylene View Post
                      Also if you haven't gotten backing store to work with the new xorg/xserver using the synaptic package, turn it off... It didn't work for me, and with 1066 dual channel I really don't notice a difference so I haven't bothered testing it again...
                      Thanks Methylene. Using --install works. Well I've disabled loading dri/glx/glcore and turned off backing store, but I doubt that had any impact ;-)

                      Anyway with this release, amdcccle still reports that my fglrx works in mesa mode :/

                      Comment


                      • #26
                        Disable Xgl.

                        Comment


                        • #27
                          I followed the instructions on CCHTML wiki (I did it multiple times before for Ubuntu 8.04 and ATI 8.10 driver) and got problems. This guy had the same problem:

                          http://www.mail-archive.com/ubuntu-b...sg1149141.html

                          I am using Xubuntu 8.10.

                          Comment


                          • #28
                            Originally posted by Kano View Post
                            Disable Xgl.
                            I don't have it even installed, AIGLX turned off.

                            Comment


                            • #29
                              Tares, deinstall everything and wait for the ubuntu package, ok? And please check your system thoroughly for stale files.

                              Comment


                              • #30
                                Hi, I installed Catalyst 8.11 yesterday after reupgrading to XServer 1.5.
                                However, when I boot into graphical mode (i.e. start the x server), Xorg.log says:
                                (II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000010, disabled=0x00000000
                                (II) fglrx(0): Connected Display1: CRT on secondary DAC [crt2]
                                (II) fglrx(0): Display1: No EDID information from DDC.
                                (EE) fglrx(0): Unknown EDID version 0
                                (II) fglrx(0): Display1: Failed to get EDID information.
                                And then it falls back to 640x480, though it should use 1280x1024..
                                Is there any way to force fglrx to use the better resolution (Note: I can switch to 1280x1024 by using KRandrTray or so, if that's useful information)?
                                This is on an ATI 3850.

                                And by the way, there is a VERY painful bug causing window resizing (at least in Compiz) to have a delay of multiple seconds...

                                EDIT: Oh, well... the log goes further:
                                (EE) fglrx(0): Unknown EDID version 0
                                (II) fglrx(0): Display1: Failed to get EDID information.
                                (WW) fglrx(0): Only one display is connnected,so single mode is enabled
                                (II) fglrx(0): Primary Controller - CRT on secondary DAC
                                (II) fglrx(0): Internal Desktop Setting: 0x00000001
                                (==) fglrx(0): QBS disabled
                                (==) fglrx(0): FAST_SWAP disabled
                                (==) fglrx(0): PseudoColor visuals disabled
                                (==) fglrx(0): Center Mode is disabled
                                (==) fglrx(0): TMDS coherent mode is enabled
                                (II) fglrx(0): Total of 2 modes found for primary display.
                                So I guess the problem can be reduced to finding a way to tell fglrx to actually use the higher resolution, but specifying the resolution via aticonfig didn't work...
                                Last edited by NeoBrain; 11-14-2008, 09:18 AM.

                                Comment

                                Working...
                                X