Announcement

Collapse
No announcement yet.

Catalyst 8.11

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Yes, there is no tearing when using OpenGL even with new 8.11 driver.

    You just need to use Catalyst Control Center and set 3d Vertical Refresh to always on (max quality).

    mplayer -vo gl:yuv=5 video.avi


    Works for me atleast.

    Comment


    • #12
      Same crap every month, now with new errors :S

      Errors with AIGLX
      Code:
      (EE) AIGLX error: fglrx exports no extensions (/usr/lib64/dri/fglrx_dri.so: undefined symbol: __driDriverExtensions)
      (EE) AIGLX: reverting to software rendering
      amdccle crashes
      Code:
      #0  0x00007f90a1c32390 in strcpy () from /lib/libc.so.6
      #1  0x00007f90a043dc3b in LnxXextOglGetInfo () from /usr/lib/libatiadlxx.so
      #2  0x00007f90a0435f21 in ADL_Adapter_SWInfo_Get () from /usr/lib/libatiadlxx.so
      #3  0x000000000060d91e in CADLDriver::GetSWInfo ()
      #4  0x000000000057b5a9 in CInfoRule::GetDriverData ()
      #5  0x000000000057b00d in CInfoRule::Initialize ()
      #6  0x00000000005724a8 in CLDC::Initialize ()
      #7  0x0000000000571032 in main ()
      glxgears report over 2300fps but the window is laggy when i try to move it, and fgl_glxgears show a completly corrupted animation

      Any ideas?

      EDIT: trying to enable the kde compositing the X server crashes
      Code:
      Backtrace:
      0: /usr/bin/X(xf86SigHandler+0x65) [0x480a9d]
      1: /lib/libc.so.6 [0x7f8878e33130]
      2: /usr/lib64/xorg/modules/extensions//libglx.so(__glXDeassociateContext+0x30) [0x7f8877956ffd]
      3: /usr/lib64/xorg/modules/extensions//libglx.so(__glXContextDestroy+0xf) [0x7f8877953c15]
      4: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f8877956472]
      5: /usr/lib64/xorg/modules/extensions//libglx.so(__glXFreeContext+0x65) [0x7f887795594b]
      6: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f887795597a]
      7: /usr/bin/X(FreeResourceByType+0xe9) [0x4335c1]
      8: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f8877952b0d]
      9: /usr/lib64/xorg/modules/extensions//libglx.so [0x7f8877955ab6]
      10: /usr/bin/X(Dispatch+0x33a) [0x44813c]
      11: /usr/bin/X(main+0x43e) [0x4312aa]
      12: /lib/libc.so.6(__libc_start_main+0xf4) [0x7f8878e1fb74]
      13: /usr/bin/X(FontFileCompleteXLFD+0x251) [0x430719]
      X.Org X Server 1.5.2
      Linux 2.6.27
      ATI Radeon Mobility X1400
      Last edited by codestation; 11-13-2008, 03:34 PM.

      Comment


      • #13
        Package build failed!

        I wanted to try new version and I couldn't even build driver, all I got is this:

        ./ati-driver-installer-8-11-x86.x86_64.run --buildpkg SuSE/SUSE110-IA32
        Created directory fglrx-install.CEzyKE
        Verifying archive integrity... All good.
        Uncompressing ATI Proprietary Linux Driver-8.552.......... DOTS TRIMMED
        ==================================================
        ATI Technologies Linux Driver Installer/Packager
        ==================================================
        Generating package: SuSE/SUSE110-IA32
        /tmp/ati.ciYtWR
        Package build failed!
        Removing temporary directory: fglrx-install.CEzyKE

        Old version (8.10) is still building well on my configuration. Any idea?

        Comment


        • #14
          Driver 8.11 is NOT working for me.
          I use 64-bit Xubuntu 8.04.1 LTS

          8.10 used to destroy my Gaming experience in UrbanTerror and Nexiuz and other (GL screen shifted to the right and down, therefore useless)
          but 8.11 really does not work at all

          I use Biostar 690G AM2 motherboard with 690g Chipset (X1250).
          I made packages for Ubuntu 8.04/Hardy and installed them and then
          did sudo aticonfig --initial -f after that
          and restart.

          Driver does Not work, all I get is Ubuntu screen for setting up hardware
          and after a while, I can only log in 800x600 vesa, I think.

          Do Not use this 8.11 driver with Ubuntu 8.04 64-bit/amd64!

          I reverted back to 8.10 for even to get picture on monitor.
          I am thinking to go back to 8.9 when my games used to behave normal.
          Last edited by Markore; 11-15-2008, 08:35 AM.

          Comment


          • #15
            @ NeoBrain:
            One other thing I had a problem with is that fglrx still can't detect my monitor's EDID correctly
            This is not necessarily a driver problem.- It could also be something very simple like an old VGA-cable or a faulty plug. I just had that myself... :-)

            Comment


            • #16
              Look here for fix

              Originally posted by shinigami View Post
              ./ati-driver-installer-8-11-x86.x86_64.run --buildpkg SuSE/SUSE110-IA32
              [...]
              Package build failed!
              [...]
              Old version (8.10) is still building well on my configuration. Any idea?
              Hi shinigami,

              I experienced the same problem - you can find my fix for it here.

              Cheers,
              knutbert

              Comment


              • #17
                For me since the catalyste 8.8 release I cannot use the composite extension with Mandriva and the 8.11 version didn't fix it.

                Does anyone had this problem?

                Is this bug distribution specific?

                Comment


                • #18
                  Originally posted by Peruna View Post
                  Yes, there is no tearing when using OpenGL even with new 8.11 driver.

                  You just need to use Catalyst Control Center and set 3d Vertical Refresh to always on (max quality).

                  mplayer -vo gl:yuv=5 video.avi


                  Works for me atleast.
                  thanks a lot. that worked great. I switched back to 8.8 as well so that I could use force-pbo. Unfortunately even with that, I still couldn't play 1080p mpeg2. Here's what I used for mplayer

                  vo=gl,yuv=5,swapinterval=1,force-pbo,ati-hack

                  Do you set any other switches in order to play 1080p? thanks.

                  Comment


                  • #19
                    I use vo=gl:nomanyfmts. This works much better for me than any yuv= option.

                    Comment


                    • #20
                      anyone else having trouble to get this driver working on a 780g + HD3200 onboard card?

                      Everything installs fine, fglrx module loads, but when I start X the screen stays black. No errors in the log, just a "giving up." at the end of startx.

                      I'm using gentoo, btw.

                      Comment

                      Working...
                      X