Announcement

Collapse
No announcement yet.

CPUFreq Ondemand Could Be Faster, Use Less Power With Linux 3.17

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Baconmon View Post
    You can't wait until kernel 3.17 to have a 6% increase in speed??..
    I think a workaround until then would be go buy a faster processor..
    I was referring to governor tweaks. I'm using currently 2 sets of tweaks, but they might be outdated.

    First set:

    Code:
    /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor = 6
    /sys/devices/system/cpu/cpufreq/ondemand/up_threshold = 35
    /sys/devices/system/cpu/cpufreq/ondemand/ignore_nice_load = 1
    
    #Battery
    /sys/devices/system/cpu/cpufreq/ondemand/powersave_bias = 200
    Second set (battery only)

    Code:
    /sys/devices/system/cpu/cpufreq/conservative/up_threshold = 98
    /sys/devices/system/cpu/cpufreq/conservative/down_threshold = 95
    /sys/devices/system/cpu/cpufreq/conservative/sampling_down_factor = 7
    /sys/devices/system/cpu/cpufreq/conservative/ignore_nice_load = 1

    Comment


    • #12
      Originally posted by rdnetto View Post
      The approach you suggest would be less responsive. i.e. it would take more iterations to reach the desired state. Hysteresis (jumping between states) would be a problem too, depending on how you tuned it.
      I suspect the reason the algorithm is designed that way is that it makes it much easier to apply control theory to its design, since the definition does not rely on current state.



      The CPUFreq governors offer more control. That said, according to this appears that even if CPUFreq specifies a certain frequency, the governor built into the CPU treats it as a suggestion only.
      Control Theory uses a feedback loop (thus hysteresis), according to the link you provided.

      Comment


      • #13
        Nice, a change (and an article) I can understand .

        … And I just noticed I don’t have a /sys/devices/system/cpu/cpufreq/ anymore… acpi_cpufreq refuses to load, and /proc/cpuinfo says my Core i3 550 (3.2GHz) is running at 3840.242 MHz. Meh.

        Comment


        • #14
          Originally posted by stqn View Post
          Nice, a change (and an article) I can understand .

          … And I just noticed I don’t have a /sys/devices/system/cpu/cpufreq/ anymore… acpi_cpufreq refuses to load, and /proc/cpuinfo says my Core i3 550 (3.2GHz) is running at 3840.242 MHz. Meh.
          Start the driver manually (i.e.: using modprobe) if you have to. And IIRC, it's

          Code:
          acpi-cpufreq
          , not
          Code:
          acpi_cpufreq
          Last edited by Sonadow; 07-24-2014, 02:21 AM.

          Comment


          • #15
            Originally posted by Sonadow View Post
            Start the driver manually (i.e.: using modprobe) if you have to. And IIRC, it's

            Code:
            acpi-cpufreq
            , not
            Code:
            acpi_cpufreq
            Thanks Sonadow, I found out today that I had to set EIST to Enabled instead of Auto in my BIOS to make cpufreq work.
            In module names, - and _ are interchangeable (which is confusing, but true).

            Comment

            Working...
            X