No announcement yet.

ASRock Z97 Extreme6

  • Filter
  • Time
  • Show
Clear All
new posts

  • ASRock Z97 Extreme6

    Phoronix: ASRock Z97 Extreme6

    Those looking for an Intel Z97 motherboard that's Linux-friendly and jam-packed with features should checkout the ASRock Z97 Extreme6 as it should cost you less than $170 USD.

  • #2

    Too bad I am AMD fanboy.
    But does Linux support thunderbolt at all, I was under impression sh** just doesn't work?


    • #3
      Onboard gfx speed depends on RAM timing and gfx clock. My guess is that the fastest xmp profile was used by default and no standard ddr3-1600 timing with OC RAM. I dont think that using just optimized defaults is enough, some vendors like Asus even disable vt-t by default... Best check those settings, if needed using CPU-Z. Asus used another trick with board, after selecting a custom RAM speed the turbo mode is working in an all cores mode. Usually the highest turbo is only specified for 1 core at max speed with an i7-3770S but then all cores work at that speed, that is a benchmark cheat as well. With 3.16+ the turbo speed is exposed via standard /proc/cpuinfo, before tools like i7z are needed, you can simply run benchmarks with different thread settings and monitor the turbo speed. One other possible trick to cheat would be disabling the power restrictions for turbo boost. I do NOT think that asrock uses standard settings the way you tested the board.


      • #4
        I do like ASRock's Extreme6 line of motherboards. I own an FM2 Extreme6 board and my friend owns a Z77.
        We've never had a problem with either boards, both boards have a ton of features, were reasonably (cheaply) priced and are built pretty well.


        • #5
          Asrock's newer motherboards seem to be a lot better. They used to be iffy. Now they are rock solid.


          • #6
            Thanks for the excellent article. Although, I only read the first page and the "Linux Compatibility" section which is my main concern when it comes to choosing hardware.


            • #7
              I didn't know motherboards even were an issue. What is it on motherboards that doesn't always work with Linux? Maybe I've just been lucky? I use a Gigabyte GA-990FXA-UD3 right now.


              • #8
                Ethernet adapter, for one, and only in some cases and only with some Distros. My new mobo came with an Intel 1218-V Ethernet adapter. Works fine under Ubuntu, but Fedora 20 could not find the adapter, nor can the latest SystemRescueCD or AVGRescueCD.

                Intel has released a Linux driver, so I doubt that getting it working under Fedora is a big deal. I haven't tried to insert into a LiveCD environment like SystemRescueCD, yet.

                Or, maybe it's a license issue with some distros. I dunno, I try to stay away from that part of the ecosystem.
                Last edited by rbmorse; 06-27-2014, 01:11 AM.


                • #9
                  Originally posted by xeekei View Post
                  I didn't know motherboards even were an issue. What is it on motherboards that doesn't always work with Linux? Maybe I've just been lucky? I use a Gigabyte GA-990FXA-UD3 right now.
                  I think the Linux compatibility issues suggested in the article are based on this quote:

                  The only real issue encountered with the modern motherboards have been the lack of LM_Sensors support for being able to detect and read the onboard motherboard hardware sensors (temperatures, fan speeds, voltages, etc). The ASRock Z97 Exteme6 is no different to the other Z97 motherboards tested at Phoronix. The ASRock Z97 Extreme6 happily booted up on Ubuntu 14.04 LTS without any issues, but was unable to detect any onboard sensors besides for the coretemp driver reading the Core i7 processor's thermal data.
                  It would be nice if there was a reference in the article to captures that Michael may have for the following Linux commands:

                  lspci -vvvv

                  Then any user planning to run Linux on this and any other motherboards that Michael tests for Phoronix will have a much better understanding of the actual hardware found on the motherboard. The output of "sensors-detect" would be especially interesting since Michael claims to have issues detecting sensor chips. The "sensors-detect" command will show all of us what might be found by that command and why (or why not) "sensors-detect" does or does not detect any sensors on the boards that he tests.

                  On the other hand, maybe I didn't find the link to Michael's test suite results in the article? Michael, why not include these commands in your test suite, perhaps as an option so that those commands don't have to be run on systems that obviously don't have such capabilities? For example, if you ran "lspci" on a POGOplug E02, a very simple ARM-based device, it would not find a PCI bus not would it find any sensors, but other aspects of the test suite might run on such a simple device if it supported that "target" system.


                  • #10

                    First time posting here, I can usually find the information I need, but sometimes I have to ask. So from browsing a lot, it seems that there aren't any motherboard with a z97 chip currently supported by lm_sensors, which means, if I'm not mistaken, no fan control.

                    The question is, how do the fans behave? I will buy a motherboard soon, and maybe plan to use watercooling. I guess the fans will be automatically throttled by the board, and that would probably be enough for me, but I want to be sure.

                    If the lack of fan control means the fans will run full speed constantly (as I remember hearing about), it kind of defeats the purpose of watercooling.

                    Can we get some more information about that specific point?



                    • #11
                      Not Working


                      My first time posting. After reading the article and seeing this comment I purchased a new set of components for building a system based on the ASRock Z97 Extreme6. Haven't built a system in years and thought it would be fun.

                      Originally posted by phoronix View Post
                      Phoronix: ASRock Z97 Extreme6

                      Those looking for an Intel Z97 motherboard that's Linux-friendly and jam-packed with features should checkout the ASRock Z97 Extreme6 as it should cost you less than $170 USD.

                      Everything seemed to go well until it was time to power-up. I got a 00 (processor problem) code and about 1/2 second of power. ASRock support told me that the BIOS that came with the board did not support the i7 4790K and sent me a bios chip in the mail. I installed it and had the same problem so am returning the board to Newegg. A few random google searches seems to show similar problems. Does anyone have direct experience with this? Any suggestions as to what I may have done?

                      I've tried two different boards now with two different processors (both were new i7-4790K)

                      Proceed cautiously...

                      P.S. Trying a Gigabyte GA-Z97MX-Gaming 5 next as some folks seem to have good luck with Gigabyte boards. Any thoughts?


                      • #12
                        i had been planning new build for several months, my first in years, and finally decided to go with this board because (a) Michael's suggestion, (b) all the connectivity on the board and (c) it looked like a big play pen for hardware that i'd like to try. here's the gear i went with:

                        ASRock Z97 Extreme6
                        Intel Core i7-4790
                        G.Skill RipJawsZ DIMM kit 16GB, DDR3-2400, CL9-11-11-31
                        Crucial MX100 512GB
                        HGST Deskstar NAS 4TB 7200rpm
                        be quiet! Shadow Rock Slim
                        2x Noctua NF-P14s redux-1200 PWM 140mm
                        Cooler Master HAF XB Evo Cube
                        Super Flower Leadex Gold 650W

                        system build was a dream, love Love LOVE the Cooler Master case. basic tweaks for the fast memory and improved fan profiles was dead easy with good results. idle temps on CPU and mobo are ambient plus a few C, as expected.

                        intalled Mint 17 KDE -- no problems -- and it's all up and running very nicely, typing this post on it now.

                        system runs very quiet. under heavy load temps reach 50ish but the cooler works well (afaik) and the tweaked fan profiles bring cool-down time to a couple of seconds.

                        overall i love it, a superb SOHO/multimedia system with the juice to do pretty much anything i throw at it including some real gaming once i get a good graphics card to go with. i know the processor and memory were overkill but i had my reasons and wanted the extra muscle on hand.

                        one snafu: analog sound is buggered, totally washed out with static. unuseable. HDMI audio is fine.

                        anyone have ideas how to fix the analog sound?
                        Last edited by hooly; 07-25-2014, 01:18 PM.


                        • #13
                          seems it's a known problem with ALC1150 on the Z97 chipset:

                          Bug #1321421 8086:8ca0 Sound output distorted/unusable with Intel Z97/H97

                          within the bug discussion is a fairly straightforward solution, simple addition to /etc/modprobe.d/alsa-base.conf which does seem to fix things.


                          • #14
                            tried to post this yesterday .. discovered that there is a know problem in pre-3.16 kernels regarding analog audio and the ALC1150. see for details.

                            turns out a localized fix is pretty straight-forward, a simple edit and reboot.


                            • #15
                              I also had some problems with this board. I've tried to install Arch but I wasn't able to boot Arch from an USB Stick (freeze at startup) or even Ubuntu from CD (blank screen). After adding the "acpi=off" parameter at the kernel line I've just got an kernel panic message.

                              It turned out (after a few hours ), that my DVD drive was connected to a SATA port from the ASMedia chip and after disabling the chip/unplugging the drive everything works fine .

                              So just in case that some of you are trying to use more than 6 SATA drives, you might get some problems.