Announcement

Collapse
No announcement yet.

LM_Sensors 3.1.2 Released: Better HW Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LM_Sensors 3.1.2 Released: Better HW Support

    Phoronix: LM_Sensors 3.1.2 Released: Better HW Support

    Jean Delvare has announced the second point release for the LM_Sensors 3.1 series, which was introduced last March. The LM_Sensors 3.1.2 release delivers better Linux system sensor monitoring support by preemptively adding support for future kernels and HID devices in libsensors, the sensord daemon has received a lot of clean-ups, and sensors-detect is better detecting the supported sensors with drivers. The LM_Sensors 3.1.2 release announcement can be found on the project's mailing list...

    http://www.phoronix.com/vr.php?view=Nzk1Mg

  • #2
    Not too clear from the site, but did they ever get temp reporting working in the AMD phenom II's?

    Comment


    • #3
      Originally posted by rotarychainsaw View Post
      Not too clear from the site, but did they ever get temp reporting working in the AMD phenom II's?
      According to the official list, there should be working support in 2.6.33 for all hardware that doesn't suffer from Errata 319, which may or may not include your CPU. (Of course, according to the documentation this feature doesn't actually measure absolute temperature anyway, just temperature relative to the point at which maximum cooling is needed.)

      Comment


      • #4
        The sensor on AM3 CPUs works correctly. Erratum 319 applies to all Socket F and AM2+ CPUs, but it says that the sensor "might be unreliable", so it might actually work in specific cases.

        The k10temp driver is part of the kernel (or you can get it from the website separately if you want to compile it yourself); the new version of the lm_sensors library is not required.

        Comment


        • #5
          Does lm-sensors support reporting voltage values on any hardware?

          Comment


          • #6
            my p2 X4 3.4 now works on a n msi board, this was only fixed in 2.6.33

            f71889fg-isa-0e80
            Adapter: ISA adapter
            in0: +1.68 V
            in1: +0.98 V (max = +2.04 V)
            in2: +1.09 V
            in3: +0.87 V
            in4: +0.63 V
            in5: +0.42 V
            in6: +0.31 V
            in7: +1.67 V
            in8: +1.63 V
            fan1: 1022 RPM
            fan2: 0 RPM ALARM
            fan3: 0 RPM ALARM
            temp1: +42.0C (high = +255.0C, hyst = +251.0C)
            (crit = +255.0C, hyst = +251.0C) sensor = Intel PECI
            temp2: FAULT (high = +255.0C, hyst = +251.0C)
            (crit = +255.0C, hyst = +251.0C) sensor = transistor
            temp3: +36.0C (high = +255.0C, hyst = +253.0C)
            (crit = +255.0C, hyst = +253.0C) sensor = transistor

            Comment


            • #7
              Thanks a lot pheldens. This means that eventually, in a few years, lm-sensors might be able to report voltages on a P45 motherboard.

              Comment


              • #8
                phenom II dude ;p the most recent AMD cpu

                Comment

                Working...
                X