Announcement

Collapse
No announcement yet.

Catalyst 8-4 and Ubuntu 8.04

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 8-4 and Ubuntu 8.04

    Hello, I ask your help because I don't know what is the technic to install ATI Catalyst Linux Driver on Ubuntu 8.04.

    Tank you,
    Pier Luc

  • #2
    You can try envy. It's a script that dl's and installs the newest drivers from nvidia or ati. I have used it for nvidia on 7.10 and it was really quick and easy.

    Comment


    • #3
      - Download driver

      - Open a terminal and do the following:

      Code:
      sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)
      
      cd ~/<location where you saved the driver to>
      
      sudo sh ati-driver-installer-8-4-x86.x86_64.run
      
      # let the installer run
      
      cd
      
      sudo aticonfig --initial
      - Reboot
      Last edited by Melcar; 04-27-2008, 03:12 AM.

      Comment


      • #4
        Code:
        sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)
        What is the utility of this command?

        Finally, I have try to install the driver with the prprietary driver toll of Ubuntu 8.04 and it work. But, I don't know if they will update the depot when ATI will give the version 8-5 of Catalyst so it's important for me to understand the install procedure.

        Now, the driver number, I think it's 8-3, work and this is my xorg.conf.

        Code:
        # xorg.conf (X.Org X Window System server configuration file)
        #
        # This file was generated by dexconf, the Debian X Configuration tool, using
        # values from the debconf database.
        #
        # Edit this file with caution, and see the xorg.conf manual page.
        # (Type "man xorg.conf" at the shell prompt.)
        #
        # This file is automatically updated on xserver-xorg package upgrades *only*
        # if it has not been modified since the last upgrade of the xserver-xorg
        # package.
        #
        # If you have edited this file but would like it to be automatically updated
        # again, run the following command:
        #   sudo dpkg-reconfigure -phigh xserver-xorg
        
        Section "InputDevice"
        	Identifier	"Generic Keyboard"
        	Driver		"kbd"
        	Option		"XkbRules"	"xorg"
        	Option		"XkbModel"	"pc105"
        	Option		"XkbLayout"	"ca"
        EndSection
        
        Section "InputDevice"
        	Identifier	"Configured Mouse"
        	Driver		"mouse"
        	Option		"CorePointer"
        EndSection
        
        Section "Device"
        	Identifier	"Configured Video Device"
        	Driver		"fglrx"
        EndSection
        
        Section "Monitor"
        	Identifier	"Configured Monitor"
        EndSection
        
        Section "Screen"
        	Identifier	"Default Screen"
        	Monitor		"Configured Monitor"
        	Device		"Configured Video Device"
        	Defaultdepth	24
        EndSection
        
        Section "ServerLayout"
        	Identifier	"Default Layout"
          screen "Default Screen"
        EndSection
        Section "Module"
        	Load		"glx"
        EndSection

        Comment


        • #5
          If you're going to simply run the installer you most likely just need dkms and ia32-libs (if you're running 64bit). The other dependencies are for package generation, which doesn't hurt to have on your system anyways.
          fglrx hardly gets updated in the Ubuntu repositories. It will probably remain at 8.4 until the new Ubuntu comes out, unless the developers decide otherwise.

          Edit: One thing I have noticed in Hardy in relation to the drivers. In Gutsy, the Xv extension is loaded automatically (for the most part), unless you specify otherwise in xorg.conf. In Hardy it does not for some reason; you have to manually specify it in your xorg.conf, either VideoOverlay or TexturedVideo. I don't think it's a kernel issue, since this behavior was not present when I was using the 2.6.24 kernel in Gutsy. So after you do the aticonfig --initial part, you have to input an additional command:

          Code:
          sudo aticonfig overlay-type=Xv
          However, if you have a R500 card or newer (x1xxx or latter) you may want to use TexturedVideo instead. For that, open xorg.conf and add this option to the device section:

          Code:
          Option   "TexturedVideo"  "on"
          Last edited by Melcar; 04-28-2008, 06:10 PM.

          Comment


          • #6
            Question about xorg.conf:

            On sectection "screen", what is the utility of "Defaultdepth 24" ?

            And at the end of the file what is the utility
            "
            Code:
            Module"
            	Load		"glx"
            ??

            Code:
            In Gutsy, the Xv extension is loaded automatically (for the most part), unless you specify otherwise in xorg.conf. In Hardy it does not for some reason; you have to manually specify it in your xorg.conf, either VideoOverlay or TexturedVideo.
            It's a bug?

            Code:
            Option   "TexturedVideo"  "on"
            It's not automatic on aticonfig?

            Question: Is aticonfig have his owne config file?

            Is the command:
            Code:
            sudo aticonfig --initial
            Will set the xorg.conf file like the ubuntu proprietary driver installer or it will ad a lot of informations?

            Does Catalyst support RandR, does aticonfig command will set my RandR.

            Sorry for my english, I'me a Canadien of the Québec. (French speaker)

            Comment


            • #7
              The GLX extension is loaded automatically, so no need to specify it. When you perform the aticonfig --initial command, aticonfig creates entries in your xorg.conf for the driver; these new entries are duplicates of the Device, Screen, and Monitor sections, so you can safely remove the older ones. Alternatevely, you can simply change the driver paramenter under the Device section to fglrx and then add the other overlay options manually without aticonfig. Either way works. Fglrx does support xrandr as well; just type in a terminal xrandr -s [resolution you want].
              Hardy seems to have problems with non-native resolutions on LCDs. Don't know why. The driver worked fine on Gutsy, even with a custom 2.6.24 kernel. Another thing is the fonts; on Gutsy fglrx would cause the fonts to appear bigger and clearer, but in Hardy for some reason they get noticeably smaller.
              Last edited by Melcar; 04-29-2008, 10:47 AM.

              Comment


              • #8
                You guys are making it difficult, there is no XV bug, everything is using TexturedVideo now. There used to be an xv scaling issue, but thats fixed.

                Code:
                Option "TexturedVideo" "on"
                remove any other overlay crap, its deprecated.

                But really, your system should work fine without any options except Driver "fglrx" and the identifier...

                Oh, and two, you guys are kind of doing the installation wrong:
                First, to make this clean, put the run script in its own directory, cleaner organization
                Code:
                chmod +x ati-script.run
                ./ati-script.run --buildpkg Ubuntu/hardy
                dpkg -i *.deb
                m-a a-i -f fglrx-kernel-src
                For xorg.conf, you can edit it manually and set it to fglrx or try aticonfig --initial
                Last edited by damentz; 04-29-2008, 06:48 PM.

                Comment


                • #9
                  Under hardy, fglrx does not load Xv (in any form) unless I load it manually in xorg.conf. This behavior is not present in Gutsy. This has happened to all my ATI cards. I don't know why it happens, but it does.
                  The driver should automatically use either VideoOverlay or TexturedVideo depending on the card being used (according to Bridgman it's VideoOverlay for pre-AVIVO cards and TexturedVideo for newer models). I confirmed this on Gutsy; my HD2900XT would work with TexturedVideo by default, while my X200 used VideoOverlay by default (both cases without having to specify anything in xorg.conf). This is supposed to be a new functionality thought, so maybe Hardy conflicts with something.

                  Originally posted by damentz View Post
                  ...

                  Oh, and two, you guys are kind of doing the installation wrong:
                  First, to make this clean, put the run script in its own directory, cleaner organization
                  Code:
                  chmod +x ati-script.run
                  ./ati-script.run --buildpkg Ubuntu/hardy
                  dpkg -i *.deb
                  m-a a-i -f fglrx-kernel-src
                  For xorg.conf, you can edit it manually and set it to fglrx or try aticonfig --initial
                  The above method I gave works for me every time, but so does package generation for that matter. It's "cleaner" too, since all you have to worry about is /etc/ati and /usr/share/ati, and if you use that method, you can also use the uninstall script, which restores your xorg.conf to what it was previously.
                  Last edited by Melcar; 04-29-2008, 07:29 PM.

                  Comment


                  • #10
                    So, my xorg.conf can be like that:

                    Code:
                    # xorg.conf (X.Org X Window System server configuration file)
                    #
                    # This file was generated by dexconf, the Debian X Configuration tool, using
                    # values from the debconf database.
                    #
                    # Edit this file with caution, and see the xorg.conf manual page.
                    # (Type "man xorg.conf" at the shell prompt.)
                    #
                    # This file is automatically updated on xserver-xorg package upgrades *only*
                    # if it has not been modified since the last upgrade of the xserver-xorg
                    # package.
                    #
                    # If you have edited this file but would like it to be automatically updated
                    # again, run the following command:
                    #   sudo dpkg-reconfigure -phigh xserver-xorg
                    
                    Section "InputDevice"
                    	Identifier	"Generic Keyboard"
                    	Driver		"kbd"
                    	Option		"XkbRules"	"xorg"
                    	Option		"XkbModel"	"pc105"
                    	Option		"XkbLayout"	"ca"
                    EndSection
                    
                    Section "InputDevice"
                    	Identifier	"Configured Mouse"
                    	Driver		"mouse"
                    	Option		"CorePointer"
                    EndSection
                    
                    Section "Device"
                    	Identifier	"Configured Video Device"
                    	Driver		"fglrx"
                    EndSection
                    
                    Section "Monitor"
                    	Identifier	"Configured Monitor"
                    EndSection
                    
                    Section "Screen"
                    	Identifier	"Default Screen"
                    	Monitor		"Configured Monitor"
                    	Device		"Configured Video Device"
                    	Defaultdepth	24
                    EndSection
                    
                    Section "ServerLayout"
                    	Identifier	"Default Layout"
                      screen "Default Screen"
                    EndSection
                    On the screen section, why does it has this information:
                    Code:
                    	Defaultdepth	24

                    Comment

                    Working...
                    X